We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

Remote Desktop maximizing over both screens instead of one

Medium Priority
810 Views
Last Modified: 2013-11-21
Hi guys,

I have a Windows XP SP3 with 2 LCD displays which are connected to the laptop via Matrox analog dual-head connector. I am using Matrox Powerdesk SE to control the maximizing of the Windows on both screens. It is set to maximize the windows onto current screen. Everything is working fine except for remote desktop which is maximizing (meaning going to fullscreen mode) over both screens. I tried every possible setting of the Powerdesk but nothing worked.
I would like to have remote desktop maximized just on the current screen. Any ideas how to achieve this?

Thanks.
Comment
Watch Question

Irwin W.There are a 1000 ways to skin the technology cat.
CERTIFIED EXPERT

Commented:
There is no way to extend that remote display over your second local monitor.
Toni UranjekConsultant/Trainer

Commented:
Hi!
If you use RDP client 6.0 the following command should work:
"mstsc /span"

Remote Desktop Connection supports high-resolution displays that can be spanned across multiple monitors. However, the total resolution on all monitors must be under 4096 x 2048 pixels. The monitors must have the same resolution. Additionally, the monitors must be aligned side-by-side.

"Remote Desktop Connection (Terminal Services Client 6.0)"
http://support.microsoft.com/kb/925876/en-us

HTH

Toni

Commented:
I suggest to use mstsc.exe for this.

The command line parameters are described here:
http://technet.microsoft.com/en-us/library/bb490797.aspx
You can use the /w and the /h parameter to specifiy the dimension of one of your displays. If you cannot access the whole remote desktop because of the window borders and have to scroll vertical and horizontal, I suggest to use values for the /w and the /H parameter that are e. g. 50 pixels below the maximum value so that the complete remote desktop fits on one screen with its borders.
Hope that helps...
CERTIFIED EXPERT
Most Valuable Expert 2011
Top Expert 2011
Commented:
Sure there is.....

start>run>mstsc /span

Need both the target and the host ot have the same configuration though......

For your situation though....

Look in My Documents for the default.rdp file.....

Edit the following....

desktopwidth:i:1280
desktopheight:i:1024

Your width is probably at 2560 (or similar, but you get the idea..)

Then save it...

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.