Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1253
  • Last Modified:

EtherChannel from Intel Team to cisco swtch

  I am trying to create an etherchannel (LACP) on the Cisco 3560G. The entire switch is currently VLAN 1.  My question is:

When I create the etherchannel does it have to ve on a different VLAN or can it be on the flat VLAN 1?   When I try to create an ether chaqnnel on VLAN one I get PO1 (SD) - Down instaed of up when I run CLI - #show etherchannel 1 summary.

When I run show spanning-tree interface port-channel 1 I don't see any spanning trees?

 
0
Kevin Larkin
Asked:
Kevin Larkin
  • 18
  • 12
1 Solution
 
Don JohnstonInstructorCommented:
It can be either.

Can you post the config of the cisco switch?

0
 
Kevin LarkinAuthor Commented:

version 12.2
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime
service timestamps log datetime localtime
service password-encryption
!
!
!
!
errdisable recovery cause udld
errdisable recovery cause bpduguard
errdisable recovery cause security-violation
errdisable recovery cause channel-misconfig
errdisable recovery cause pagp-flap
errdisable recovery cause dtp-flap
errdisable recovery cause sfp-config-mismatch
errdisable recovery cause gbic-invalid
errdisable recovery cause l2ptguard
errdisable recovery cause psecure-violation
errdisable recovery cause dhcp-rate-limit
errdisable recovery cause unicast-flood
errdisable recovery cause vmps
errdisable recovery cause storm-control
errdisable recovery cause inline-power
errdisable recovery cause arp-inspection
errdisable recovery cause loopback
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel1
 switchport access vlan 10
 switchport mode access
!
interface GigabitEthernet0/1
 description Epicor EtherChan1
 switchport mode access
 channel-group 1 mode active
 spanning-tree portfast
!
interface GigabitEthernet0/2
 description Epicor EtherChan2
 switchport mode access
 channel-group 1 mode active
 spanning-tree portfast
!
interface GigabitEthernet0/3
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/4
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/5
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/6
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/7
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/8
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/9
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/10
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/11
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/12
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/13
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/14
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/15
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/16
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/17
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/18
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/19
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/20
 description PrimaryDc1
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet0/21
 description PrimaryDc2
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet0/22
 description BackUpDc1
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet0/23
 description BackUpDc2
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet0/24
 description EmailSRV1
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet0/25
 description EmailSRV2
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet0/26
 description FergData1
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet0/27
 description FergData2
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet0/28
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/29
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/30
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/31
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/32
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/33
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/34
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/35
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/36
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/37
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/38
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/39
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/40
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/41
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 speed 100
 spanning-tree portfast
!
interface GigabitEthernet0/42
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/43
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/44
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/45
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/46
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/47
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/48
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/49
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet0/50
 description VLAN1 Data Access
 switchport trunk encapsulation dot1q
 switchport mode trunk
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/51
 description VLAN1 Data Access for servers, PC's, Switches
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/52
 description uplink to Ferg1 Cisco Switch via cab-sfp-50cm uplink
!
interface Vlan1
0
 
Kevin LarkinAuthor Commented:
I am trying to create an etherchannel from the switch to two nic ports on a server
0
Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

 
Don JohnstonInstructorCommented:
Config looks okay to me. What does a "show ether summ" say?
0
 
Kevin LarkinAuthor Commented:
How does traffic get from VLan 1 to the new VLan 10?   All lights are green and everything looks good but I can't ping and device on VLAN1 from the server on VLAN 10.  This is all from the same switch.

Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi0/1(P)    Gi0/2(P)
0
 
Kevin LarkinAuthor Commented:
Does the EtherChannel have to be on a different VLAN than the rest of the switch?  Because I can't communicate across VLans?
0
 
Don JohnstonInstructorCommented:
Your etherchannel link is working.

Traffic between VLANs would have to be routed by either the 3560 or some other routing device.


0
 
Kevin LarkinAuthor Commented:
DO you have any idea how that type of routing is done
0
 
Don JohnstonInstructorCommented:
You would need a vlan1 interface and a vlan 10 interface defined on the 3560 with the appropriate IP addresses. Then the hosts would need to have default gateways on the vlan interfaces.

ip routing
 
int vlan 1
 ip address 192.168.1.1 255.255.255.0
 no shut
 
int vlan 10
 ip address 192.168.2.1 255.255.255.0
 no shut

Open in new window

0
 
captainmorgankCommented:
Give this link a look for how to configure a 3560 for layer 3 routing.

http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a008019e74e.shtml
0
 
Kevin LarkinAuthor Commented:
So, Does an ether channel need to be on it's own VLAN, or can it be on the default VLan 1?  This way routing will not be an issue?

0
 
Don JohnstonInstructorCommented:
It can be either. Depends on what you're trying to accomplish. In your case, if you want the server on the same broadcast domain as the hosts that are connecting to it, put the server in the same VLAN as the hosts.
0
 
Kevin LarkinAuthor Commented:
When I setup the etherchannel on VLAN1, the two ports are amber and I have no connection to anything on the switch or the network.  When I set it up on VLAN10 The ports are green but I don't have access to anything on the switch or network due to the layer3 routing.
0
 
Don JohnstonInstructorCommented:
How are you putting the etherchannel in VLAN1? What commands are you using?
0
 
Kevin LarkinAuthor Commented:
Gi0/1
Gi0/2

For Each Port I do:

Switch#conf t
Switch(config)#int Gi0/1
Switch(config-if)#switchport
Switch(config-if)#Configure the port as an access port and assign the appropriate VLAN.
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 1
Switch(config-if)#spanning-tree portfast
Switch(config-if)#channel-group 1 mode active

Then I do this once:
Switch(config)#port-channel load-balance src-mac
0
 
Kevin LarkinAuthor Commented:
Sorry, This is what Use:

Gi0/1
Gi0/2

For Each Port I do:

Switch#conf t
Switch(config)#int Gi0/1
Switch(config-if)#switchport

Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 1

Switch(config-if)#spanning-tree portfast
Switch(config-if)#channel-group 1 mode active

Then I do this once:
Switch(config)#port-channel load-balance src-mac
0
 
Don JohnstonInstructorCommented:
What I wanted was, "what commands do you use to set the vlan for the etherchannel?"

That said, the commands to change the vlan membership of an EXISTING etherchannel to vlan 1 would be:

conf t
int po 1
 switchport access vlan 1

0
 
Kevin LarkinAuthor Commented:
Not Sure.
  I did run

conf t
int po1
switchport vlan 1

But when I run show config I still see:

!
interface Port-channel1
 switchport access vlan 10
 switchport mode access
!
interface GigabitEthernet0/1
 description Epicor EtherChan1
 switchport mode access
 channel-group 1 mode active
 spanning-tree portfast
!
interface GigabitEthernet0/2
 description Epicor EtherChan2
 switchport mode access
 channel-group 1 mode active
 spanning-tree portfast
!
0
 
Don JohnstonInstructorCommented:
The command is "switchport access vlan 1"
0
 
Kevin LarkinAuthor Commented:
Sorry that was a mistype on that post.  I did do

conf t
int po 1
switchport access vlan 1

  But in show config still say's
!
interface Port-channel1
 switchport access vlan 10
 switchport mode access
0
 
Don JohnstonInstructorCommented:
Interesting.

Try:

int range po1 , g0/1 - 2
 switchport access vlan 1

and do you get any messages when you enter the commands?
0
 
Kevin LarkinAuthor Commented:
I will as soon as I get it back the way it was.  I wanted to start over so I ran:
conf t
interface range gigabitethernet0/1 -2
    no channel-group

I am trying to get the two ports back to regular switch ports on Vlan 1 and remove the channel group / port-channel1.  The two ports show up as VLan 1 but how do I delete the port-channel and start fresh.

!
interface Port-channel1
 switchport access vlan 10
 switchport mode access
!
interface GigabitEthernet0/1
 description Epicor EtherChan1
 switchport mode access
 channel-group 1 mode active
 spanning-tree portfast
!
interface GigabitEthernet0/2
 description Epicor EtherChan2
 switchport mode access
 channel-group 1 mode active
 spanning-tree portfast
But when I run config it is still listed as:
0
 
Don JohnstonInstructorCommented:
no int po1

0
 
Kevin LarkinAuthor Commented:
Command does not work, I get:

3560G-48-Ferg2(config)#no int po1
                                ^
% Invalid input detected at '^' marker.
0
 
Don JohnstonInstructorCommented:
?!?!

You can't enter a "no" command? Where is the "^" pointing?

0
 
Kevin LarkinAuthor Commented:
It is pointing at the 1,  

    It almost looks like it may have been deleted but still shows up in the show config.  NOt sure what is going on.
0
 
Don JohnstonInstructorCommented:
Does the port-channel 1 interface still exist? It may already be deleted.

From a 3550, I get:

Switch(config)#int range g0/1 - 2      
Switch(config-if-range)#no channel-group 1 mode des
Switch(config-if-range)#exit
Switch(config)#no int po1
Switch(config)#

0
 
Kevin LarkinAuthor Commented:
Everything went ok but when I tried to delete with no int po1 I get the same error pointing at the 1


0
 
Kevin LarkinAuthor Commented:
OK, I just went into the Web Interface for the switch and noticed the two ports were not active.  I activated them via the web interface then went back into telnet and ran show config again and everything looks back to were it was.  I will try to start again after lunch.

Thank you so much for your help so far.  Hopfully this new etherchannel on VLAN 1 will do the trick.  I'll let you know.
0
 
Kevin LarkinAuthor Commented:
That worked!  It must have been stuck the whole time.  One last question before I close this.  How can I verify that the throuput of this etherchannel is better than the throuput if I just had one nic to a regular port on the switch?

Kevin
0
 
Kevin LarkinAuthor Commented:
Thanks for all your help on this
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 18
  • 12
Tackle projects and never again get stuck behind a technical roadblock.
Join Now