[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1922
  • Last Modified:

Cisco Call manager Express

Hello
i have a cisco 2821 isr and im trying to get the cme gui interface working. everytime i go to my routerip/ccme.html i get a blank page. could anyone help with this.

here is my running config.


!
version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname I80_VOIP_Router2821
!
boot-start-marker
boot system flash:/c2800nm-ipvoicek9-mz.124-22.T.bin
boot-end-marker
!
logging message-counter syslog
logging buffered 4096
no logging console
enable secret 5 $1$b3hL$N9M1fHrry9HnldBy4Pxjj1
!
no aaa new-model
clock timezone CST -6
network-clock-participate wic 0
network-clock-select 1 T1 0/0/0
!
dot11 syslog
ip source-route
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.0.12.1 10.0.12.50
!
ip dhcp pool ITS
   network 10.0.12.0 255.255.255.0
   option 150 ip 10.0.12.1
   default-router 10.0.12.1
!
!
no ip domain lookup
ip domain name MAA.com
ip name-server 10.0.1.4
ip name-server 10.0.1.2
ip multicast-routing
ip sap cache-timeout 30
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-ni
!
!
voice rtp send-recv
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol pass-through g711ulaw
 modem passthrough nse codec g711ulaw
 sip
  registrar server expires max 200 min 60
!
!
voice class codec 1
 codec preference 1 g711alaw
 codec preference 2 g711ulaw
 codec preference 3 g729r8
!
voice class codec 2
 codec preference 3 g711ulaw
 codec preference 4 g729br8
 codec preference 5 g729r8
!
voice class codec 3
 codec preference 1 g729br8
 codec preference 2 g729r8
!
!
!
!
!
!
!
!
!
!
!
!
voice register pool  23
!
!
!
voice-card 0
!
!
application
 service mgcp voice
 !
 global
  service alternate DEFAULT
 !
!
!
crypto pki trustpoint TP-self-signed-2706577777
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2706577777
 revocation-check none
 rsakeypair TP-self-signed-2706577777
!
!
crypto pki certificate chain TP-self-signed-2706577777
 certificate self-signed 01
  30820253 308201BC A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32373036 35373737 3737301E 170D3039 30323035 30333230
  33375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 37303635
  37373737 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100B678 D726705D 309D80D2 12104C72 3DDB5E06 D56AE783 D3F63AEF 29E426BD
  D7184D98 FDB2D611 7EC608C2 C3C2758B 0DA89EEA 6C249FEE 5CDC6C0A 53DD6D6C
  E6050724 55FE1CC0 118665FF 6F18E822 D0CED81B D4B9E642 D8D98E1B DDF7193F
  99667A6E 2C23F744 A7DD2C55 248EE1E3 0C4ED486 29DA7926 EFA66895 E4E569E1
  47C90203 010001A3 7B307930 0F060355 1D130101 FF040530 030101FF 30260603
  551D1104 1F301D82 1B493830 5F564F49 505F526F 75746572 32383231 2E4D4141
  2E636F6D 301F0603 551D2304 18301680 147D339B C54AF712 4EA5C4CF 1815F046
  3CDC45ED F8301D06 03551D0E 04160414 7D339BC5 4AF7124E A5C4CF18 15F0463C
  DC45EDF8 300D0609 2A864886 F70D0101 04050003 818100A9 79E612DB 29346622
  03086922 19E38DBA EC4EBBF1 644DBDDD EBCDB51E 3C799E5D D068AE50 79D91050
  49699E0C 9D0A50D5 8CEB5247 3868A17B D4017B35 4FB2D632 8D32E31E CE86DD32
  BFAEEB24 6C3697E5 A49DCC6F 6A436EA0 6F2D076A F3C212E5 7ADAE88D 13A4E327
  E6A3AC6E FF1CEE6A 54B13A9E B0DFC3D9 D5F512A1 7CFA97
        quit
!
!
username admin privilege 15 secret 5 $1$BQT.$4yUyogAh9s27CXLgzabyN1
archive
 log config
  hidekeys
!
!
controller T1 0/0/0
 pri-group timeslots 1-24
!
!
!
!
!
interface Loopback0
 no ip address
!
interface GigabitEthernet0/0
 description ConnectionToLan
 ip address 10.0.5.18 255.255.255.0
 duplex auto
 speed auto
!
interface Service-Engine0/0
 ip unnumbered GigabitEthernet0/1
 service-module ip address 10.0.12.222 255.255.255.0
 service-module ip default-gateway 10.0.12.1
 vlan-id dot1q 200
  exit-vlan-config
 !
!
interface GigabitEthernet0/1
 ip address 10.0.12.1 255.255.255.0
 duplex full
 speed 100
 h323-gateway voip interface
 h323-gateway voip id 22821 ipaddr 10.0.12.222 1719
 h323-gateway voip h323-id 2821-cme-3745
 h323-gateway voip tech-prefix 1#
 h323-gateway voip bind srcaddr 10.0.12.1
!
interface Serial0/0/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
ip forward-protocol nd
ip route 10.0.12.2 255.255.255.255 Service-Engine0/0
ip route 10.0.12.222 255.255.255.255 Service-Engine0/0
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash:
!
!
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:23
!
voice-port 0/1/0
 signal groundStart
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
 signal groundStart
!
ccm-manager fallback-mgcp
ccm-manager mgcp
ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 10.0.12.1  
!
mgcp call-agent cme service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp vad
no mgcp timer receive-rtcp
mgcp fax t38 ecm
no mgcp explicit hookstate
!
mgcp profile default
!
sccp local GigabitEthernet0/1
sccp
!
!
dial-peer voice 1 pots
 destination-pattern 9.......
 clid network-number 4024083401
 port 0/0/0:23
 forward-digits 7
!
dial-peer voice 2 pots
 destination-pattern 4083401
 incoming called-number .T
 direct-inward-dial
 port 0/0/0:23
!
dial-peer voice 3 voip
 shutdown
 destination-pattern 40834..
 session target ipv4:10.0.12.222
 incoming called-number .T
 dtmf-relay rtp-nte h245-alphanumeric
 no vad
!
!
gateway
 timer receive-rtp 1200
!
!
telephony-service
 sdspfarm units 1
 sdspfarm transcode sessions 12
 sdspfarm unregister force
 em logout 0:0 0:0 0:0
 max-ephones 32
 max-dn 32
 ip source-address 10.0.12.1 port 2000
 application mgcp
 auto assign 1 to 32
 timeouts interdigit 2
 system message Mitchell Auto Auction
 url authentication http://10.0.12.222/voiceview/authentication/authenticate.do 
 voicemail 555
 max-conferences 8 gain -6
 call-forward pattern .T
 call-forward system redirecting-expanded
 web admin system name i80admin password 0
 web admin customer name cmeadmin password password
 dn-webedit
 time-webedit
 transfer-system full-consult
 transfer-pattern 9.T
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn  1  dual-line
 number 100
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  2  dual-line
 number 101
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  3  dual-line
 number 102
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  4  dual-line
 number 103
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  5  dual-line
 number 104
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  6  dual-line
 number 105
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  7  dual-line
 number 106
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  8  dual-line
 number 107
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  9  dual-line
 number 108
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  10  dual-line
 number 109
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  11  dual-line
 number 110
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  12  dual-line
 number 111
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  13  dual-line
 number 112
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  14  dual-line
 number 113
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  15  dual-line
 number 114
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  16  dual-line
 number 115
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  17  dual-line
 number 116
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  18  dual-line
 number 117
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  19  dual-line
 number 118
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  20  dual-line
 number 119
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  21  dual-line
 number 120
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  22  dual-line
 number 121
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  23  dual-line
 number 122
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  24  dual-line
 number 123
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  25  dual-line
 number 124
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  26  dual-line
 number 125
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  27  dual-line
 number 126
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  28  dual-line
 number 127
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  29  dual-line
 number 128
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  30  dual-line
 number 129
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  31  dual-line
 number 130
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone-dn  32  dual-line
 number 131
 call-forward busy 999
 call-forward noan 999 timeout 18
 application mgcp
!
!
ephone  1
 mac-address 001A.E2BC.2ED0
 type 7940
 button  1:1
!
!
!
ephone  2
 mac-address 0014.A9CA.FD2E
 type 7940
 button  1:2
!
!
!
ephone  3
 mac-address 001A.E2BC.4490
 type 7940
 button  1:3
!
!
!
ephone  4
 mac-address 001A.E2BC.0EC3
 type 7940
 button  1:4
!
!
!
ephone  5
 mac-address 001A.E2BC.4DDF
 type 7940
 button  1:5
!
!
!
ephone  6
 mac-address 001B.0C18.E047
 type 7940
 button  1:6
!
!
!
ephone  7
 mac-address 001B.0C18.209F
 type 7940
 button  1:7
!
!
!
ephone  8
 mac-address 001A.E2BC.449F
 type 7940
 button  1:8
!
!
!
ephone  9
 mac-address 0013.80C2.BF43
 username "EXT_108"
 type 7940
 button  1:9
!
!
!
ephone  10
 mac-address 001B.0C18.E07B
 type 7940
 button  1:10
!
!
!
ephone  11
 mac-address 0007.0E56.E104
 type 7940
 button  1:11
!
!
!
ephone  12
 mac-address 001A.E2BC.8D83
 type 7940
 button  1:12
!
!
!
ephone  13
 mac-address 001A.E2BC.4DD1
 type 7940
 button  1:13
!
!
!
ephone  14
 mac-address 001A.E2BC.0E14
 type 7940
 button  1:14
!
!
!
ephone  15
 mac-address 0013.606C.BE32
 type 7970
 button  1:15
!
!
!
ephone  16
 mac-address 0018.B93B.BCEA
 type 7940
 button  1:16
!
!
!
ephone  17
 mac-address 001A.E2BC.0E7F
 type 7940
 button  1:17
!
!
!
ephone  18
 mac-address 0014.A9BD.C0A8
 type 7940
 button  1:18
!
!
!
ephone  19
 mac-address 0018.B93B.BD19
 type 7940
 button  1:19
!
!
!
ephone  20
 mac-address 001A.E2BC.0F7F
 type 7940
 button  1:20
!
!
!
ephone  21
 mac-address 001A.E2BC.0B6E
 type 7940
 button  1:21
!
!
!
ephone  22
 mac-address 0016.478B.0E98
 type 7940
 button  1:22
!
!
!
ephone  23
 mac-address 001A.E22B.5DFF
 type 7940
 button  1:23
!
!
!
ephone  24
!
!
!
ephone  25
!
!
!
ephone  26
!
!
!
ephone  27
!
!
!
ephone  28
!
!
!
ephone  29
!
!
!
ephone  30
!
!
!
ephone  31
!
!
!
ephone  32
!
!
!
line con 0
 password password
 login
line aux 0
line 194
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 password password
 login
 transport input telnet
!
scheduler allocate 20000 1000
ntp server 10.0.1.4
end
0
chrisglissman
Asked:
chrisglissman
  • 9
  • 6
  • 4
1 Solution
 
lrmooreCommented:
What verson CME GUI?
Did you install the GUI files?
Can you post result of 'dir flash:"
0
 
chrisglissmanAuthor Commented:
Directory of flash:/

    1  -rw-    31547720  Dec 24 2008 17:03:06 -06:00  c2800nm-ipvoicek9-mz.124-23.bin
    2  -rw-    46993168  Jan 21 2009 01:28:36 -06:00  c2800nm-ipvoicek9-mz.124-22.T.bin

256483328 bytes total (177938432 bytes free)
I80_VOIP_Router2821#

i do not know were the gui files would be in order to install them.

i did post the dir flash.
0
 
chrisglissmanAuthor Commented:
i am running the 124-22.t.bin version.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
yegs2000Commented:
you need to get the CCME files from cisco's site.

Go here and then click the "download software" link on the side.
http://www.cisco.com/en/US/products/sw/voicesw/ps4625/index.html

Once you have the .zip file appropriate to your version of IOS you need to extract the tar file to the flash of your router, you will also need to extract the tar GUI files for the web interface.

example:
archive tar /xtract tftp://yourTFTPServerIP/cme-bacd-3.0.0.1.tar flash:    < This is the latest CME files
archive tar /xtract tftp://yourTFTPServerIP/cme-gui-7.1.0.0.tar flash:       < This is the latest GUI files
*(you can also just copy the extracted tar files from your computer to the flash card)*

Once you have done that you can issue these commands to get the GUI working.
conf t
telephony-service
web admin system name admin secret 0 <password>

then navigate to http://ip_addr_of_2811/telephony_service.html .
0
 
lrmooreCommented:
Dang, vegs2000 beat me to it!...
0
 
chrisglissmanAuthor Commented:
i am only a regiterd user on cisco site. can i download with only regiterd user access?
0
 
chrisglissmanAuthor Commented:
i will create 2 post for both of you if you can get me the files. i will even pay for them. i need them really bad. i cannot download from cisco website do to the fact i do not have a service agrement with them. any help would be great.
0
 
lrmooreCommented:
The only way to legally get the files is direct from Cisco.
Your Cisco reseller may be able to help you.
It looks from your configuration like you are a MGCP gateway/failover for Call Manager, but your voip dial-peer is shutdown? What's up?
0
 
chrisglissmanAuthor Commented:
i am still trying to get it all set up. i am will to pay someone to maybe help me over the phone for a little guide on a few things. i am also on msn chat. my email add is jon@happycab.com and my msn address is jon@advancetechomaha.com.
0
 
lrmooreCommented:
0
 
chrisglissmanAuthor Commented:
will this file work i download it from rapid share. i can post a screen print of what is inside it.

thanks
jon
0
 
chrisglissmanAuthor Commented:
sorry here is the file image

cme-124-11XW1.zip
0
 
lrmooreCommented:
I think that is for a different version of CME
>boot system flash:/c2800nm-ipvoicek9-mz.124-22.T.bin
This output shows that you are running 12.4-22T
Those files are for 12.4-11XW version of IOS that you are not running.
0
 
chrisglissmanAuthor Commented:
can i run 12.4-11 xw on a cisco 2821isr?
0
 
yegs2000Commented:
yeah, you can, but you have to get the IOS file itself and load that on first, and if you don't have access to CME files you won't have access to that.

=[
0
 
yegs2000Commented:
and you would need the c2800nm version of IOS code for the 2821
0
 
lrmooreCommented:
And it would be a downgrade from what you have.
0
 
chrisglissmanAuthor Commented:
what does the c2800nm file is that the ios image for the cisco call manager ver im running?
0
 
yegs2000Commented:
No, its the standard IOS image, and depending on the IOS version you get it determines the feature set, some feature sets include voice/ while other contain ids/firewall features etc.

0

Featured Post

New Tabletop Appliances Blow Competitors Away!

WatchGuard’s new T15, T35 and T55 tabletop UTMs provide the highest-performing security inspection in their class, allowing users at small offices, home offices and distributed enterprises to experience blazing-fast Internet speeds without sacrificing enterprise-grade security.

  • 9
  • 6
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now