Server error in '/' Application

Posted on 2009-02-11
Last Modified: 2012-05-06
When I began deploying my remote website, I encountered this error.

To solve it, I carefully granted access to the ASPNET machine account, configured IIS to consider the folder as an application, granted permission for scripts and read access to the Home Directory, etc.  I had the default.aspx page showing when the browser was launched and was even able to login.

However, I had errors when I tried to access a menu item from the default page.  To correct it, I assigned a password to the ASPNET account (b/c the db refused the connection) and tried to align my connection string with it.

Now, I'm back to the original error.  I've tried to double-check permissions, etc. but am getting no joy.  

What am I missing?

<section name="infragistics.web" type="System.Configuration.SingleTagSectionHandler,System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>



  Now that we have added the section tag, we can add the infragistics.web tag, without 

  the framework complaining.  We will specify two properties here, imageDirectory and 

  javaScriptDirectory.  Both of these properties are rooted at the current application 

  directory, specified by ~/.


  Both properties do not need to be specified.  I.E.,you can specify javaScriptDirectory, without

  specifying imageDirectory.  Also note that the property specifies the javaScriptDirectory, 

  not a specific path to a file.  All Infragistics WebElements JavaScript files should reside

  in the directory specified here.  This includes the common scriptfile (ig_csom.js).



    		<add name="SLLConnectionString" connectionString="Data Source=SLL-FILESERVER;Initial Catalog=ASPNET;UserID=ASPNET;Password=password; Integrated Security=True" providerName="System.Data.SqlClient"/>


			<add name="SLLConnectionString" connectionString="Data Source=GIBB-DEV;Initial Catalog=SLL;Integrated Security=True" providerName="System.Data.SqlClient"/>




  <infragistics.web imageDirectory="~/ig_common/images" javaScriptDirectory="~/ig_common/scripts"/>


		<roleManager enabled="true"/>

		<compilation defaultLanguage="c#" debug="false">


				<add assembly="Infragistics.WebUI.Shared.v4.3, Version=4.3.20043.61, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB"/>

				<add assembly="Infragistics.WebUI.UltraWebToolbar.v4.3, Version=4.3.20043.61, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb"/>

				<add assembly="System.Web, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

				<add assembly="System.Drawing, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

				<add assembly="System.Windows.Forms, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

				<add assembly="System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

				<add assembly="System.Xml, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

				<add assembly="System.Design, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

				<add assembly="System.Data, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

				<add assembly="Microsoft.JScript, Version=, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/></assemblies></compilation>

		<customErrors defaultRedirect="~/Errors.aspx" mode="RemoteOnly"/>

    <authentication mode="Forms">

      <forms name="SllAuth" path="/" loginUrl="slllogin.aspx" protection="All" timeout="30">

        <credentials passwordFormat="Clear">

          <user name="Glen" password="babyCat#1" />





      <allow users="*" />


		<profile enabled="true">


				<add name="SLL_UserName"/>

				<add name="FirstName"/>

				<add name="LastName"/>

				<add name="Address"/>

				<add name="City"/>

				<add name="PostalCode"/>

				<add name="Country"/>

				<add name="Phone"/>

				<add name="Fax"/>

				<add name="Mailings" type="System.Boolean"/>

				<add name="Email"/>

				<add name="Theme"/>

				<add name="Cart" serializeAs="Binary" type="SLL.Commerce.ShoppingCart" allowAnonymous="true"/>



		<trace enabled="false" requestLimit="10" pageOutput="false" traceMode="SortByTime" localOnly="true"/>

		<sessionState mode="InProc" stateConnectionString="tcpip=" sqlConnectionString="data source=;user id=sa;password=" cookieless="false" timeout="20"/>

		<globalization requestEncoding="utf-8" responseEncoding="utf-8"/>



Open in new window

Question by:Glen Gibb
    LVL 16

    Accepted Solution

    Try and see what is the exact error message shown. You could set the the customErrors mode="Off" in web.config and see this.

    Author Closing Comment

    by:Glen Gibb
    Looking at the exact error enabled me to solve the problem.  Tnx

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    What Is Threat Intelligence?

    Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

    Suggested Solutions

    Foreword (May 2015) This web page has appeared at Google.  It's definitely worth considering! How to Know You are Making a Difference at EE In August, 2013, one …
    New Relic: Our company recently started researching several products to figure out what were the best ways for us to increase our web page speed and to quickly identify performance problems that we may be having. One of the products we evaluated wa…
    This video teaches users how to migrate an existing Wordpress website to a new domain.
    Learn how to set-up custom confirmation messages to users who complete your Wufoo form. Include inputs from fields in your form, webpage redirects, and more with Wufoo’s confirmation options.

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    15 Experts available now in Live!

    Get 1:1 Help Now