RWW not working from outside the network

Hi guys,

Strange thing.. all my users work with laptops. We all have the ability to work from home but this seems to be a luxury that will soon be taken away as well as taking laptops home. Sooo... I decided to test the RWW tool and once logged on select the "connect to client desktops" option and it doesnt work. I can connect to the servers just fine but not my machine or a workstation I have here. I have in system properties to allow remote desktop (which seems to be greyed out anyway) checked and my username as one of the remote users allowed.

Also, I have tried this from within the network and was able to connect without any issues when within the LAN.

Any suggestions?
sbodnarAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
suppsawsConnect With a Mentor Commented:
as for rww, you know you need to open port 443 and 4125 ??
http://sbs.editme.com/Remoteaccess
0
 
acromentCommented:
I would re-run the configure firewall option and make sure that the appropriate items are checked for "allow access to".

You can find that within the internet group in the Server Management console.

-Eric
0
 
Hypercat (Deb)Commented:
Another problem that can cause this behavior is if something else on the server is using port 4125.  You might want to check that out to be sure:
http://support.microsoft.com/kb/886209 
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
Hypercat (Deb)Commented:
If none of our comments resolve your issue, please post a more detailed description of what happens when you try to connect. Include the text of any error message that appears when you try to connect, or any event log errors that you can see related to this.
0
 
sbodnarAuthor Commented:
suppsaws:

I checked and port 443 and 4125 are open for RWW and HTTP. I also opened up port 4125 for HTTPS Management.
0
 
sbodnarAuthor Commented:
hypercat:

How can I check if something else is using port 4125 on the server?
0
 
suppsawsCommented:
btw, how did you join these computers to the domain?
did you do this the correct way through http://server/connectcomputer?
there will normally not be another program that is using that port, I've never seen this before actually.
This will be a firewall policy problem because of the computers not joined correctly to the sbs domain, my first guess.
btw also test this while antivirus/firewall program disabled on the client, because that could also be blocking the connection.
0
 
Hypercat (Deb)Commented:
The article that I posted walks you through the steps for checking whether that port is in use.
0
 
sbodnarAuthor Commented:
Yes I did connect it correctly via the http://server/connectcomputer.  I have my windows firewall locally turned off. When I look into the exceptions tab of the firewall settings everything seems to be grayed out and I cant modify anything?????
0
 
suppsawsCommented:
"I have my windows firewall locally turned off'  > that is already a sign that there are manual configs on the sbs server.
Normally you cannot turn of the windows firewall, because it is controlled bu the SBS firewall group policy.
So I guess you disabled the firewall policy on the sbs GP management?

Then rerun the connect to the internet wizard.
0
 
sbodnarAuthor Commented:
I did disable the GPO so that I could mess with the firewall settings to make sure it wasnt the issue.
0
 
sbodnarAuthor Commented:
I can access my servers but not workstations
error1.JPG
0
 
Hypercat (Deb)Commented:
sbodnar, have you tested using a remote desktop connection to one of the computers from within the network?  I'm just thinking we need to narrow this down to see if remote desktop connections work at all.  This will help us determine if it is a local firewall or a local or domain setting/permissions issue, or if it really does have something to do with the RWW configuration. I'm thinking it's more likely something locally on the workstation, or some problem with the domain-level group policies or permissions, rather than an RWW connection issue, because you can connect to the servers without a problem.
0
 
Hypercat (Deb)Commented:
OOPS - sorry, I missed the part of your OP where you said that you can connect from within the LAN, so please disregard my last post.
0
 
suppsawsCommented:
did you try temporary diabling the SBS firewall policy, and disable the local firewall on a client?
disable antivirus soft also and do an external test.
0
 
sbodnarAuthor Commented:
I have disabled the local firewall policy. The SBS firewall policy I do not see one under my GPO's.

I have tried connecting to my servers also and I was under the assumption that I was able to connect to them but just like the laptops I cant connect to them either??? Very strange....

If I connect via a vpn connection I can ping all my machines just fine though... I am sooo stumped!!
0
 
Hypercat (Deb)Commented:
If you connect through a VPN connection, can you then RDP to workstations and servers?  I would assume so, since you can do this when you are on the network.
Have you tried re-running the CEICW?  I would recommend that, make sure you select not to change your email settings, and then go through the website setup again, including RWW. If that doesn't fix it, then try turning off the SBS group policy that controls remote access.  Then manually go to a workstation, checking the remote desktop settings and remote desktop users group membership and test again.
Did you ever get around to checking on the server to make sure nothing else is using port 4125?
0
All Courses

From novice to tech pro — start learning today.