• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 973
  • Last Modified:

Visual Studio hangs when deploying cube

Hello All,

I'm having an issue with an Analysis Services project in Visual Studio 2005. My project always builds but only occasionally deploys.  No errors are reported and VS just hangs.  This is my first Analysis Services project so I am hoping that there is something obvious that I am just missing.

Here is the situation I have a cube that I have successfully deployed.

I then make some change, e.g., adding a hierarchy to a dimension.  When I try to deploy again VS hangs.  I have to restart Analysis Services to regain control of VS so I can shut it down.  I restart everything sometimes once, sometimes twice or more before the project will eventually deploy.  This happens with any change I make there seems to be no pattern to this behaviour.  

Sometimes I have to delete the cube from Analysis Services before restarting everything to get a successful deploy.  

Also I have successfully deployed the cube, and then subsequently successfully reprocessed a dimension then when I open a query window in SQL Server Management Studio it says that it can find any cubes.

As a test I have deployed a cube successfully.  I have then deleted it in Analysis Services and attempted to redeploy it, without making any changes to the cube, only to have the same behaviour mentioned above.

VS just hangs with no reason so I have no idea where to start hunting down the problem.

It is taking 15-20 minutes to make a change as simple as setting the NameColumn of a dimension attribute.  As you can imagine this is taking hours of my time so I would greatly appreciate any assistance anyone can give me.

0
NewOLAPUser
Asked:
NewOLAPUser
  • 4
  • 2
  • 2
1 Solution
 
srnarCommented:
I can recommend you working in online with Analysis Services from Visual Studio (File/Open Analysis Database). The project mode (or offline mode) is used rarely - e.g. for deployment - you can later create a new project from an existing cube (Fie/New project/BI studio projects/Import AS 9.0 database).
Also check wheter you have latest service pack (SP3 from December) on your analysis services server.
0
 
NewOLAPUserAuthor Commented:
Hi srnar,

Thanks for your reply.  Unfortunately your recommendation didn't solve the problem.  VS still hangs when using it in online mode.

I am at the moment building a new machine and will  just install SQL Server 2005 on it and nothing else to see if maybe that there is something wrong with the machine that I am using.

I am at a complete loss.  I spend 4 hours this morning trying to deploy a cube which I was able to deploy yesterday.

I have the latest service packs for everything.

If I find a solution i'll post it here

Thanks again
0
 
srnarCommented:
It is weird. You can also check Sql server profiler and connect to your analysis server to see what is going on. You may detect that some security problems. Also try to edit cube directly on the server - if you have remote desktop - this way you exclude problems on your developer machine.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
NewOLAPUserAuthor Commented:
Hi srnar,

The problem seems to be with my development machine.  As mentioned above I built a new test machine and everything seems to be working fine on it.  I have made many changes and deployed many times.

I re-installed SQLServer on my development machine and the situation just got worse.

Anyway just wanted to let you know a solution was found and to thank you for your time.
0
 
PedroCGDCommented:
Install acumulative package 9 or SP3 of SQL Server.
Regards,
Pedro
0
 
NewOLAPUserAuthor Commented:
Problem solved
0
 
PedroCGDCommented:
and solution was?
0
 
NewOLAPUserAuthor Commented:
The solution was to re-install my operating system and SQL Server.

This problem occurred only on my development machine.  I built a new test machine, installed SQL Server 2005 and everything worked correctly.

I then tried to re-install SQL Server on my development machine and the situation only got worse.

I was under extreme time pressure to find a solution. So re-installed windows and then SQL Server on my development machine and everything has been working perfectly since.

I'm guessing something went wrong during the installation of SQL Server.  I have many disk images going back over 2 years and the problem existed on all of them.

Excuse my last post above I was trying to close the question.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now