We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now


How do you uninstall a previous version of GLIB?

Abarros22 asked
Medium Priority
Last Modified: 2013-12-06
I'm trying to install syslog-ng and I've run into a problem when compiling the source. Here is the message that I receive:

checking for GLIB - version >= 2.10.1...
*** 'pkg-config --modversion glib-2.0' returned 2.18.4, but GLIB (2.6.4)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error: Cannot find GLIB version >= 2.10.1: is pkg-config in path?

How do I uninstall the previous version of GLIB?
Watch Question

Maciej Ssysadmin

May I ask, why don't use package (for both - syslog-ng and glib)?
If you want to install syslog-ng, you should probably run: yum install syslog-ng and I think this will be all you need.
My suggestion (I had in the past similar problems of slotted versions of libs) is to remove all the instances of glib and the reinstall the lastest



Thank you for your comments. However, oklit, I tried doing a yum install and I received the following message:
Setting up Install Process
Setting up repositories
Cannot find a valid baseurl for repo: updates-released

Also, ai_ja_nai, if I uninstall the first original version I receive the following messages:


[root@pptp1 syslog-ng-3.0.1]# rpm -e glib-1.2.10-16
error: Failed dependencies:
        libglib-1.2.so.0 is needed by (installed) ORBit-0.5.17-15.i386
        libglib-1.2.so.0 is needed by (installed) oaf-0.6.10-12.i386
        libglib-1.2.so.0 is needed by (installed) g-wrap-1.3.4-8.i386
        libglib-1.2.so.0 is needed by (installed) gtk+-1.2.10-39.i386
        libglib-1.2.so.0 is needed by (installed) GConf-1.0.9-16.i386
        libglib-1.2.so.0 is needed by (installed) libgal23-0.24-6.i386
        libglib-1.2.so.0 is needed by (installed) gdk-pixbuf-0.22.0-18.i386
        libglib-1.2.so.0 is needed by (installed) imlib-1.9.13-24.i386
        libglib-1.2.so.0 is needed by (installed) gnome-libs-
        libglib-1.2.so.0 is needed by (installed) gdk-pixbuf-gnome-0.22.0-18.i386
        libglib-1.2.so.0 is needed by (installed) libglade-0.17-16.i386
        libglib-1.2.so.0 is needed by (installed) libgnomeprint15-0.37-11.i386
        libglib-1.2.so.0 is needed by (installed) gnome-print-0.37-11.i386
        libglib-1.2.so.0 is needed by (installed) gtkhtml-1.1.9-11.i386
        libglib-1.2.so.0 is needed by (installed) gnucash-1.8.11-3.i386
        libglib-1.2.so.0 is needed by (installed) gtk-engines-0.12-7.i386
        libglib-1.2.so.0 is needed by (installed) netdump-server-0.7.7-6.i386
        libglib-1.2.so.0 is needed by (installed) xdelta-1.1.3-16.i386
        libglib-1.2.so.0 is needed by (installed) libdv-tools-0.103-4.i386
        libglib-1.2.so.0 is needed by (installed) ORBit-devel-0.5.17-15.i386
        libglib-1.2.so.0 is needed by (installed) usbview-1.0-13.i386
        libglib-1.2.so.0 is needed by (installed) xferstats-2.16-13.i386
        libglib-1.2.so.0 is needed by (installed) cdicconf-0.2-11.i386
        libglib-1.2.so.0 is needed by (installed) gnucash-backend-postgres-1.8.11-3.i386
        libgmodule-1.2.so.0 is needed by (installed) oaf-0.6.10-12.i386
        libgmodule-1.2.so.0 is needed by (installed) gtk+-1.2.10-39.i386
        libgmodule-1.2.so.0 is needed by (installed) GConf-1.0.9-16.i386
        libgmodule-1.2.so.0 is needed by (installed) libgal23-0.24-6.i386
        libgmodule-1.2.so.0 is needed by (installed) gdk-pixbuf-0.22.0-18.i386
        libgmodule-1.2.so.0 is needed by (installed) imlib-1.9.13-24.i386
        libgmodule-1.2.so.0 is needed by (installed) gnome-libs-
        libgmodule-1.2.so.0 is needed by (installed) gdk-pixbuf-gnome-0.22.0-18.i386
        libgmodule-1.2.so.0 is needed by (installed) libglade-0.17-16.i386
        libgmodule-1.2.so.0 is needed by (installed) libgnomeprint15-0.37-11.i386
        libgmodule-1.2.so.0 is needed by (installed) gnome-print-0.37-11.i386
        libgmodule-1.2.so.0 is needed by (installed) gtkhtml-1.1.9-11.i386
        libgmodule-1.2.so.0 is needed by (installed) gnucash-1.8.11-3.i386
        libgmodule-1.2.so.0 is needed by (installed) gtk-engines-0.12-7.i386
        libgmodule-1.2.so.0 is needed by (installed) libdv-tools-0.103-4.i386
        libgmodule-1.2.so.0 is needed by (installed) ORBit-devel-0.5.17-15.i386
        libgmodule-1.2.so.0 is needed by (installed) usbview-1.0-13.i386
        libgmodule-1.2.so.0 is needed by (installed) xferstats-2.16-13.i386
        libgmodule-1.2.so.0 is needed by (installed) cdicconf-0.2-11.i386
        glib >= 1:1.2.10 is needed by (installed) gtk+-1.2.10-39.i386
        glib >= 1:1.2.0 is needed by (installed) GConf-1.0.9-16.i386
        glib = 1:1.2.10 is needed by (installed) glib-devel-1.2.10-16.i386

If I force the removal, and then reinstall the latest version will these dependencies be restored???

>Cannot find a valid baseurl for repo: updates-released
You have the URLs commented in /etc/yum.repos.d. Remove the comment sign to enable those.

>If I force the removal, and then reinstall the latest version will these dependencies be restored???
I don't know, in the sense that if the new version breaks the retrocompatibility ALL those programs will stop working. Otherwise, the new version mantains it, those programs will never ever be even aware of what happened.
Now, since you are trrying to pass from 1.2 to 2.10 I would bet that some major change will occurr :/

Generally, when this happens to me I take note of the complaining programs, remove them, remove the old lib, install the new lib and reinstall the removed programs.

But are you sure you still have such a old lib? I'd investigate on the sentence "pkg-config --modversion glib-2.0' returned 2.18.4"



I will remove the comments in the file and try the yum install. If that doesn't work, then I will probably try removing the first original lib. Lastly, yes I still do have the old lib. When I do a "make uninstall" for the new lib, and then try doing a "./configure" for syslog-ng for the installation I receive the following message:

checking whether to enable PCRE support... yes
checking for pkg-config... (cached) /usr/local/bin/pkg-config
checking pkg-config is at least version 0.14... yes
checking for GLIB - version >= 2.10.1... no
configure: error: Cannot find GLIB version >= 2.10.1: is pkg-config in path?

You'll notice that this is different than the message I originally posted above. Please let me know your thoughts.
Usually, makefiles provide good hints on possible causes

configure: error: Cannot find GLIB version >= 2.10.1: is pkg-config in path?

Is it? That's all I can think right now

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts



I decided to install a previous version of syslog-ng and it worked. Thanks for helping out earlier.

Wait a moment. This question was not about syslog-ng troubles, was about removing glibc. And we provided the how to (at 23622327 and at 23624083).
So, it would be fair assigning points, not for the time we dedicated, but because that particular issue was about to fix before you gave up
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.


Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.