We help IT Professionals succeed at work.

Exchange hotfix 911829 to allow Vista to connect to OWA will not intall

Medium Priority
816 Views
Last Modified: 2012-06-27
I have attempted to install hotfix 911829 and it tells me it cannot install because Exhange 2003 doesnt have SP2 installed. Yet when I check the properties on the server it tells me I have Exchange 6.5 Build 7638.2: Service Pack 2. I have senior execs wanting to connect to OWA remotely and they cannot.

Is anyone able to assist?
Comment
Watch Question

Expert of the Quarter 2009
Expert of the Year 2009

Commented:
Reapply the service pack, and then run Microsoft Update. It will download whatever updates are required.

-M

Author

Commented:
I did reapply the service pack and it errored saying it could not instal the Exchange part but it di update the other bits.

David

Author

Commented:
Btw I have run MS update and applied all available updates which do not include any for Exchange.

David
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
The service pack erroring is a concern. What exactly did it say?

Are you sure that you ran Microsoft Update and not Windows Update?

-M
Nitin GuptaSolutions & Presales
CERTIFIED EXPERT

Commented:
Hi,
Run ExBPA on Exchange server and see if it throws up anything interesting for you to act upon
Thanks
Nitin

Author

Commented:
M,

I'll check the event log to see if I can find the error.

Yes I did use Microsoft update.

Nitin,

I'm running BPA in Health Check scan at the moment and I'll get back when its done.

David

Author

Commented:
Error message from the event log:
Exchange Server component Microsoft Exchange failed.
Error: 0xc007007e - The specified module could not be found.

For more information, click http://www.microsoft.com/contentredirect.asp.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Author

Commented:
Excerpts from the Exchange Server Setup.log
[08:45:24]  CCompExchangeRoot::ScGetPIDAndSaveToRegistry (f:\tisp2\admin\src\udog\exsetdata\components\exroot\compexroot.cxx:451)
           Error code 0XC007007E (126): The specified module could not be found.
[08:45:24] Leaving CCompExchangeRoot::ScGetPIDAndSaveToRegistry
[08:45:24]  CCompExchangeRoot::ScSetup (f:\tisp2\admin\src\udog\exsetdata\components\exroot\compexroot.cxx:231)
           Error code 0XC007007E (126): The specified module could not be found.
[08:45:24] Leaving CCompExchangeRoot::ScSetup
[08:45:24]  CComExchSetupComponent::Install (f:\tisp2\admin\src\udog\bo\comboifaces.cxx:829)
           Error code 0XC007007E (126): The specified module could not be found.
[08:45:24] Entering ScQueueWatsonErrorReport
[08:45:33] Leaving ScQueueWatsonErrorReport
[08:45:33] About to remove EUSER_EXSTOREEVENT account
[08:45:33] Failed to remove EUSER_EXSTOREEVENT account - continuing
[08:45:33] === IGNORING PREVIOUS ERRORS === CComExchSetupComponent::Install (f:\tisp2\admin\src\udog\bo\comboifaces.cxx:770)
           The operation has completed successfully.

[08:58:57]  CCompExchangeRoot::ScGetPIDAndSaveToRegistry (f:\tisp2\admin\src\udog\exsetdata\components\exroot\compexroot.cxx:451)
           Error code 0XC007007E (126): The specified module could not be found.
[08:58:57] Leaving CCompExchangeRoot::ScGetPIDAndSaveToRegistry
[08:58:57]  CCompExchangeRoot::ScSetup (f:\tisp2\admin\src\udog\exsetdata\components\exroot\compexroot.cxx:231)
           Error code 0XC007007E (126): The specified module could not be found.
[08:58:57] Leaving CCompExchangeRoot::ScSetup
[08:58:57]  CComExchSetupComponent::Install (f:\tisp2\admin\src\udog\bo\comboifaces.cxx:829)
           Error code 0XC007007E (126): The specified module could not be found.
[08:58:57] Entering ScQueueWatsonErrorReport
[08:58:59] Leaving ScQueueWatsonErrorReport
[08:58:59] About to remove EUSER_EXSTOREEVENT account
[08:58:59] Failed to remove EUSER_EXSTOREEVENT account - continuing
[08:58:59] === IGNORING PREVIOUS ERRORS === CComExchSetupComponent::Install (f:\tisp2\admin\src\udog\bo\comboifaces.cxx:770)
           The operation has completed successfully.

Not sure if any of this will help.

David
Jeffrey Kane - TechSoEasyPrincipal Consultant
CERTIFIED EXPERT
Most Valuable Expert 2016
Top Expert 2014

Commented:
Are Small Business Server 2003 SP1 and Windows Server 2003 SP2 installed on this machine yet?

Jeff
TechSoEasy

Author

Commented:
SBS - no
Win server 2003 Standard Edition SP2 - yes

David
Jeffrey Kane - TechSoEasyPrincipal Consultant
CERTIFIED EXPERT
Most Valuable Expert 2016
Top Expert 2014

Commented:
If you haven't installed SBS's SP1 then you will have problems, including the fact that it won't support Vista clients.  (Plus your server is now in an unsupported status).

Please see http://sbsurl.com/sp1 for details on installing it.  If you haven't already installed Exchange 2003 SP2 you can do that instead of Exchange 2003 SP1 as described in that article.

Jeff
TechSoEasy

Author

Commented:
Jeff,

I am not running SBS at all and never have. I have Exchange Server 2003 standard edition on Windows Server 2003.

Properties on the Mail server in Exchange System Manager tell me I have SP2 installed.

David
Jeffrey Kane - TechSoEasyPrincipal Consultant
CERTIFIED EXPERT
Most Valuable Expert 2016
Top Expert 2014

Commented:
Sorry, since you linked this to the other question I just assumed... I shouldn't have done that.  :-)

Anyhow... you posted a few lines from the Exchange install log... but what are the lines just above where you started?  ie, right before [08:45:24] ?

Because the errors are referring to whatever it says before them.

Jeff
TechSoEasy

Author

Commented:
Thanks Jeff,
Could not connect to the E-E site yesterday for some weird reason. Excerpt from the log follows:
[08:45:24] Beginning Update of Microsoft Exchange component -- ID:62208 --
[08:45:24] Entering CBaseComponent::ScPrepareForFileCopy
[08:45:24] Leaving CBaseComponent::ScPrepareForFileCopy
[08:45:24] Entering CBaseComponent::ScAddFilesToQueue
[08:45:24] Leaving CBaseComponent::ScAddFilesToQueue
[08:45:24] Completed Update of Microsoft Exchange component -- ID:62209 --
[08:45:24] Entering CCompRoot::ScOnSuccessfulSetup
[08:45:24] Leaving CCompRoot::ScOnSuccessfulSetup
[08:45:24] Leaving CBaseComponent::ScSetup
[08:45:24] Entering CCompRoot::ScOnSuccessfulSetup
[08:45:24] Leaving CCompRoot::ScOnSuccessfulSetup
[08:45:24] Leaving CCompRoot::ScSetup
[08:45:24] Setup is adding the PID to the registry
[08:45:24] Entering CCompExchangeRoot::ScGetPIDAndSaveToRegistry
[08:45:24] About to LoadLibrary and call into PidGen.dll to generate the PID.
[08:45:24] Calling LoadLibrary on PidGen.dll.
[08:45:24] Failed to LoadLibrary the PidGen module.
[08:45:24]  CCompExchangeRoot::ScGetPIDAndSaveToRegistry (f:\tisp2\admin\src\udog\exsetdata\components\exroot\compexroot.cxx:451)
           Error code 0XC007007E (126): The specified module could not be found.

Hope this gives you some clues.

Cheers
David

Author

Commented:
And the 8:58 error sequence is as follows (PIDGEN failure again I think):
[08:58:57] Beginning Update of Microsoft Exchange component -- ID:62208 --
[08:58:57] Entering CBaseComponent::ScPrepareForFileCopy
[08:58:57] Leaving CBaseComponent::ScPrepareForFileCopy
[08:58:57] Entering CBaseComponent::ScAddFilesToQueue
[08:58:57] Leaving CBaseComponent::ScAddFilesToQueue
[08:58:57] Completed Update of Microsoft Exchange component -- ID:62209 --
[08:58:57] Entering CCompRoot::ScOnSuccessfulSetup
[08:58:57] Leaving CCompRoot::ScOnSuccessfulSetup
[08:58:57] Leaving CBaseComponent::ScSetup
[08:58:57] Entering CCompRoot::ScOnSuccessfulSetup
[08:58:57] Leaving CCompRoot::ScOnSuccessfulSetup
[08:58:57] Leaving CCompRoot::ScSetup
[08:58:57] Setup is adding the PID to the registry
[08:58:57] Entering CCompExchangeRoot::ScGetPIDAndSaveToRegistry
[08:58:57] About to LoadLibrary and call into PidGen.dll to generate the PID.
[08:58:57] Calling LoadLibrary on PidGen.dll.
[08:58:57] Failed to LoadLibrary the PidGen module.
[08:58:57]  CCompExchangeRoot::ScGetPIDAndSaveToRegistry (f:\tisp2\admin\src\udog\exsetdata\components\exroot\compexroot.cxx:451)
           Error code 0XC007007E (126): The specified module could not be found.
[08:58:57] Leaving CCompExchangeRoot::ScGetPIDAndSaveToRegistry
[08:58:57]  CCompExchangeRoot::ScSetup (f:\tisp2\admin\src\udog\exsetdata\components\exroot\compexroot.cxx:231)
           Error code 0XC007007E (126): The specified module could not be found.
[08:58:57] Leaving CCompExchangeRoot::ScSetup
[08:58:57]  CComExchSetupComponent::Install (f:\tisp2\admin\src\udog\bo\comboifaces.cxx:829)
           Error code 0XC007007E (126): The specified module could not be found.
[08:58:57] Entering ScQueueWatsonErrorReport
[08:58:59] Leaving ScQueueWatsonErrorReport
[08:58:59] About to remove EUSER_EXSTOREEVENT account
[08:58:59] Failed to remove EUSER_EXSTOREEVENT account - continuing
[08:58:59] === IGNORING PREVIOUS ERRORS === CComExchSetupComponent::Install (f:\tisp2\admin\src\udog\bo\comboifaces.cxx:770)
           The operation has completed successfully.

David
Principal Consultant
CERTIFIED EXPERT
Most Valuable Expert 2016
Top Expert 2014
Commented:
Okay, that helps... please see this forum post for how someone else resloved this issue:
http://episteme.arstechnica.com/eve/forums/a/tpc/f/12009443/m/256009519731?r=906008819731#906008819731

Jeff
TechSoEasy

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Thanks Jeff,
That makes a lot of sense and I'll redo SP2 following the instructions on the page you listed and let you know how I get on.

Cheers
David

Author

Commented:
Many thanks for that reference Jeff,
Its all run like a dream and I got 7 exchange security updates as soon as I had finished reapplying SP2 as outlined. I have also applied 911829 successfully.

Cant thank you enough ;-)
David
Jeffrey Kane - TechSoEasyPrincipal Consultant
CERTIFIED EXPERT
Most Valuable Expert 2016
Top Expert 2014

Commented:
No problem.  Glad to help.

Jeff
TechSoEasy
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.