We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

Vpn stopped working

huntleyj
huntleyj asked
on
Medium Priority
1,007 Views
Last Modified: 2012-05-06
Site to Site VPN to my parent company's exchange server has been working for months then I get a call saying that no one can connect to the exchange server tonight.

I log into my Cisco 5505 and start the log and see errors when the tunnel tries to connect.
1)    3      Feb 11 2009      21:39:10      713048                   IP = 142.176.xxx.xxx, Error processing payload: Payload ID: 1
2)   3      Feb 11 2009      21:39:10      713902                   IP = 142.176.xxx.xxx, Removing peer from peer table failed, no match!
and
3)   4      Feb 11 2009      21:39:10      713903                   IP = 142.176.87.114, Error: Unable to remove PeerTblEntry


I have  no idea whats going on and I cant get in touch with the admin of the exchange server to see if he knows anything as to why

Attached is my running config. anyone see anything wrong?
Result of the command: "show running-config"
 
: Saved
:
ASA Version 8.0(3)6 
!
hostname ciscoasa
domain-name company.ca
enable password rB1zdBSeYOLPaxEO encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.113.15 PGWEB description Web Server
name 10.2.0.0 Exchange
name 192.168.113.243 Honeywell description Building Maintenance system
name 192.168.113.4 InterfaceProcessor
name 192.168.113.239 RemoteV1 description Remote V1 PC
name 192.168.113.240 TelecostPC description Call Accounting PC
name 192.168.113.1 PGServer1 description SQL server
name 192.168.113.242 CaptureDVR description Capture DVR
name 192.168.113.241 PanasonicDVR description Panasonic DVR
name 24.222.206.154 Verb description Verb to SQL
name 142.176.164.68 tricon
name 142.176.79.235 CSH
name 76.11.114.81 Phil
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.113.2 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 142.176.xxx.xxx 255.255.255.240 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone AST -4
clock summer-time ADT recurring
dns server-group DefaultDNS
 domain-name company.ca
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group network DM_INLINE_NETWORK_1
 network-object host Verb
 network-object host tricon
 network-object host CSH
 network-object host Phil
object-group service DM_INLINE_TCP_1 tcp
 port-object eq ftp
 port-object eq ftp-data
access-list outside_1_cryptomap extended permit ip any Exchange 255.255.0.0 
access-list outside_access_in extended permit tcp any interface outside eq www 
access-list outside_access_in extended permit tcp any interface outside eq https 
access-list outside_access_in remark Remote Desktop connection to PGWEB
access-list outside_access_in extended permit tcp any interface outside eq 3389 
access-list outside_access_in remark SQL access
access-list outside_access_in extended permit tcp object-group DM_INLINE_NETWORK_1 interface outside eq 1433 
access-list outside_access_in remark PCAnywhere access to Interface Processor
access-list outside_access_in extended permit tcp any interface outside eq pcanywhere-data 
access-list outside_access_in remark PCAnywhere to Interface Processor
access-list outside_access_in extended permit tcp any interface outside eq 5632 
access-list outside_access_in remark Telecost VNC
access-list outside_access_in extended permit tcp any interface outside eq 5800 
access-list outside_access_in remark Maintenance VNC
access-list outside_access_in extended permit tcp any interface outside eq 5900 
access-list outside_access_in remark Remote V1 VNC
access-list outside_access_in extended permit tcp any interface outside eq 5901 
access-list outside_access_in remark Panasonic DVR access
access-list outside_access_in extended permit tcp any interface outside eq 87 
access-list outside_access_in remark Capture DVR access
access-list outside_access_in extended permit tcp any interface outside eq 88 
access-list outside_access_in extended permit tcp any interface outside object-group DM_INLINE_TCP_1 
access-list inside_nat0_outbound extended permit ip any Exchange 255.255.0.0 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-602.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface www PGWEB www netmask 255.255.255.255  dns 
static (inside,outside) tcp interface https PGWEB https netmask 255.255.255.255  dns 
static (inside,outside) tcp interface 3389 PGWEB 3389 netmask 255.255.255.255 
static (inside,outside) udp interface www PGWEB www netmask 255.255.255.255  dns 
static (inside,outside) tcp interface 1433 PGServer1 1433 netmask 255.255.255.255 
static (inside,outside) tcp interface pcanywhere-data InterfaceProcessor pcanywhere-data netmask 255.255.255.255 
static (inside,outside) tcp interface 5632 InterfaceProcessor 5632 netmask 255.255.255.255 
static (inside,outside) tcp interface 5800 TelecostPC 5800 netmask 255.255.255.255 
static (inside,outside) tcp interface 5900 Honeywell 5900 netmask 255.255.255.255 
static (inside,outside) tcp interface 5901 RemoteV1 5901 netmask 255.255.255.255 
static (inside,outside) tcp interface 87 PanasonicDVR 87 netmask 255.255.255.255 
static (inside,outside) tcp interface 88 CaptureDVR 88 netmask 255.255.255.255 
static (inside,outside) tcp interface ftp PGWEB ftp netmask 255.255.255.255  dns 
static (inside,outside) tcp interface ftp-data PGWEB ftp-data netmask 255.255.255.255  dns 
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 142.176.xxx.xxx 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.113.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set peer 142.176.xxx.xxx 
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 5
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 10
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.113.3-192.168.113.254 inside
dhcpd dns 142.177.1.2 142.177.129.11 interface inside
!
 
threat-detection basic-threat
threat-detection scanning-threat shun
threat-detection statistics
tunnel-group 142.176.xxx.xxx type ipsec-l2l
tunnel-group 142.176.xxx.xxx ipsec-attributes
 pre-shared-key *
 isakmp keepalive threshold 300 retry 7
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:9b2a842c37feabcfc728f73a944904c0
: end

Open in new window

Comment
Watch Question

Commented:
pretty sure it has nothing to do with the exchange server on the site of the tunnel.
the tunnel just broke for some reason.

If none of the config has change, i would suspect there has been a change on the internet address (142.176.87.114)

double check the internet address at both sides if it's still valid.

Commented:
try tearing down the tunnel and re-establishing it..

clear crypto ipsec sa

then send a ping over the network

Author

Commented:
no the IP is correct, just checked at another site, using a watchguard FW, and they are up. It seems to be only this one site affected.
Looked through the ADSM at the "top 10 access rules" and when i click on the exchange and say "show rule" I get         Internal Error: Unable to find Access Rule
WTH??

Author

Commented:
keep in mind I'm semi new to the cisco

Commented:
pretty weird,
if tunnel should either be both up or down at both sides.

try clear ipsec at both ends:
clear crypto ipsec sa peer x.x.x.x (internet address), This way, it  will not break any other site 2 site tunnels.

Commented:
yes, this is what i recommended in  my previous post...

i was assuming he would be running the command from the site thats down.

Commented:
Also are you sure nothing changed?

Do you have a backup to compare to?

If  you are sure nothing has changed, (and have already tried the clear cryto stuff form above) try

wr me


to recompile the ACL's.

Author

Commented:
I tried the
clear crypto ipsec sa
that theoaks sugeested. no go
Currently looking for a backup. found one for my 1841 router but no luck yet on the 5505.
Will try the wr me shortly.
I was at home when the vpn went down, watching Duke v UNC, so I'm fairly certain nothing has changed

Author

Commented:
wr me
had no effect
Try to reload it. if it still does not work, upgrade to ver 8.0(4). There is a well know bug on ASA about VPN tunnel. I have couples customers having same issue.

Author

Commented:
Sorry I dont see ver 8.0(4) anywhere
Commented:
I really dont know what happened but now it's back up!?! I'm at a loss. It had to have been on the head office side. I was googling and when I went back it was up!
 
Thanks to all of you

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.