• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2998
  • Last Modified:

When contacting https://mail.domain.com/autodiscover/autodiscover.xml received the 401: Unautherized error

I replaced the exchange 2007 self signed certificate with a commercial one and all services work fine.[ owa, Outlook Anywhere, active sync etc]. Modified all EWS services to use the new certificate as per the TechNet article http://support.microsoft.com/kb/940726 to fix the certificate warning error and Outlook 2007 works OK too.
Issue is when I use test-outlookwebservice cmdlet it gives the error  bellow.
Id      : 1013
Type    : Error
Message : When contacting https://access.siemens.com.au/autodiscover/autodiscover.xml received the  error The remote server returned an error: (401) Unauthorized.
If I change URIs back to server name it can contact the .xml file but get the certificate error. What is causing this?
Thanks , jayaj1
0
jayaj1
Asked:
jayaj1
1 Solution
 
KaffiendCommented:
See the following:
http://www.exchange-genie.com/2007/07/401-error-when-attempting-test-outlookwebservices/
http://support.microsoft.com/?id=896861

It will always fail, unless you disable loopback checking (which should only be done for testing and re-enabled afterward)
0
 
jayaj1Author Commented:
Thanks for your response. When I disabled loop back checking I was able to run the test-outlookwebservices command and enabled it afterwards.
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now