We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

Citrix Xen Farm Web Login

FrontlineTech
on
Medium Priority
1,878 Views
Last Modified: 2012-08-13
A former co-worker set up a Citrix Xen farm for one of our clients.  This was to replace an older version of Citrix.  All is working well, however, when the users log in to the Web version of the Farm through Citrix Secure Gateway, in the Applications folder, they see a shortcut for every application they have permission to use.   The client does not like seeing all these shortcuts... they JUST want to see the shortcut to launch the Citrix Desktop and then launch the apps through the Desktop.   I am sure this is something easy, but I can't seem to figure out how to remove the shortcuts.  Any suggestions?
Comment
Watch Question

Carl WebsterCitrix Technology Professional - Fellow
CERTIFIED EXPERT
Most Valuable Expert 2019
Top Expert 2010

Commented:
In the properties for each published app, check the box to disable the app or remove the users from each app.  Either way, the icon will "disappear" from the web interface.  Then they will see only the published desktop icon.

Author

Commented:
Our old farm we could just remove the user, but on this version if we do it, they can no longer access the program through the Desktop feature.    

How do you disable the app... I do not see that as a feature in the Citrix Access Management console for Xen Farm.
Carl WebsterCitrix Technology Professional - Fellow
CERTIFIED EXPERT
Most Valuable Expert 2019
Top Expert 2010

Commented:
I am redoing my XenApp lab to answer another question right now but it is a checkbox on one of the property pages for a published app.

Author

Commented:
Unless I am going to the wrong place, it doesn't seem to be working...

I removed the users and Xen App automatically disabled the app.  At that point, it disappeared from the Applications page on the Web Interface.  When I logged into the Desktop, the App was NOT on the Start menu nor on the Desktop.    The users have no way to access it.

If I just right-click and disable, the apps still show up on the web interface application page.   If I set it to anonymous users, same thing regardless if its enabled or disabled.
Carl WebsterCitrix Technology Professional - Fellow
CERTIFIED EXPERT
Most Valuable Expert 2019
Top Expert 2010

Commented:
Login as admin

Create desktop shortcuts for all the apps the users need

Move those icons to the All Users\Desktop folder

Change the permissions on the icons so everyone has access

User will now have the icons when the login to the published desktop

Author

Commented:
I tried that and it did not work... those icons do NOT show up... in fact there are other icons in the all users desktop folder with everyone access that do not show up either.    

This is Presentation Server 4.5 according to the Admin Manual that was in the Folder Documentation... not sure if maybe this is a different version than you originally thought and if that makes a difference.  Under the access management console, the farm is named Xen Farm.  

Sorry as I said, i did not set it up.
Carl WebsterCitrix Technology Professional - Fellow
CERTIFIED EXPERT
Most Valuable Expert 2019
Top Expert 2010
Commented:
Anything in the All Users\Desktop folder should show up for all users.  If they don't have permissions to the icons, the icons still show but they have a funny look to them and nothing happens when you double-click them.

If the icons have everyone in the permissions and they are not showing up then you have other issues.  It doesn't matter the version of Windows or XenApp/Presentation Server.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Ok I have this resolved.   Apparently, some older scripting software the client uses is why the All Users/Desktop that Carl Suggested would not work.   I found this fix...


http://www.thomaskoetzing.de/index.php?option=com_content&task=view&id=56&Itemid=96 

Which basically replaces the global.asax file on the IIS part of Web interface and then has you modify the CONF file to pick what you want hidden.  Not the way I wanted to go, but it will work for this particular client.  

Thanks for your help Carl...
Carl WebsterCitrix Technology Professional - Fellow
CERTIFIED EXPERT
Most Valuable Expert 2019
Top Expert 2010

Commented:
So no points for the help? :)
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.