[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

VPN Connection behind ASA 5505

Posted on 2009-02-12
4
Medium Priority
?
772 Views
Last Modified: 2012-05-06
I am using Cisco's VPN client to VPN into state owned VPN equipment.  I was able to use the VPN correctly before adding a Cisco ASA 5505 and Windows SBS 2008.  Now the connection gets made, but none of the applicaitons will launch.  I see the following error in the system logs on the ASA and I cannot launch the needed applications over the VPN.

translation creation failed for protocol 50 src inside:192.168.1.103 dst outside:XXX.XX.XX.X

Thanks for any insight you can give me.  I did add the crypto isakmp nat-traversal  20 thinking that would resolve the issue, but didn't.

Result of the command: "show running config"

Result of the command: "show running-config"

: Saved
:
ASA Version 7.2(4)
!
hostname ciscoasa
domain-name xxxxxxxxxx.com
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute
!
interface Vlan3
 shutdown
 nameif dmz
 security-level 50
 ip address dhcp
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name jtengineering.com
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group service CompanyWebAccess tcp
 description External secure Companyweb access
 port-object eq 987
access-list inside_nat0_outbound extended permit ip any 192.168.50.0 255.255.255.224
access-list outside_access_in remark SMTP Port 25
access-list outside_access_in extended permit tcp any host 192.168.1.2 eq smtp
access-list outside_access_in remark RWW and OWA
access-list outside_access_in extended permit tcp any host 192.168.1.2 eq https
access-list outside_access_in remark External secure Companyweb access
access-list outside_access_in extended permit tcp any host 192.168.1.2 eq 987
access-list outside_access_in remark PPTP (VPN)
access-list outside_access_in extended permit tcp any host 192.168.1.1 eq pptp
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool VPNpool 192.168.50.1-192.168.50.30 mask 255.255.255.0
no failover
monitor-interface inside
monitor-interface outside
monitor-interface dmz
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface smtp 192.168.1.2 smtp netmask 255.255.255.255
static (inside,outside) tcp interface https 192.168.1.2 https netmask 255.255.255.255
static (inside,outside) tcp interface 987 192.168.1.2 987 netmask 255.255.255.255
static (inside,outside) tcp interface pptp 192.168.1.1 pptp netmask 255.255.255.255
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs group1
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.2-192.168.1.33 inside
!
dhcprelay server 192.168.1.5 inside

group-policy VPNgroup internal
group-policy VPNgroup attributes
 dns-server value 192.168.1.2
 vpn-tunnel-protocol IPSec
group-policy vpngroup internal
group-policy vpngroup attributes
 dns-server value 192.168.1.2
 vpn-tunnel-protocol IPSec
username amplitel password Bu3OwTYaJv/0C2MR encrypted privilege 0
username amplitel attributes
 vpn-group-policy VPNgroup
tunnel-group VPNgroup type ipsec-ra
tunnel-group VPNgroup general-attributes
 address-pool VPNpool
 default-group-policy VPNgroup
tunnel-group VPNgroup ipsec-attributes
 pre-shared-key *
tunnel-group vpngroup type ipsec-ra
tunnel-group vpngroup general-attributes
 address-pool VPNpool
 default-group-policy vpngroup
tunnel-group vpngroup ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:acd77682990d9b87d4a7da162d6bf28f
: end
0
Comment
Question by:lahma35
  • 2
3 Comments
 
LVL 15

Accepted Solution

by:
bignewf earned 2000 total points
ID: 23629249
Your access-lists for port forwarding have incorrect syntax
This is the correct syntax for NAT using port-forwarding with the corresponding access-lists

the ip addresses below are for example only.

access-list outside_access_in extended permit tcp any interface outside eq 3389
static (inside,outside) tcp interface 3389 192.168.1.10 3389 netmask 255.255.255.255
access-group outside_access_in in interface outside

try using these first although these commands control traffic from outside-in to the services i.e smtp, http, ftp, etc

Also, this could be causing issues:

static (inside,outside) tcp interface pptp 192.168.1.1 pptp netmask 255.255.255.255

Also,  Why are you port forwarding pptp?

you want to use ipsec with cisco clients and asa
0
 
LVL 1

Author Comment

by:lahma35
ID: 23631944
The port forwarding is for the SBS 2008, and I thought something was wrong with that.  Thank you for correcting it.  I just opened all ports for the SBS and didn't realize Ihad added pptp to the CLI until now.
I found out from the network administrator at the VPN connection site that I needed to open a few ports up.  I am looking for the CLI to open the following ports...any help would be greatly appriciated.

TCP : 10000
UDP: 4500
UDP: 500
ESP Traffic
0
 
LVL 15

Assisted Solution

by:bignewf
bignewf earned 2000 total points
ID: 23641047
just substitue the above ports in the commands I gave you if you are doing port forwarding
and remember, esp is a protocol, not a tcp or udp port

the above ports allow nat-traversal on IPSEC tunnels


here is a quick reference on the above
http://technet.microsoft.com/en-us/library/cc779912.aspx


also, create a link for this:
http://en.wikipedia.org/wiki/List_of_TCP_and_UDP_port_numbers

this is a great reference for firewall ports

0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I've written this article to illustrate how we can implement a Dynamic Multipoint VPN (DMVPN) with both hub and spokes having a dynamically assigned non-broadcast multiple-access (NBMA) network IP (public IP). Here is the basic setup of DMVPN Pha…
Let’s list some of the technologies that enable smooth teleworking. 
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses
Course of the Month19 days, 10 hours left to enroll

872 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question