• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 450
  • Last Modified:

Visual Studio debug problem

Hello,

I'm running Visual Studio 2005.

When I try to run my local web application (ASP.NET/VB), through VS (Debug menu), it seems that I can't get my login page to do anything. The javascript isn't being executed, so I just click on my button and nothing happens.

If I run the application outside of Visual Studio, by starting a browser and going to the location, it works fine.

Any ideas?

Thanks in advance,

Steve
0
skbohler
Asked:
skbohler
  • 7
  • 5
1 Solution
 
Bob LearnedCommented:
"If I run the application outside of Visual Studio"
Is your web site running from IIS or the internal development server?
0
 
skbohlerAuthor Commented:
IIS.
0
 
Sachintana DissanayakeSenior Web DeveloperCommented:
It seems that Debugger user does not have to your project folder/scripts folder.
Please grant access full permission to Debugger user group.

Your browser might does not recognize your web site as trusted when you debug it from visual studio.
What is your operating system and browser?
0
Microsoft Certification Exam 74-409

VeeamĀ® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
skbohlerAuthor Commented:
Hello,

What is the user that the debugger uses?

I'm on Windows Vista using Internet Explorer.

Thanks,

Steve
0
 
Sachintana DissanayakeSenior Web DeveloperCommented:
Can you check whether your web site is trusted from your browser?
0
 
skbohlerAuthor Commented:
Would I check for localhost?
0
 
Sachintana DissanayakeSenior Web DeveloperCommented:
What the browser zone (Local Intranet, Internet or Trusted Zone) when you open your web page from vs debug mode?

Go to Tools --> Internet Options and select Security tab in IE 7.
Then select proper zone (one of the zones above) from and go to Custom Level... option.

Select low level security setting, ie. you have to allow to execute all javascripts.



IE-security-settings.jpg
0
 
skbohlerAuthor Commented:
Sachintana:

Thanks. It's the Local-Intranet zone. I set it to low. However, it didn't help anything.

Steve
0
 
Sachintana DissanayakeSenior Web DeveloperCommented:
Other option would be navigate to go to your web page from the browser.
Attach the IIS worker process (www) from VS.
   From Debug menu, Attach to Process and select the worker process from the list.

You can add breakpoints in your code and have fun:)
0
 
skbohlerAuthor Commented:
What is the IIS worker process I need to attach?

Thanks!

Steve
0
 
Sachintana DissanayakeSenior Web DeveloperCommented:
Attach yoour IIS worker process by selecting proper w3wp.exe process (see attachment).
If you have multiple, you need to select correct worker processor to debug.
AttachProcess.jpg
0
 
skbohlerAuthor Commented:
That seems to be a work-around for now.

It's not ideal and not a long-term solution, but it gets me doing some debugging.

Thanks,

Steve
0
 
skbohlerAuthor Commented:
Ultimate solution not found, but temporary work-around solution is all I can work with for now.
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

  • 7
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now