We help IT Professionals succeed at work.

Can't upgrade Blackberry Curve OS

jasondimaio
jasondimaio asked
on
Medium Priority
562 Views
Last Modified: 2012-06-27
I have a Blackberry 8310 from AT&T.  It's running v4.2.2.170.  I have a BES, running 4.1.6.9.

This morning, I downloaded Blackberry Desktop Manager 4.7, and installed it to my XP workstation.  I then rebooted, as prompted.  

I've also downloaded from AT&T, the 4.5.0.152 OS, and ran that executable.

According to other instructions here, I then went to C:\Program Files\Common Files\Research in Motion\AppLoader and got rid of Vendor.xml.  I then connected my Blackberry while opening Desktop Manager.  I selected Application Loader.  At no point have I been prompted to Upgrade the OS, nor do I see any place to make this happen, and I am stumped on how to do this.  Any help?
Comment
Watch Question

CERTIFIED EXPERT

Commented:
First, talk to your BES administrator and be sure that there is not a policy limitation in place that prevents you from doing this.

When I upgraded the OS on my curve, I had it connected to the computer already, and then ran the 4.5 executable. During the execution of that application, it connected to the BB and did the upgrade.

Author

Commented:
I am the sole source of IT for my company.  However, I inherited the BES.  I'm a wiz at adding or removing accounts, not so much at anything beyond that.  Can you tell me how to check to see if there is a limitation, and how to remove it?

Commented:
Follow these directions.  There is no limitation, if you have a curve you can but 4.5 on it.

http://blackberrysync.com/2008/09/how-to-upgrade-your-blackberry-os/

Author

Commented:
jdera, compare the steps that are in the link that you posted to the steps that I said I took, and tell me which one I'm missing.  It seems to me that that's exactly what I did.

Commented:
How many times have you tried to do this, when you look at the bb device about info, does it show that it was upgraded to 4.5?  If not then it did not upgrade start from step 1 and go thru it again.  Also check that you actually have a good usb cable.

Author

Commented:
I've tried to do this no fewer than 3 times.  That's including uninstalling and reinstalling the OS image, and the desktop manager software, both 4.6 and 4.7.  My USB cable works fine, as I can access and manipulate storage data, as well as the Desktop Manager recognizing the device when plugged into the USB cable.

Commented:
Well one suggestion, is go back to DM version 4.3 and try that.  This version works no issues.

Commented:
Verify you are not already on that version on your handheld. Just a thought :)

I would delete my vendor.xml and device.xml file, close down desktop manager, then open it up again. This helps.

Author

Commented:
I have verified my current version many, many times.  I may have found the stumbling block on the BES in the IT policy.  I'm goofing around with that now.

Commented:
How did this turn out?
I never was able to make it happen, and moved on to more pressing work.  Sorry I didn't close this.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.