Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

VMWare & Ubuntu - USB problems

Posted on 2009-02-12
6
Medium Priority
?
1,250 Views
Last Modified: 2013-11-15
VMWare 1.0.6 (build-91891) with Ubuntu 8.04 (64bit) host doesn't recognize USB memory stick or SDCard.  I have two different versions of 32bit XP as the client hosts in VMWare.  Both have the appropriate settings for USB connection (USB controller: present: "The USB Controller is enabled".  But when I power on either version of XP, & go to VM -> Removable Devices -> USB devices, it only says "empty".  No USB devices recognized.  It does this whether the USB device is mounted in the host Ubuntu OS or not.

Sound & Video actually work ok, this is the last step before I conclude that Ubuntu+VMWare can run any software and do anything a pure windows setup can do plus some.  :)
0
Comment
Question by:sweetde23
  • 3
  • 2
6 Comments
 
LVL 14

Assisted Solution

by:Fabio Marzocca
Fabio Marzocca earned 200 total points
ID: 23626588
I suppose you are talking about VMWare Server.
To get usb correctly detected, install the new VMWare Server 2. It is available as Open Source to download from VmWare sit here: http://www.vmware.com/freedownload/login.php?product=server20
0
 
LVL 1

Author Comment

by:sweetde23
ID: 23626809
Thanks for the comment fmarzocca, but...

I used this guide to install both my host and clients:
http://ubuntuforums.org/showthread.php?t=779934

And here's an excerpt: "Warning : I find VMWare Server 2.0 RC1 to be buggy, more then I would expect for a RC."

Since I've tried unsuccessfully to use vmware with previous (& later) versions of Ubuntu, and since I've had problems installing new versions of software, then going back & trying to use old ones, I'm a little hesitant to try this 2.0.  

Can you point me to a guide of someone who's used 8.04 and VMW 2.0?
0
 
LVL 3

Accepted Solution

by:
ht-docs earned 1800 total points
ID: 23626980
Here is the description and workaround
https://bugs.launchpad.net/ubuntu/+bug/157843

I can offer another way, if you use USB only for storage devices:
since usb storage devices mount successfully in ubuntu host, in guest OS you can use shared folders or map a network drive to a USB device mountpoint and get access to your storage via vmware network
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 14

Expert Comment

by:Fabio Marzocca
ID: 23627240
sweetde23: I am using succesfully VMWare Server 2 with Hardy since several months with no problems at all. You don't need a guide to install it, it is very straightforward. It has a nice installer which provides compilation of needed modules, then just open the browser and point to https://127.0.0.1:8333/ui/#

0
 
LVL 1

Author Comment

by:sweetde23
ID: 23637458
Thanks for the comments guys.  I will try these out as soon as I get back home.
0
 
LVL 1

Author Closing Comment

by:sweetde23
ID: 31546295
Thanks for the help!  The link ht-docs provided had a link to https://bugs.launchpad.net/ubuntu/+source/qemu/+bug/156085, which entirely solved the problem.  I will eventually upgrade to 2.0, so thanks also to fmarzocca.  :)
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When converting a physical machine to a virtual machine using VMware vCenter Converter Standalone or vCenter Converter Enterprise, if an adapter type is not selected during the initial customization the resulting virtual machine may contain an IDE d…
Fine Tune your automatic Updates for Ubuntu / Debian
This video shows you how easy it is to boot from ISO images for virtual machines with the ISO images stored on a local datastore on the ESXi host.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses

572 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question