[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 859
  • Last Modified:

Excel will not print for some users after migration from a Windows 2003 print server to 2008

I have a select few uses who can't print from Excel after we migrated to a Windows Server 2008 Core printer server. All other applictions work just fine. This happens with a HP Laserjet 4240, Xerox 4500 and a Konica Minolta Color Bizhub 450.

I have tried about every possible print driver for each of these. I have tried new user profiles. Deleted Office Application Data from All Users. I have tried different printer quality settings within the drivers and on the printers. I have tried to copy and paste into new files. I have tried to mess with fonts and reinstalling fonts.

Some PC's can print these same Excel spreadsheets with no issues. The PC's that have no issues are using the same office update and the are all XP SP2.

I have no idea where to go from here.
0
MMHDU
Asked:
MMHDU
  • 3
  • 2
1 Solution
 
weellioCommented:
what happens when you try to print?
errors? nothing?
does it matter who is trying to print? can the same people print from different computers?

same version of excel? sp?
0
 
MMHDUAuthor Commented:
Sometimes when they try to print, the printer acts like it is going to start for a second and then it stops.
No errors at all.
It seems to be related to the PC and the user account.
The same people can print from other PC's.
Same Service Pack, same version of Excel.
0
 
weellioCommented:
it isn't the user account if the people can print on other machines (assuming roaming profiles)

are there any errors in the even logs?
eventvwr.msc

0
 
MMHDUAuthor Commented:
Ok,

The clients show nothing in their event logs, but I filtered the logs on the Server 2008 Core Print Server and I found this in the logs:
Log Name:      System
Source:        Microsoft-Windows-PrintSpooler
Date:          2/18/2009 7:46:03 AM
Event ID:      6161
Task Category: None
Level:         Error
Keywords:      Classic
User:          MINSTER\snappr
Computer:      MinsterPS.MINSTER.COM
Description:
The document 600399.XLS, owned by SnappR, failed to print on printer IS01_LJ. Try to print the document again, or restart the print spooler.
Data type: NT EMF 1.008. Size of the spool file in bytes: 1093092. Number of bytes printed: 117391. Total number of pages in the document: 1. Number of pages printed: 0. Client computer: \\172.16.40.87. Win32 error code returned by the print processor: 87. The parameter is incorrect.

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-PrintSpooler" Guid="{e4c60dfa-ecc5-4889-b406-e9ddd38463c8}" EventSourceName="Print" />
    <EventID Qualifiers="49152">6161</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2009-02-18T12:46:03.000Z" />
    <EventRecordID>4542</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>System</Channel>
    <Computer>MinsterPS.MINSTER.COM</Computer>
    <Security UserID="S-1-5-21-2110855865-1834110326-1341851483-2739" />
  </System>
  <EventData>
    <Data Name="param1">600399.XLS</Data>
    <Data Name="param2">SnappR</Data>
    <Data Name="param3">IS01_LJ</Data>
    <Data Name="param4">NT EMF 1.008</Data>
    <Data Name="param5">1093092</Data>
    <Data Name="param6">117391</Data>
    <Data Name="param7">1</Data>
    <Data Name="param8">0</Data>
    <Data Name="param9">\\172.16.40.87</Data>
    <Data Name="param10">87</Data>
    <Data Name="param11">The parameter is incorrect.
</Data>
  </EventData>
</Event>
0
 
MMHDUAuthor Commented:
I found that unticking the advanced printing option fix this issue. I just stumbled on this and tried it out. The issue id resolved.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now