[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

how do i  up grading the IOS on a cisco 2960 switch, it doesnt seem to be like the older switch i have worked on

Posted on 2009-02-12
5
Medium Priority
?
5,621 Views
Last Modified: 2012-05-06
i have a 2960 switch, and i am trying to upgrade the image from c2960-lanbase-mz.122-35.SE5
to this c2960-lanbasek9-mz.122-25.SEE4.bin which i downloaded from Cisco's web site.

first i TFTP'ed the this file c2960-lanbasek9-mz.122-25.SEE4.bin to the switch
then entered the command "bootflash c2960-lanbasek9-mz.122-25.SEE4.bin" when i reloaded the switch
it booted to its old image.

then i noticed the old firmware was here not in the root.

flash:c2960-lanbase-mz.122-35.SE5/c2960-lanbase-mz.122-35.SE5.bin

so i put the new image in to here as well by using the following commands

cd c2960-lanbase-mz.122-35.SE5
copy tftp flash


then i entered the boot flash command again
bootflash c2960-lanbasek9-mz.122-25.SEE4.bin

this time the switch reloaded with the new IOS, but i can not get HTTP Access tot he switch anymore.

i think i have put the new IOS in the wrong place? what should i have done not to loose the http server? and how can i get it back?

any help is much appreciated. thanks in advance.

the config is below but, i have had to remove all the security stuff
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco_2960
!
enable secret xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
!
username xxxxxx password xxxxxxxxxxxxxxx
no aaa new-model
system mtu routing 1500
vtp domain xxxxxxxxxxxxxxxxx
vtp mode transparent
ip subnet-zero
!
ip domain-name xxxxxxxxxxxxxxx
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
 switchport mode access
 spanning-tree portfast
!
 
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 ip address 10.169.13.128 255.255.255.0
 no ip route-cache
!
ip default-gateway 10.169.13.250
ip http server
no cdp run
 
!
control-plane
!
banner login  C
 
 
!
line con 0
 exec-timeout 0 0
 logging synchronous
 login local
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 login local
line vty 5 15
 exec-timeout 0 0
 logging synchronous
 login local
!
end

Open in new window

0
Comment
Question by:CraigShag
5 Comments
 
LVL 3

Expert Comment

by:yegs2000
ID: 23628228
not exactly sure what you did.

if the image is on the TFTP server just go into the switch and type copy tftp: flash: IOSIMAGENAME

the go into global configuaration mode > conf t
the do boot system flash:IOSIMAGENAME
e.g. boot system flash:c2960-lanbasek9-mz.122-25.SEE4.bin

as far as the http server make sure you issue the command:
ip http server
or
ip http secure server (if you want SSL)

also, enable local authentication by typing
aaa new-model
username <username> password 0 <password>
0
 
LVL 3

Expert Comment

by:yegs2000
ID: 23628244
sorry,
for copying from tftp to flash just type:
copy tftp: flash:
and it will walk you through the rest (assuming you have connectivity to the tftp server)
0
 
LVL 23

Expert Comment

by:Mysidia
ID: 23628767
Type  show bootvar
show run | inc boot

Find the current line that shows the current boot image...

dir /v flash:

Update the same line as existing, to use the new filename.

Normally on a 29xx  running IOS the command is not 'bootflash'
but
'boot system flash:<FILENAME>'
0
 
LVL 10

Accepted Solution

by:
ampranti earned 2000 total points
ID: 23645114
Try to  erase flas and then upload the IOS you want to boot.
Use the commands:

# erase flash
... mpla mpla....
conf t
boot system flash
<remove all other "boot flash" commands>
exit
wr
reload

If your IOS come in tar package, use "archive" command
archive download-sw tftp://<path> flash:

This way you will have only one IOS to teh flash, and cisco will be "forced" to boot from that one.
0
 
LVL 8

Expert Comment

by:bsohn417
ID: 24369689
Cisco 2960 is fixed IOS switch, There no upgrades.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I see many questions here on Experts Exchange regarding switch port configurations and trunks. This article is meant for beginners in the subject to help to get basic knowledge about Virtual Local Area Network (VLAN (http://en.wikipedia.org/wiki/Vir…
This article will show how Aten was able to supply easy management and control for Artear's video walls and wide range display configurations of their newsroom.
this video summaries big data hadoop online training demo (http://onlineitguru.com/big-data-hadoop-online-training-placement.html) , and covers basics in big data hadoop .
As many of you are aware about Scanpst.exe utility which is owned by Microsoft itself to repair inaccessible or damaged PST files, but the question is do you really think Scanpst.exe is capable to repair all sorts of PST related corruption issues?
Suggested Courses
Course of the Month19 days, 10 hours left to enroll

872 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question