?
Solved

ASA 5520 VPN client cannot ping inside network

Posted on 2009-02-12
10
Medium Priority
?
1,662 Views
Last Modified: 2012-05-06
My VPN client can connect and get an IP, but after that it cannot ping anything on the inside (WEB) interface.

Here is the config on the ASA:
firewall> ena
Username: insure
Password: ************
firewall# show run
: Saved
:
ASA Version 7.0(8)
!
hostname firewall
domain-name e-server.local
enable password HOPjv9GTT6nZu6Eq encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
dns-guard
!
interface GigabitEthernet0/0
 nameif OUTSIDE
 security-level 0
 ip address 10.10.10.225 255.255.255.0
!
interface GigabitEthernet0/1
 nameif WEB
 security-level 100
 ip address 192.168.1.5 255.255.255.0
!
interface GigabitEthernet0/2
 nameif LAN2
 security-level 50
 ip address 178.10.1.20 255.255.0.0
!
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 78.1.100.253 255.255.255.240
 management-only
!
ftp mode passive
clock timezone GST 4
dns domain-lookup OUTSIDE
dns name-server 212.72.1.186
dns name-server 212.72.23.4
object-group service WEB-POLICY tcp
 port-object eq www
 port-object eq https
access-list LAN2_access_in extended permit tcp any host 178.10.1.21 object-group
WEB-POLICY
access-list LAN2_access_in extended deny icmp any any
access-list OUTSIDE_access_in extended permit tcp any host 10.10.10.226 object-g
roup WEB-POLICY
access-list OUTSIDE_access_in extended deny icmp any any
access-list WEB_nat0_outbound extended permit ip any 192.168.1.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu OUTSIDE 1500
mtu WEB 1500
mtu LAN2 1500
mtu management 1500
ip local pool vpnpool 192.168.1.100-192.168.1.150 mask 255.255.255.0
no failover
asdm image disk0:/asdm-508.bin
no asdm history enable
arp timeout 14400
global (OUTSIDE) 200 interface
global (WEB) 200 10.10.10.227 netmask 255.255.255.0
nat (WEB) 0 access-list WEB_nat0_outbound
static (WEB,OUTSIDE) 10.10.10.226 192.168.1.30 netmask 255.255.255.255
static (WEB,LAN2) 178.10.1.21 192.168.1.30 netmask 255.255.255.255
access-group OUTSIDE_access_in in interface OUTSIDE
access-group LAN2_access_in in interface LAN2
route OUTSIDE 0.0.0.0 0.0.0.0 10.10.10.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
group-policy e-serverVPN internal
username adsLAN2 password gyRTMOmJntv4L.9x encrypted privilege 5
username insurance password Se0O6UlsQzPYENoX encrypted privilege 0
username insurance attributes
 vpn-group-policy e-serverVPN
 webvpn
username insure password exW5L6cIqJp1bUa7 encrypted privilege 15
aaa authentication enable console LOCAL
aaa authentication telnet console LOCAL
aaa authorization command LOCAL
http server enable
http 78.1.100.240 255.255.255.240 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map OUTSIDE_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map OUTSIDE_dyn_map 20 set security-association lifetime seconds
28800
crypto dynamic-map OUTSIDE_dyn_map 20 set security-association lifetime kilobyte
s 4608000
crypto map OUTSIDE_map 65535 ipsec-isakmp dynamic OUTSIDE_dyn_map
crypto map OUTSIDE_map interface OUTSIDE
isakmp enable OUTSIDE
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
tunnel-group e-serverVPN type ipsec-ra
tunnel-group e-serverVPN general-attributes
 address-pool vpnpool
 default-group-policy e-serverVPN
tunnel-group e-serverVPN ipsec-attributes
 pre-shared-key *
tunnel-group-map default-group e-serverVPN
telnet 178.10.0.0 255.255.0.0 LAN2
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 78.1.100.254-78.1.100.254 management
dhcpd lease 3600
dhcpd ping_timeout 50
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect dns maximum-length 512
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
ssl encryption 3des-sha1 des-sha1
privilege cmd level 3 mode exec command perfmon
privilege cmd level 3 mode exec command ping
privilege cmd level 3 mode exec command who
privilege cmd level 3 mode exec command logging
privilege cmd level 3 mode exec command failover
privilege cmd level 3 mode exec command vpn-sessiondb
privilege show level 5 mode exec command running-config
privilege show level 3 mode exec command reload
privilege show level 3 mode exec command mode
privilege show level 3 mode exec command firewall
privilege show level 3 mode exec command interface
privilege show level 3 mode exec command clock
privilege show level 3 mode exec command dns-hosts
privilege show level 3 mode exec command access-list
privilege show level 3 mode exec command logging
privilege show level 3 mode exec command ip
privilege show level 3 mode exec command failover
privilege show level 3 mode exec command asdm
privilege show level 3 mode exec command arp
privilege show level 3 mode exec command route
privilege show level 3 mode exec command ospf
privilege show level 3 mode exec command aaa-server
privilege show level 3 mode exec command aaa
privilege show level 3 mode exec command crypto
privilege show level 3 mode exec command vpn-sessiondb
privilege show level 3 mode exec command ssh
privilege show level 3 mode exec command dhcpd
privilege show level 3 mode exec command vpn
privilege show level 3 mode exec command blocks
privilege show level 3 mode exec command uauth
privilege show level 3 mode configure command interface
privilege show level 3 mode configure command clock
privilege show level 3 mode configure command access-list
privilege show level 3 mode configure command logging
privilege show level 3 mode configure command ip
privilege show level 3 mode configure command failover
privilege show level 5 mode configure command asdm
privilege show level 3 mode configure command arp
privilege show level 3 mode configure command route
privilege show level 3 mode configure command aaa-server
privilege show level 3 mode configure command aaa
privilege show level 3 mode configure command crypto
privilege show level 3 mode configure command vpn-sessiondb
privilege show level 3 mode configure command ssh
privilege show level 3 mode configure command dhcpd
privilege show level 5 mode configure command privilege
privilege clear level 3 mode exec command dns-hosts
privilege clear level 3 mode exec command logging
privilege clear level 3 mode exec command arp
privilege clear level 3 mode exec command aaa-server
privilege clear level 3 mode exec command crypto
privilege cmd level 3 mode configure command failover
privilege clear level 3 mode configure command logging
privilege clear level 3 mode configure command arp
privilege clear level 3 mode configure command crypto
privilege clear level 3 mode configure command aaa-server
Cryptochecksum:03b18ce6474109b3f7e2e076342e9f00
: end

Open in new window

0
Comment
Question by:rabih_saleh
  • 3
  • 3
  • 2
  • +1
9 Comments
 
LVL 81

Expert Comment

by:arnold
ID: 23633010
I think you need to add "inspect icmp" to your ASA policy configuration.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 23639020
Your IP pool for the vpn clients needs to be a different IP subnet than the inside LAN
You are also using 192.168.1.0 subnet on the inside and perhaps your home LAN is also 192.168.1.0 ?
0
 

Author Comment

by:rabih_saleh
ID: 23639262
yes correct so do u want me to change the ip pool ? i will change and i will come back to you , but do u think the problem from ip pool ??
0
A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

 
LVL 79

Accepted Solution

by:
lrmoore earned 1000 total points
ID: 23640543
Yes, part of the problem is the ip pool needs to be different from the internal lan
Also, the internal LAN needs to be different from your home LAN with the VPN client.
I highly discourage anyone from using 192.168.1.x on the inside of any firewall appliance that will be supporting external vpn users simply because almost every home device on the market uses that same IP subnet as the local lan.
0
 

Author Comment

by:rabih_saleh
ID: 23641158
hi my freind , i changed the IP pool but sorry still the same problem the new ip pool now starting from 78.100.1.100-78.100.1.200

What do u think the problem ?
0
 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 1000 total points
ID: 23641289
Did you also change the  WEB_nat0_outbound to match?
access-list WEB_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 78.100.1.0 255.255.255.0

Also add:
 crypto isakmp nat-traversal 25

0
 
LVL 81

Assisted Solution

by:arnold
arnold earned 500 total points
ID: 23641801
You Should not use a Pulic IP as a pool which 78.100.1.x is and it assigned through ripenet. You will run into the same problem if the person is connected through a 78.100.1.x IP
Use a higher 192.168.x.y segment i.e. 192.168.250.x etc.  And adjust the access lists to include the new IP.
0
 

Author Comment

by:rabih_saleh
ID: 23643466
good morning , ok i will try and i will come back to u
0
 

Assisted Solution

by:chenault68
chenault68 earned 500 total points
ID: 23983792
You need to setup split_tunnel to all traffic from the VPN client to the internal interface.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Juniper VPN devices are a popular alternative to using Cisco products. Last year I needed to set up an international site-to-site VPN over the Internet, but the client had high security requirements -- FIPS 140. What and Why of FIPS 140 Federa…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses
Course of the Month14 days, 18 hours left to enroll

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question