We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

Cisco Catalyst Express 520 speed issue

Medium Priority
663 Views
Last Modified: 2012-05-06
I had a network speed issue (mesured ~10 Mbits/s but should be 100 Mbits/s) using HP workstation with Windows XP SP3 / network card Intel Pro VE 100  connected to a second level Cisco Catalyst Express 520 Switches. Second Level Switches are connected to the central Switch Cisco Catalyst Express 520G at 1000 Mbits/s using uplink port (1000 Gbits/s).
Central server is connected directly to the central switch at 1000 Gbits/s.
The same test connecting a workstation (100 Mbits/s network card) to the second uplink port 1000 port, XP report a 100 Mbit/s link and the test report a correct bandwidth !
 
Setting port speed / duplex at network card and switch doesnt help
Trying with another network card (100 Mbits/s) on such workstation doesnt help.

Doing a test with another PC with a 1000 Gbits/s network card report a link at 100Mbit/s and the test report a correct bandwith ...

So at this point I dont know really if this is a switch or network card or OS issue ?

 
Comment
Watch Question

Commented:
Is the firewall on the NIC turned on?

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
ICF Firewall is turned off (at service level) because of Microsoft KB and Cisco CTC.
Bill BachPresident and Btrieve Guru
CERTIFIED EXPERT
Commented:
Have you ALSO swapped out the cables?  Perhaps a badlt-terminated cable is introducing lots of errors, or causing the connection to scale back to 10Mbps.  Also, verify that the card and switch are either both set to AUTO, or better yet, set both to 100Mbps Full Duplex and see if that helps.

Author

Commented:
I swapped out the cables, I swapped the switches without resutls.
I swapped also the Cisco Catalyst Express 520 switch with another switch (Linksys 10/100/1000)  and did not get the issue ... so there is really a negociation problem with this Cisco Catalyst Express 520 switches and Network cards / drivers (Intel Pro/100 VE or Broadband NetExtreme)
Setting HD/FD at both side also doesnt help.

Author

Commented:
I get also the following answer from Cisco forum (not already tested):

Might be a HD/FD problem. Did you check the settings and statistics on the NIC (which is possible using the right drivers ...).

With 1Gbps links you should not have problems because the auto-negotation is part of the IEEE 802.3ab Standard and they removed the weaknesses of the original IEEE 802.3u.

With 100 Mbps links you might have cards following the first version of IEEE 802.1u and other ones which are using the second version of this standard. Therefore, havin the old version and the other site does not want to negotiate HD/FD problems are common.

Author

Commented:
Working today with second level of Cisco TAC, we found  a workaround :

disabling mls qos at switch level  (config > no mls qos) solve the issue.

Because disabling  mls qos is not the goal, Cisco TAC and us are still working on this issue  ...
Commented:
The following solution from TAC definitively solve this issue:

Set the following:

1° configure "mls qos queue-set output 2 threshold 4 3200 3200 100 3200"
2° write
3° reboot the switch

By changing that value, we just allowed that class to use more buffers, however, those buffers are shared among all the interfaces, so the total output will be balanced among all interfaces that are passing traffic sharing the same class/threshold.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.