help... xp pc can no longer browse the internet

Posted on 2009-02-12
Last Modified: 2012-05-06
I have an XP pro pc with all of the current SPs. I was working to install the software that will allow me to tether my iphone.... I don't know if that had anythign to do with my problem... but I can no longer browse (ie, safari, or chrome).

I have an ip address, I can ping yahoo, etc.. ,my IM software still works, and I can attch to network drives through NET USE to their IP the underlying tcpip seems to be ok. when I browse, I get a "page not found" error. the probem is with both of my NICs (and I have uninstalled and reinstalled them.

I also tried a winsock fix as well.. no go.  

What is happening here?
Question by:dbrennecke
    LVL 3

    Expert Comment

    My suspect is you have more than one NIC's, but only one of them has Internet access.
    The fact you could access your network drive is that it is available/specified in the routing table.

    Use Netstat -r to look at your routing table.
    Network Destination        Netmask          Gateway       Interface  Metric
                           x.x.x.x          x.x.x.x1       20
                           y.y.y.y          y.y.y.y1       50
    The lowest Metric is the default GW, means any routing unless defined in the routing table will flow through the default GW. IF this is the interface that don't have internet access, than you will not be able to access the Internet. The metric is usually defined automatically, but some software could force the metric to assure their program works as it suppose to be.

    You could decide to change it back to automatically assign metric. Or if this is already the case, you could change the one that is not standard in your environment to make the one with the internet access the default GW.

    Author Comment

    OK... now this is strange... I have now tried 4 browsers... IE, Chrome, Safari, and FireFox...
    AND ONLY FIREFOX is able to browse the Internet... all the rest error out:
    BUT.. IE can access our corporate SharePoint Intranet website.
    LVL 3

    Accepted Solution

    More things it is not clear2me.
    Do you check proxy settings on all the browsers?
    Do you have internet access on both interfaces?

    Author Comment

    BINGO! The iPhoneModem installer setup a proxy in the browser settings! I cleared it and it is good to go!
    LVL 3

    Expert Comment

    Meaning, only 1 interface has Internet acces. That should be the one through your Iphonemodem.
    The other interface has only your companies intranet access.

    Be carefull about this situation, as your PC become more vulnerable for attacks from the Internet while you are connected on your companies network.

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    Join & Write a Comment

    Do you come here a lot? Are you lazy like me and don't want to go through the "trouble" of having to click your Dock's Safari icon and then having to click your Experts Exchange Favorites bookmark to get here? Well then this article is for you.
    Several part series to implement Internet Explorer 11 Enterprise Mode
    This Micro Tutorial will demonstrate how nuggets on the Web are formatted by using Chrome Developer Tools. These tools would not only view the site's CSS but it can also modify it and save the CSS to use on your own site.
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    730 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now