We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

Disk % Time Performance always high

AJKBOC
AJKBOC asked
on
Medium Priority
676 Views
Last Modified: 2012-05-06
We have a problem with one of our servers in the office. We have 5 identical servers. Same model, same HD, memory etc. Everything is fine for the 4 of the servers. One of them (the red line in the attachment) is always very high (% Disk Time) in the Performance log. Even when all of the users are logged out (all of the users are being used as application servers via terminal services) Application3 is showing activity. We replaced the disks (Mirror) we scanned for viruses, spywares etc but we didn't find anything. Also have in mind that the users logged in each server every day are different. (We use Sun Rays and the sessions are doing load balancing)

The servers are SUN 4150 with Windows Server 2003 Enterprise Edition, 16GB memory and 2 Quad Code Processors.

What could be the cause for this?

Thanks.
docPerformance.doc
Comment
Watch Question

Have you tried to monitor the network traffic of that specific server during low activity hours? Does the problem go away if you disconnect the server from the network (if possible)? I had a firewall causing the same problem for a server once..

Author

Commented:
No I hanen't tried disconnecting it from the network. But I don't think this would be the cause for this since the new attached performance snapshot shows problem in the Average Disk Write Queue Length.

I am attaching a new snapshot with the Performance of 3 of my servers showing the Average Queue Lenghts. Application 3 is the one that has the problem. If you see the Queue Lengh has a max of 11 and average of 2.75 where the other have a max of 1.2 and 0.9 and an average of 0.109 and 0.137.

What could be a solution for this? (hard disks have already been replaced)
docPerformance2.doc
Run Filemon and see what is beeing written....
http://technet.microsoft.com/en-us/sysinternals/bb896642.aspx

Author

Commented:
Thanks for the tip.  I ran Filemon just now but there are thousands of entries. How to I use this?
You start and stop a capture by pressing Ctrl+E. I usually search for a process that is overrepresented and try to find info on that process. You can also check the Path and look for suspected entries. There is a bunch of KB articles at the bottom of the page where you download the tool
Commented:
The setting on the raid controller was write though and we changed it to write back. That solved the problem.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.