terminal services - Stop auto log off when administrator quits program which runs on startup

Hi experts, I manage a call room network which is running 2 terminal servers. The problem I have is I have set a program to run, via TS console, to load on start-up. This means when a user quits the program they are forced to log off, which is perfect for all of the call room staff. However my issue is managers need to login to the terminal server and these users dont want to have a program running.

My current solution which isnt great is when a manager logs in they have to load task manger then explorer and minimise the application making sure not to quit it or they will be kicked off.

I guess your now thinking why dont you run the program from a group policy and exclude managers from this policy. The problem with this is we have 2 terminal servers and one group of call room users, so the GP would only be able to make all the users run the program on 1 terminal server or the other. So why not create to groups, the problem with this is we need to split the work load between the two servers, and we cant just create two groups, as the callers sit at differnt clients each day, which is a problem as half of the thin clients are set to connect to terminal 1 the other to connect to terminal 2. So this would create the problem of a user who is in the group which runs the application on TS 1 logging onto a Thin client which is configured to connect to TS 2, this will work but I think it creates allot of unnecessary network traffic,

Another solution you may be thinking is configure the load program on the RDC, this may be possible but time consuming as we have lots of different types of thin clients here. Plus we would have to add all of the clients to the domain, again more time.

The best solution would be if we could create a GP to exclude managers from the standard auto log off functionality which happens when you set a program to load on start-up.
LVL 1
coreccAsked:
Who is Participating?
 
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
  1. Create two GPOs 1 for your managers and another for your standard users.  
  2. Remove the authenticated users from the security tab of both GPOs
  3. Touch no other permissions unless you know what they are for).
  4. Add the managers group to the permissions tab of the the managers GPO
  5. Add the users to the permissions tab of the users GPO
  6. If you configured the item to startup from users profile tab I would suggest you remove it.
  7. open each policy and lock everything down from the desktop to the start menu and only place the apps you want them to access in the start menu

0
 
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
I think you have it backwards.  If you apply the same GPO's to both terminal servers, then it does not matter which server the user(s) or manager(s) logs on to, they will get the proper settings.
0
 
coreccAuthor Commented:
Thanks for the reply, it sounds like you could have the answer, but i dont understand. Could you give me a brief summary of how you would set this up.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
coreccAuthor Commented:
Thats definatly a possible soluction, it is a nice feature though to have the program load on startup and log the user off when the program is closed. I dont think people would be happy with loosing this feature.
0
 
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
Unfortunately, there's not other way around it that I could think of. But they have to logon/off their computer everyday so this should be no different.
0
 
coreccAuthor Commented:
Thanks for your comments, Its a good solution. I think I'll still try and find another work around though. Another possible idea is to get the managers to login to the server using logmein, this way the startup program shouldnt load.

Thanks for your help, I will give you the points if no one else suggests any other soluctions.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.