We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

Exchange 2007/Outlook 2007 Public Folders - Non-local users cannot be given rights on this server?

iain_stephen
iain_stephen asked
on
Medium Priority
6,210 Views
Last Modified: 2012-06-06
Hello - we are moving from Exchange 2003 to 2007.  When I try to add a mail-enabled group to a public folder in Outlook (like I always used to), I get the error "One or more users cannot be added to the folder access list.  Non-local users cannot be given rights on this server."
How do I add group permissions in the new world for public folders?
Comment
Watch Question

Expert of the Quarter 2009
Expert of the Year 2009

Commented:
What type of group is it?
The behaviour of Public Folders hasn't changed much from Exchange 2003 to Exchange 2007.

-M
iain_stephenIT Manager

Author

Commented:
Sorry - I missed your question - I seem to get this whether it is a newly created dynamic distribution list or simply a regular distribution list - all members of the list exist on the Exchange 2007 server - in fact, we have tried creating new groups with only one member in them - and we get the same error.

I am wondering now if it is because the folder(s) in question originally were created in Exchange 2003 - then 'moved' to exchange 2007...  ??  Maybe it's not the users that aren't local to exchange 2007 but the public folder??
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
Shouldn't make any difference where the folder was located.
Do check that your mailboxes are regular mailboxes and not linked mailboxes, which can cause a similar problem.

Simon.
iain_stephenIT Manager

Author

Commented:
Where do I see that status?  

Here is what I did that worked this morning...

We still have the Exchange 2003 server on the network - no users on it - no public folders 'homed' on it - all folders in Exchange Management Console Public Folder Viewer are showing properties that put them on the new Exchange 2007 server... I turned off the 2003 server and could still get to the public folder... so that should mean it's on 2007, right?

I turned on the 2003 server and created a distribution list using AD on that box - added the members I needed - and then jumped into outlook on a workstation and was able to add that list with permissions set to none and not visible...

Why won't it work to create a group using either AD UC or Exchange Management Console on the 2007 box??
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
Just reading back, you didn't actually answer the question on the type of group.
Is is a security group or a distribution group?

Simon.
iain_stephenIT Manager

Author

Commented:
The one that is working this morning is a distribution group - created using AD users/computers on Exchange 2003 server.

All of the other permissions done at a group level on those public folders (that have been around for years) were done using distribution groups also - before Exchange 2007 existed...
Expert of the Quarter 2009
Expert of the Year 2009
Commented:
Being distribution groups is your problem.

The groups needs to be mail enabled security groups. In previous versions of Exchange the store did an internal process to change distribution groups to security groups. That is no longer done by Exchange 2007, so you need to create the groups as security groups.

Simon.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Commented:
I'm actually experiencing this same issue. Any group created after we migrated from Exchange 2003 gives us the same error. I checked on the security vs distribution setting, however it has no affect. In fact all of the groups that migrated over from 2003 are set currently as distribution groups, and I can manipulate public folder permissions with them without any problem. Any other suggestions?

Commented:
I noticed if I use an Outlook 2003 client to modify the public folder permissions instead of 2007, I can modify permissions on any of the new groups added after the migration.
iain_stephenIT Manager

Author

Commented:
Still having the same problem here too.
The distributrion group must be a secuity group. Then to clear the prohibtion icon, An Exchange admin can open the MMC, Open properties for the distribuiton list, go to the E-Mail Addresses tab, Uncheck the "Automatically update e-mail addresses based on e-mail address policy" option,  Apply changes then recheck the option and apply again.

Reference:
http://www.eggheadcafe.com/conversation.aspx?messageid=34066447&threadid=29663151

I'm using Outlook 2007 with Exchange 2007 as the backend.   I can add some groups to the permissions tab on a public folder even if they are distribution only lists.  I have some groups that I can't add regardless of whether I set the group to security or distribution.    

This issue is not solved.

Commented:
FYI VertigoRay's post fixed my issue. Thanks! I had the group set but all I needed to do was clear the prohibition icon and it then appeared like every other group.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.