?
Solved

Opening Ports for Cisco VPN client from behind ASA 5505

Posted on 2009-02-13
12
Medium Priority
?
3,299 Views
Last Modified: 2012-05-06
I have been unable to run applications over a vpn connection since I installed an ASA 5505.  I have tried adding the crypto isakmp nat-traversal  20 to the CLI but still am not able to run my applications.  I do see "translation creation failed for protocol 50 src inside" errors being logged.  I have recently spoken with the network admin at the location that hosts the applications and he told me that I need to open the following ports.

TCP : 10000
UDP: 4500
UDP: 500
ESP Traffic

Can someone post the CLI or directions to do this using ASDM?  I am new to Cisco firewalls so bear with me.  Also, what is he refering to when he says, "ESP Traffic"?  
0
Comment
Question by:lahma35
  • 5
  • 5
11 Comments
 
LVL 8

Expert Comment

by:Nothing_Changed
ID: 23633566
ESP traffic is Ip Protocol 50, and is used for IPSEC  among other things, to provide an end to end encryption and endpoint authentication method that will work through NAT.

Assuming your outside ACL is called
access-list OUTSIDE-INBOUND
and your access group statement then was
access-group OUTSIDE-INBOUND in interface outside

then make avfew object groups like this:

object-group service VpnPortsTcp tcp
 port-object eq 10000
object-group service VpnPortsUdp udp
 port-object eq 4500
 port-object eq 500
object-group protocol VpnProtocols
 protocol-object 50

(some of these ports will translate to names once they are in, dont worry)

Then first try like this, ill assume to anyone?

access-list OUTSIDE-INBOUND extended permit object-group VpnProtocols any any

Then test it. Since udp & tcp should allow return traffic automagically unless you have an access list entry to deny it specifically, this will allow ESP traffic back into anyone. If that fails, post back your error log entries and we'll take the next step. (i know we didnt use the two tcp & udp service groups yet, its for later just in case, they arent "active" unless we use them in an ACL)



0
 
LVL 1

Author Comment

by:lahma35
ID: 23633862
Here is my current running config.  I have not had them check the vpn connection yet, I was hoping you could verify my config first.  Thanks for your help I very much appriciate it.
0
 
LVL 1

Author Comment

by:lahma35
ID: 23633865
Result of the command: "show running-config"

: Saved
:
ASA Version 7.2(4)
!
hostname ciscoasa
domain-name xxxxxxxxxxxxxxxx
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute
!
interface Vlan3
 shutdown
 nameif dmz
 security-level 50
 ip address dhcp
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name jtengineering.com
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group service CompanyWebAccess tcp
 description External secure Companyweb access
 port-object eq 987
object-group service VPN_Client udp
 port-object eq 4500
object-group service VPN_Group tcp
 port-object eq 10000
object-group service VpnPortsTcp tcp
 port-object eq 10000
object-group service VpnPortsUdp udp
 port-object eq 4500
 port-object eq isakmp
object-group protocol VpnProtocols
 protocol-object esp
access-list inside_nat0_outbound extended permit ip any 192.168.50.0 255.255.255.224
access-list outside_access_in remark SMTP Port 25
access-list outside_access_in extended permit tcp any host 192.168.1.2 eq smtp
access-list outside_access_in remark RWW and OWA
access-list outside_access_in extended permit tcp any host 192.168.1.2 eq https
access-list outside_access_in remark External secure Companyweb access
access-list outside_access_in extended permit tcp any host 192.168.1.2 eq 987
access-list outside_access_in extended permit object-group VpnProtocols any any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool VPNpool 192.168.50.1-192.168.50.30 mask 255.255.255.0
no failover
monitor-interface inside
monitor-interface outside
monitor-interface dmz
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface smtp 192.168.1.2 smtp netmask 255.255.255.255
static (inside,outside) tcp interface https 192.168.1.2 https netmask 255.255.255.255
static (inside,outside) tcp interface 987 192.168.1.2 987 netmask 255.255.255.255
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs group1
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.2-192.168.1.33 inside
!
dhcprelay server 192.168.1.5 inside

group-policy VPNgroup internal
group-policy VPNgroup attributes
 dns-server value 192.168.1.2
 vpn-tunnel-protocol IPSec
group-policy vpngroup internal
group-policy vpngroup attributes
 dns-server value 192.168.1.2
 vpn-tunnel-protocol IPSec
username amplitel password Bu3OwTYaJv/0C2MR encrypted privilege 0
username amplitel attributes
 vpn-group-policy VPNgroup
tunnel-group VPNgroup type ipsec-ra
tunnel-group VPNgroup general-attributes
 address-pool VPNpool
 default-group-policy VPNgroup
tunnel-group VPNgroup ipsec-attributes
 pre-shared-key *
tunnel-group vpngroup type ipsec-ra
tunnel-group vpngroup general-attributes
 address-pool VPNpool
 default-group-policy vpngroup
tunnel-group vpngroup ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ipsec-pass-thru
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:acd77682990d9b87d4a7da162d6bf28f
: end
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 8

Expert Comment

by:Nothing_Changed
ID: 23634093
I noticed that you are running
ASA Version 7.2(4) ASA Version 7.2(4)

I'd strongly recommend updating that to 8.0(3) or later.

Config looks good, give it a go.
0
 
LVL 1

Author Comment

by:lahma35
ID: 23634514
They still are not able to open the programs.  The connection is made but the applications that she needs to runn will not run.  I see the following error in the log files of the ASA.

3      Feb 13 2009      08:37:24      305006      xxx.xx.xx.xx             regular translation creation failed for protocol 50 src inside:192.168.1.103 dst outside:130.47.34.7
0
 
LVL 1

Author Comment

by:lahma35
ID: 23634538
I dont know if this adds anything to the problem but since I replaced their Linksys router\firewall with the ASA I kept the linksys as an access point for wireless connections.  She is currently connected wirelessly to they network.
0
 
LVL 8

Expert Comment

by:Nothing_Changed
ID: 23636657
If you are using the Linksys as a wirelss AP, have oyu disabled all of its routing/firewall functions? Your network should be plugged into the "inside" interfaces of the linksys, and not it's WAN port. If she is double NATting through the linksys and the ASA that will break VPN.

Based on your config, it looks like it ought to work. Hate to say it again, but this may be a caveat in the older version software. Adding to that the known published security vulnerabilities in the older software, and hte painless nature of hte upgrade, I'd say do it off hours, and then resume the troubleshooting.
0
 
LVL 1

Author Comment

by:lahma35
ID: 23636701
Thanks for the thoughts.  I will try upgrading the firmeware and let you know what I find out.
0
 
LVL 8

Expert Comment

by:Nothing_Changed
ID: 23636994
Double check that the port on your linksys is not in the WAN port. Or have your user try from a wired port with  her wireless disabled. Two NICs active makes VPN clients malfunction as well.
0
 

Expert Comment

by:everclear_andrew
ID: 23713641
guys sorry for hopping on this one, but I'm having a similar issue, and adding only ESP didn't take care of it.  Would someone mind giving me the commands to add the VPNPortsTCP and VpnPortsUpd...

I'm assuming it will look like this:

access-list outside_access_in extended permit object-group VpnPortsTcp any any
access-list outside_access_in extended permit object-gropu VpnPortsUdp any any


correct?
0
 
LVL 8

Accepted Solution

by:
Nothing_Changed earned 2000 total points
ID: 23723522
Almost, try this way:
access-list outside_access_in extended permit tcp object-group VpnPortsTcp any any
access-list outside_access_in extended permit udp object-group VpnPortsUdp any any
This will open whatever ports are in the  two object groups into anyone from anyone. As that implies, however, ANYthing can come in those ports...
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When speed and performance are vital to revenue, companies must have complete confidence in their cloud environment.
During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Suggested Courses
Course of the Month14 days, 22 hours left to enroll

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question