• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 833
  • Last Modified:

Opening Ports for Cisco VPN client from behind ASA 5505

I have been unable to run applications over a vpn connection since I installed an ASA 5505.  I have tried adding the crypto isakmp nat-traversal  20 to the CLI but still am not able to run my applications.  I do see "translation creation failed for protocol 50 src inside" errors being logged.  I have recently spoken with the network admin at the location that hosts the applications and he told me that I need to open the following ports.

TCP : 10000
UDP: 4500
UDP: 500
ESP Traffic

Can someone post the CLI or directions to do this using ASDM?  I am new to Cisco firewalls so bear with me.  Also, what is he refering to when he says, "ESP Traffic"?  
0
lahma35
Asked:
lahma35
  • 7
  • 6
1 Solution
 
JFrederick29Commented:
This isn't an access issue but rather an issue with NAT (PAT).

He (the network admin) needs to enable NAT-Traversal (NAT-T) on his side (on the server side) which will resolve the issue.  If he won't do this, you can do the following on your ASA:

conf t
policy-map global_policy
 class inspection_default
 inspect ipsec-pass-thru

If you have a free public IP address, you can also use a static NAT for your PC running the VPN client to resolve this issue.
0
 
lahma35Author Commented:
JFrederick29 I added the lines in the CLI and still unable to open the applications once the VPN connection is made.  Here is what my running config looks like.

Result of the command: "show running-config"

: Saved
:
ASA Version 7.2(4)
!
hostname ciscoasa
domain-name xxxxxxxxxxxxxxxxxxxxx
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute
!
interface Vlan3
 shutdown
 nameif dmz
 security-level 50
 ip address dhcp
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name jtengineering.com
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group service CompanyWebAccess tcp
 description External secure Companyweb access
 port-object eq 987
object-group service VPN_Client udp
 port-object eq 4500
object-group service VPN_Group tcp
 port-object eq 10000
object-group service VpnPortsTcp tcp
 port-object eq 10000
object-group service VpnPortsUdp udp
 port-object eq 4500
 port-object eq isakmp
object-group protocol VpnProtocols
 protocol-object esp
access-list inside_nat0_outbound extended permit ip any 192.168.50.0 255.255.255.224
access-list outside_access_in remark SMTP Port 25
access-list outside_access_in extended permit tcp any host 192.168.1.2 eq smtp
access-list outside_access_in remark RWW and OWA
access-list outside_access_in extended permit tcp any host 192.168.1.2 eq https
access-list outside_access_in remark External secure Companyweb access
access-list outside_access_in extended permit tcp any host 192.168.1.2 eq 987
access-list outside_access_in extended permit object-group VpnProtocols any any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool VPNpool 192.168.50.1-192.168.50.30 mask 255.255.255.0
no failover
monitor-interface inside
monitor-interface outside
monitor-interface dmz
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface smtp 192.168.1.2 smtp netmask 255.255.255.255
static (inside,outside) tcp interface https 192.168.1.2 https netmask 255.255.255.255
static (inside,outside) tcp interface 987 192.168.1.2 987 netmask 255.255.255.255
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs group1
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.2-192.168.1.33 inside
!
dhcprelay server 192.168.1.5 inside

group-policy VPNgroup internal
group-policy VPNgroup attributes
 dns-server value 192.168.1.2
 vpn-tunnel-protocol IPSec
group-policy vpngroup internal
group-policy vpngroup attributes
 dns-server value 192.168.1.2
 vpn-tunnel-protocol IPSec
username amplitel password Bu3OwTYaJv/0C2MR encrypted privilege 0
username amplitel attributes
 vpn-group-policy VPNgroup
tunnel-group VPNgroup type ipsec-ra
tunnel-group VPNgroup general-attributes
 address-pool VPNpool
 default-group-policy VPNgroup
tunnel-group VPNgroup ipsec-attributes
 pre-shared-key *
tunnel-group vpngroup type ipsec-ra
tunnel-group vpngroup general-attributes
 address-pool VPNpool
 default-group-policy vpngroup
tunnel-group vpngroup ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ipsec-pass-thru
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:acd77682990d9b87d4a7da162d6bf28f
: end
0
 
JFrederick29Commented:
Okay, maybe that command doesn't actually fix the PAT problem.  Your two options are:

1.  Talk to the network admin and have him enable NAT-T on the VPN server.
2.  Obtain a second IP address from your ISP to static NAT the second public IP to your internal PC.
0
Exciting career futures for women in IT

Education has the power to transform lives and open the door to new career opportunities. By earning an IT degree from WGU, you can become a highly skilled IT professional. Get the credentials and certifications you need to become a leader in this rewarding field.  

 
lahma35Author Commented:
Are there any other options?  I cannot get ahold of the network admin at the remote location, and by the looks of the second option this will take some time.  I am looking to get this working asap.  How can this be such a problem when a 50 dollar linksys will allow this traffic without a hitch?
0
 
JFrederick29Commented:
You know, that is a very common argument, completely understand the frustration.  There are no other options that I am aware of other than taking the ASA out of the equation until 1 of the 2 options are done.  The IPSEC pass-thru option only appears to work with NAT (not PAT).
0
 
JFrederick29Commented:
But in defense of Cisco, there is absolutely no reason why the VPN server should not be configured with NAT-T.  In this day and age of NAT/PAT, NAT-T is essential.  With NAT-T enabled, this is a non-issue whether you are using a Linksys or ASA.
0
 
lahma35Author Commented:
I finally got ahold of the network admin and he is assuring me that NAT-T is enabled.  He had me switch the client to use IPSec over TCP Port 10000 instead of IPSec over UDP.  That allowed the applications to work, but he insisted that IPSec traffic was still being blocked by the ASA and that it would work fine if I could allow that traffic.  Does this make any sense?
0
 
JFrederick29Commented:
You aren't blocking the traffic, trust me.  NAT-T should work so I suspect something isn't setup right.  So, TCP works though?  If you can get to the applications, IPSEC is flowing fine.  TCP/UDP encapsulation wrap the ESP (IPSEC) traffic in a TCP/UDP packet which is why it works through a PAT device.
0
 
lahma35Author Commented:
Oops I miss heard what he had her change on the client...bad reception on my cell phone.  He had her uncheck the Enable Transparent Tunneling and kept everything else the same.  Once that was unchecked it worked.  Any thought on that?
0
 
JFrederick29Commented:
Okay, interesting.  Perhaps the IPSEC pass thru did work once it was native IPSEC.  If you feel up to it, you could remove the "inspect ipsec-pass-thru" and see if it breaks again or leave it as is and be happy it is working :)

Something isn't setup right on their end if NAT-T doesn't work.
0
 
lahma35Author Commented:
Does the inspect ipsec-pass-thru enable the ESP traffic?  I may try updating the firmware on the ASA this weekend also.  Do you think that may change things?  So what did disabling Transparent Tunneling actually do?  Sorry for all the questions.  Just trying to get a grip on whats going on.
0
 
JFrederick29Commented:
Disabling transparent tunneling disables NAT-T or TCP encapsulation if selected.  The IPSEC goes out straight ESP (IP 50) instead of wrapped in UDP or TCP.  This is why ipsec-pass-thru must be working now as IPSEC doesn't work through PAT.  Upgrading shouldn't change anything...
0
 
lahma35Author Commented:
Thanks for your help on this situation and quick feedback.  I very much appriciate it.  Have a great weekend.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 7
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now