Group policy software push won't work

I can't get any .msi package I tell GP to push to actually go out.  I have it set under computer config, and have it set to "assign".  I have other things running on this policy that do work, but the software won't go..... No idea why.
dannyboy266Asked:
Who is Participating?
 
dannyboy266Connect With a Mentor Author Commented:
So I decided to create a virtual directory in IIS and place the MSI there and create the policy, and that worked.....So from a shared folder on that same server with read access assigned to everyone it wouldn't work, but in a virtual directory it did work..
0
 
DonNetwork AdministratorCommented:
Have you rebooted the computers, it only installs on  startup.
0
 
dannyboy266Author Commented:
yeah i rebooted a few times, does it cancel it if the user logs in?
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
DonNetwork AdministratorCommented:
no, did you run gpupdate /force on server?
0
 
dannyboy266Author Commented:
yes i did run that
0
 
DonNetwork AdministratorCommented:
Are the computers you are pushing this to located in this OU?
0
 
dannyboy266Author Commented:
I have them in a "All Computers" OU, I have all the computers added to a "all" group as well, which is what I'm using instead of doing it 1 by 1.  And it's worked for a few things, but not software distribution.
0
 
DonNetwork AdministratorCommented:
Try opening your gpmc and at the bottom left run the group policy results wizard(right click) on any of the computers
0
 
WeirdoBcCommented:
dstewartjr, gpupdate /force should be done on the computers, not the server.

As for your problem, be sure that any user can access the MSI file using the same path the GPO is using. (If the path is on a local drive, it won't work, the Access control list should be checked too).

The other solution is, when adding the MSI in the GPO, instead of Assign, choose Advanced. In the properties choose Assign but also, go in the advanced options and check the "ignore the language" box.
0
 
DonNetwork AdministratorCommented:
I did mean to say on server and computers, btw ;-)
0
 
DonNetwork AdministratorCommented:

Another thing that may cause your issue is if you dont have the latest windows installer installed

http://www.microsoft.com/downloadS/details.aspx?familyid=5A58B56F-60B6-4412-95B9-54D056D6F9F4&displaylang=en 

Deploy this with group policy as well
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.