SQLEXPR2005 fails update KB960089, uninstall continually fails as does setup/remove

Hi Guys,
This problem is making my head sore so really hope someone can through some light on the subject. I have a Vista Bus SP1 HP nx9420 laptop with 4G memory. I run SQLEXPR2005 for various small database projects (none installed at present so no databases present)

A couple of weeks ago I had a problem with SQL2005 SP2 which was applied through windows updates (WSUS3 from our SBS2003 server) I can;t remember the error, but I donwloaded the SQL SP2 manually and deployed it OK.

This week I've had an update to SQL2005 which is KB960089 which fails to install through Windows update and I can't get it to install manually either (Error code c064. Since I'm about to start work on a project I wanted to tidy the install up so elected to uninstall then reinstall SQL2005 on this Visa PC, I can't.

I have tried uninstall through Control Panel/Programs and features but that fails during the setup progress (3 log files are included but the datastore log is XML and won't upload here) If I try to run the SQL setup program this reveals a Pending Reboot which won't clear.

I did try the SQLEXPR SP3 for 2005. Which install a default instance but would not update the named SQLEXPRESS instance.

I've obtained the MS 'Manual' cleanup script but it is less than clear and mostly fails whenever I attempt part of it (this is KB957008 29/01/2009 rev 3)

How do I cleanup and start again?
Or how do I approach getting the setup/uninstall to function again.


SQLSetup0017-WHY-WVIB2001-Core-L.log
SQLSetup0017-WHY-WVIB2001-SCC.log
SQLSetup0017-WHY-WVIB2001-SQL.log
TrevorWhiteIT ConsultantAsked:
Who is Participating?
 
Jim P.Commented:
Have you seen this article?

How to uninstall an instance of SQL Server 2005 manually
http://support.microsoft.com/kb/909967

The hack it -- Die, You Gravy Sucking Pig Dog! -- way of doing it is to go into the registry and delete the entries for:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Native Client
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server 2005 Redist
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Microsoft SQL Server 2005
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Microsoft Visual Studio 2005 Tools for Office Runtime

Delete the SQL directory hives on the drive, and then get a copy of regclean and run that.

I've had to do it that way before. Not pretty, but it works. Highly suggest that you backup your registry before doing it though.
0
 
Raja Jegan RSQL Server DBA & ArchitectCommented:
Instead of that, can you try installing the SQL Server Service Pack 3 directly which is a cumulative update and includes the above security update too.
0
 
TrevorWhiteIT ConsultantAuthor Commented:
Hi Rrjeqan17,

I'm not sure if there is a post missing before yours . . .
I believe I did try the SQL SP3 install (I'll check that there was not an 'update only' or other version of the SP3. Is there a separate SP3 for full blown SQL as opposed to SQL Express ???
Is this scenario documented anywhere ??

I'm back at base later this evening so will take a look then.

0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
Raja Jegan RSQL Server DBA & ArchitectCommented:
For complete cleanup and uninstall of SQL Server follow the steps as mentioned below;

http://support.microsoft.com/kb/909967

Have did this once myself to uninstall corrupted SQL Server 2005 installation and after that do a fresh installation along with SP3

Hope this helps you.
0
 
TrevorWhiteIT ConsultantAuthor Commented:
Hi,
I've been through this once too but it all failed. I'll give a more accurate account of what happened when I get back. This is the frustrating thing, I know I need to uninstall then start again but can't get past this hurdle. More later
Trev
0
 
TrevorWhiteIT ConsultantAuthor Commented:
Hi,
back at base now, I have been attempting (again) to run through kb909967 but not getting too far.
I'm not interested in backing up any data so ignored that para. I presumed that Deleting the local security groups should be done after successfully uninstalling program components. I don't use SQL server Reporting Services so ignored this para. I stopped all of the SQL 2005 services. I'm logged in with local admin rights.

Step 1. The MS SQL Server Setup Support files are installed (or so Programs and Features tells me)
So I go to Step 2 which says tun the ..\ARPWrapper.exe /Remove at a command prompt. The component selection dialogue appears and we are told to remove components separately. So I select the MSSQLSERVER and keep the 'Remove SQL 2005 instance components' ticked. Clicking on Next displays a dialogue requesting confirmation that I want to remove the MSSQLSERVER instance. Clicking on Finish returns us to an empty screen, no done message or anything. If I rerun arpwrapper the MSSQLSERVER instance is still there. The same applies if I try to remove the SQLEXPRESS instance.

I'm taking a deep breat and looking at the 'If you eperience problems" bit now. The last time I tried this I got errors on all but one of the {GUID}s that I submited to msiexec. It seemed pointless continuing.

More in a while . . . aaaarrrrgh
Trev
0
 
TrevorWhiteIT ConsultantAuthor Commented:
Hi Again,
If I run the arpwrapper.exe from within the Programs and features section of control panel I can uninstall the MSSQLSERVER instance but attempting this with MSSQLEXPRESS gets to the configuration check page where crosses appear next to all three checks and after 2 or 3 seconds the page disappears ging no opportunity to view the logs files (I have posted these after guessing where they were by time stamps)

So now I just have the SQLEXPRESS instance which won't uninstall . . . TW slopes off muttering obsenities in to mug of very strong coffee . . .

Cheers
Trev.

0
 
TrevorWhiteIT ConsultantAuthor Commented:
Hi Again, Results from If you experience difficulties in kb909967

I located 4 entries in the registry section with Microsoft SQL 2005 server in the display name property.
These are :
{58D379F7-62BC-4748-8237-FE071ECE797C}
{B0F9497C-52B4-4686-8E73-74D866BBDF59}
KB948109_SQL9
Microsoft SQL Server 2005

I only tried to run msiexec with the first two EG:
start /wait msiexec /x {58D379F7-62BC-4748-8237-FE071ECE797C} /l*v c:\sql_uninstall1.log
start /wait msiexec /x {B0F9497C-52B4-4686-8E73-74D866BBDF59} /l*v c:\sql_uninstall2.log

This resulted in a are you sure you want to remove this product and then (after a few seconds) with a Windows Installer error message of: "The installation source for this product is not available. Verify that the source exists and that you can access it." Clicking OK returns us to the cmd prompt.

The script in KB909967 doesn't seem to flow very well, it seems to give procedures for increasingly narrowing scenarios. Like if you recieve this error 'Blah blah blah . . " follow these steps . . . In my scenario we just have nowhere to go.

What next ????

Trev
0
 
Jim P.Commented:
I can't guarantee this is the answer, but I ran into an issue installing SP2 on SQL Express instances.

The WSUS was saying no SP2 -- You clicked on the install and it would fail to install and then come back.

The issue turned out to be the the SP2 for SQL Standard/other versions is not the same as the one for SQL Express. To solve it, you had to download the SQL Server 2005 Express Edition with Service Pack 2. Then when you fire it, it looks like it is trying to do a full install, but after you get into it, the installer allows you to upgrade existing instances.

http://www.microsoft.com/DOWNLOADS/details.aspx?familyid=31711D5D-725C-4AFA-9D65-E4465CDFF1E7&displaylang=en
0
 
TrevorWhiteIT ConsultantAuthor Commented:
Hi Jimpen,
Many thanks for your time, I had tried this before but had not documented the results so tried again.
I downloaded the 32bit only SQLEXPR.exe and ran it. All looked well includng a susscessfull installation scan (previously there had been an impending boot message and I could not continue)

I reached the section where setup shows the exsiting components (this after I selected the SQLEXPRESS named instance) A dialoge with the following is displayed.
{Begin of screen}
Existing Components
Components have been found on the machine, select upgrade options below:

The following components that you chose to install are already installed on the machine. To view a report of the available options and alternatives click details.
[  ] SQL server database service 9.2.3042
[  ] Workstation component and developer tools 9.2.3042
{End of screen}

Clicking the details button gives the following text:
Name: Microsoft SQL Server 2005 (SQLEXPRESS)
Reason: Your upgrade is blocked. For more information about upgrade support, see the "Version and Edition Upgrades" and "Hardware and Software Requirements" topics in SQL Server 2005 Setup Help or SQL Server 2005 Books Online.

Edition check:
Your upgrade is blocked because of edition upgrade rules. For more information about edition upgrades, see the Version and Edition Upgrades topic in SQL Server 2005 Setup Help or SQL Server 2005 Books Online.

I can't then proceed, if I click next I get No effective change so cannot proceed. I have to click Cancel which warns that the install had not been carried out and do I want to exist . . . I say yes.

So I'm none the wiser and I can't move forward. I don't know what 'Edition' I have but I'm prepared to uninstall it and start again with what ever SQLEXPRESS package is appropriate. But how do I get rid of the existing install . . . . Trying to keep cool about this but getting steamed up I must admit.

Thanks for your time, any pointers really appreciated.
Regards
Trevor



Name: Microsoft SQL Server 2005 Tools
Reason: Your upgrade is blocked. For more information about upgrade support, see the "Version and Edition Upgrades" and "Hardware and Software Requirements" topics in SQL Server 2005 Setup Help or SQL Server 2005 Books Online.

Edition check:
Your upgrade is blocked because of edition upgrade rules. For more information about edition upgrades, see the Version and Edition Upgrades topic in SQL Server 2005 Setup Help or SQL Server 2005 Books Online.

0
 
Jim P.Commented:
>> had not been carried out and do I want to exist . . . I say yes.

Most of us want to exist, I think. ;-)
-------------------------------------

Fire up the SQL Server Management Studio -- then go in and do

select @@version

That should give you an idea of what version you are on.  Hit <ctrl>+T to get text output.

0
 
TrevorWhiteIT ConsultantAuthor Commented:
Hi Jimpen,
Yeah go on then take the wee outa my typin' woncha ;-))
Its wierd but if I run SQLEXPR.exe (from your link) and select default instance I get 9.2.3042 which gives the same messages as the named SQLExpress instance (wrong edition etc) The SQLExpress edition (which I can connect to with Management Studio Express 2005) is 9.0.3068 SP2 Express Edition with advanced services, this is also blocked with wrong edition messages.

As I say, I'm not really bothered what the version, edition, or whatever it is I just want to remove all reference to SQL2005 on this VistaBus PC and start again . . . not much to ask you'da thought.

I'm dumping all this stuff here in the hope that someone can throw some light on the subject. I really don't want to have to format the drive and start again.

I'll leave this up here for a few more days.
Thanks to all who pass by
Trev
0
 
Jim P.Commented:
I just couldn't resist pointing it out. It was a good one for the morning chuckle.

SQL server database service 9.2.3042 indicates you are on some form of SP2.

The way to find the flavor (Express, Standard, Developer, ...) then is to go to a command prompt:

cd C:\Program Files\Microsoft SQL Server\90\Tools\Binn
sqlcmd -E -S (local) -q "select @@version"

You should get something back like this:
---------------------------------------------------------------------
Microsoft SQL Server 2005 - 9.00.3073.00 (Intel X86)
        Aug  5 2008 12:31:12
        Copyright (c) 1988-2005 Microsoft Corporation
        Standard Edition on Windows NT 5.1 (Build 2600: Service Pack 2)

C:\Program Files\Microsoft SQL Server\90\Tools\Binn>sqlcmd /?
Microsoft (R) SQL Server Command Line Tool
Version 9.00.3042.00 NT INTEL X86
Copyright (c) Microsoft Corporation.  All rights reserved.
 
usage: Sqlcmd            [-U login id]          [-P password]
  [-S server]            [-H hostname]          [-E trusted connection]
  [-d use database name] [-l login timeout]     [-t query timeout]
  [-h headers]           [-s colseparator]      [-w screen width]
  [-a packetsize]        [-e echo input]        [-I Enable Quoted Identifiers]
  [-c cmdend]            [-L[c] list servers[clean output]]
  [-q "cmdline query"]   [-Q "cmdline query" and exit]
  [-m errorlevel]        [-V severitylevel]     [-W remove trailing spaces]
  [-u unicode output]    [-r[0|1] msgs to stderr]
  [-i inputfile]         [-o outputfile]        [-z new password]
  [-f <codepage> | i:<codepage>[,o:<codepage>]] [-Z new password and exit]
  [-k[1|2] remove[replace] control characters]
  [-y variable length type display width]
  [-Y fixed length type display width]
  [-p[1] print statistics[colon format]]
  [-R use client regional setting]
  [-b On error batch abort]
  [-v var = "value"...]  [-A dedicated admin connection]
  [-X[1] disable commands, startup script, enviroment variables [and exit]]
  [-x disable variable substitution]
  [-? show syntax summary]

Open in new window

0
 
TrevorWhiteIT ConsultantAuthor Commented:
Hi Jimpen,
I couldn't get the sqlcmd script to connect, it just failed with a timeout message (Native Client faild to connect and gave the age old 'probably due to no network connections allowed' type message. Didn't spend too long with it since the version edition and SP I mentioned in my last post came from a transact script I ran from within Studio Express when connected to SQLEXPRESS.

Repeating myself here abit but whats the interest in the actual version??? I just need to uninstall it and start again. If its Express Edition with Advanced Services does that give us a different uninstall procedure ??? . . . Or maybe I need to run the setup again for "SQL EXPRESS 2005 advanced services" could that be it ??????

Hmmmm
Trev
0
 
Jim P.Commented:
To just uninstall it, go to the Add/Remove programs (or Start --> Run --> appwiz.cpl) and go through the list to remove all the SQL Server entries.

Then to be really sure go in and delete all the files/folders in the C:\Program Files\Microsoft SQL Server\ hive.
0
 
TrevorWhiteIT ConsultantAuthor Commented:
Errrr I've done the obvious stuff.
But my posts document what happens. IE in the system configuration check I crosses against all features and process stops without giving me a chance to view the logs. I have posted the logs which I found by searching and looking at time stamps.

Thanks
Trev
0
 
TrevorWhiteIT ConsultantAuthor Commented:
Ah now we may be talking.
Thanks, I've been through the KB909967 article (again documented above) but have not seen the belt and braces method (strange title to give it . . . but if it works hey ho!!! :-) ) Will give a go first thing tomorrow . . .  and yes will backup up the reg just in case.

Thanks again . . .  points could be yours yet
Good night
Trev
0
 
TrevorWhiteIT ConsultantAuthor Commented:
Not sure if regclean is a good idea these days. I noticed several Vista gurus advising strongly against its use. I used a different regclean prog that I pay for.
Thanks again.
Trev
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.