Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

How to set up "on Behalf of" emails

Posted on 2009-02-13
12
Medium Priority
?
549 Views
Last Modified: 2012-05-06
One of my clients has a requirement to have her assistant sent emails on her behalf.
I though the way to do it was adding the assistant as a Delegate on the Executive admins Outlook. All is well until I send a test email from the Assistants account and its coming up as sent from the Executive account (not on behalf of).

I checked the exchange settings on the server and it appears as though the permissions are not set for this under the Executive account. I also checked the settings on the Executive Directors system to make sure the Assistant has the appropriate permissions and it appears to be the case.

The Executive Director has Office 2007 and the assistant has Office 2003, I don't think this matters but It might be worth mentioning.
How do I fix it so the emails are being sent on 'behalf of" as opposed to "sent From".

Any help is appreciated.
Thanks!
0
Comment
Question by:swinger22
  • 5
  • 3
  • 3
11 Comments
 
LVL 58

Expert Comment

by:tigermatt
ID: 23637413

If emails are being sent 'From' the Exec user, then that would indicate that in one way or another, the Assistant's account inherits the 'Send As' permission on the Exec's user account. Look in Active Directory under Security for the Exec's account, and check all users who are granted 'Send As' permission.

'Send As' overrides 'Send on behalf', and that permission would need removing in order for the 'Send On behalf' to work correctly.

-Matt
0
 
LVL 14

Expert Comment

by:ashwynr
ID: 23637419
Swinger22,

You will need to ensure that the assistant does not have "Send As" rights on the Directors User account in Active Directory.
To check this, browse to Directors user account in AD and go to 'Security' tab. Over there the assistant should not have "Send As" rights. You could un-check the check box which allows this permission. and apply.
Also, under Exchange General tab (since this is an Exchange Server environment) of the user account, Add the assistant rights to "Send on Behalf Of"

Rest everything is detailed in the article below:
http://office.microsoft.com/en-us/outlook/HA011367671033.aspx

Hope this helps.

#wyn
0
 
LVL 58

Expert Comment

by:tigermatt
ID: 23648855
I provided basically the same solution - why did I receive no points?
0
Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
LVL 14

Expert Comment

by:ashwynr
ID: 23649165
I agree, Tigermatt also deserves points, or may be I think only he deserves them as he posted his comments before I did.

#wyn
0
 

Author Comment

by:swinger22
ID: 23660001
Sorry for the delay guys, us Canadians had a day off yesterday :D.

Anyway, I have tried what was suggested (going into Security and removing the Send-As checkbox under the Directors account for the Assistant). However, When I send a test email from the Assistant account (putting the Director in the From Field), its still sends the email As and not on behalf of.

I have granted the assistant the appropriate permissions under the Directors account (exchange general -> Delivery Options), I also made sure she was set as a Delegate (as per ashwynr link). I restarded the Assistants Outlook to be sure and still no go.

Can you guys think of anything else that can cause this? It seems as though something is still overriding the Send On Behalf Of permission with Send-As.

Thanks in advance!
0
 
LVL 58

Expert Comment

by:tigermatt
ID: 23660104

In that case it is likely there is some group which is listed in the Directory's Security tab which has the 'Send As' privilege assigned. It is possible that the permission assigned to the group is then inherited by the Assistant - and since Send As will override Send on behalf of, the assistant gets Send As rights.

I would go through each entry for the Director and check exactly what entries has 'Send As' granted to it. Don't remove it - but post those entries here and we can help you determine which one is causing this behaviour.

-Matt
0
 

Author Comment

by:swinger22
ID: 23660360
Good suggestion.... Here is what I found:
All accounts that have Send-As access on the Directors account: Domain Admins, Enterprise Admins, SYSTEM, BESAdmin and Administrators.
The assistant is a member of: Domain Users, Remote Web Workplace Users and a Distribution Group (names CAHRC).
So it doesnt seem like there is any accounts or groups in comon. Will setting up the Assistant on the Directors system as a Delagate override the permissions? Other than that I still have no explenation.

I appreciate your help so far!
0
 
LVL 58

Accepted Solution

by:
tigermatt earned 750 total points
ID: 23660612

Hmm... that's what I would expect.

As a test, I'd look at creating a temporary test account (the 'assistant') and a second temp account (the 'director') and try configuring things from scratch how you would expect. Don't grant any 'Send As' rights; just add the temp assistant as a delegate to the Director.

Then, see if you can replicate the behaviour. This will isolate for us whether the issue is something set incorrectly on these two user accounts, or something more global - in Exchange.

-Matt
0
 

Author Comment

by:swinger22
ID: 23660727
Good call.. I will try that this week and be in touch with the result.

Thanks!
0
 
LVL 58

Expert Comment

by:tigermatt
ID: 23660755

Good luck. Look forward to hearing back from you.
0
 
LVL 14

Assisted Solution

by:ashwynr
ashwynr earned 750 total points
ID: 23693700
Sorry ... lost tracking this one

Tigermatt's suggestion could help to identify the root cause and also resolve the issue however if any further help would be required then refer to the checklist below:

* Open directors AD account and browse to the 'Security' tab. Check all the groups over there and ensure that the assistant is not a member of any of the groups which has 'Send As' rights. If he is then will need to be removed from that group.
* Also ensure that the assistant is not listed in the directors 'Security' tab, in case if he is then please remove his account.
* In directors Outlook, ensure that the assistant is added as a delegate with Editor permissions.
* Ensure that in directors AD account, delegate is granted with "Send on Behalf of" rights.
* Once this is done, ask the assistant to try sending emails on behalf of director.
* If it still does not work, try re-creating users Outlook profile.
* Also, give some time for the permission replication to take effect and then try again.

#wyn
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Changing a few Outlook Options can help keep you organized!
Take a look at these 6 Outlook Email management tools which can augment the working and performance of Microsoft Outlook to give you a more rewarding emailing experience.
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
Suggested Courses

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question