Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3007
  • Last Modified:

Problems installing fuse on Ubuntu 8.04

I'm trying to mount an S3 volume to my Amazon EC2 app instances so I can download
the latest files from my S3 bucket at startup.  It looks like S3FS is the
right tool, but there appears to be an issue with fuse on the kernel
in the app image.  Has anyone else run into this? s3fs compiles fine,
but when I try to run it, I get a "fuse: device not found" error.
The following was done to build s3fs:

apt-get install -y build-essential pkg-config libcurl4-openssl-dev
libxml2-dev libfuse-dev libfuse2
svn checkout http://s3fs.googlecode.com/svn/trunk/s3fs s3fs
make -C s3fs
cp s3fs/s3fs /usr/local/bin
export AWS_ACCESS_KEY_ID=...
export AWS_SECRET_ACCESS_KEY=...
echo "$AWS_ACCESS_KEY_ID:$AWS_SECRET_ACCESS_KEY" > /etc/passwd-s3fs
chmod 600 /etc/passwd-s3fs
bucket=farm-config
mkdir -p /mnt/$bucket
/usr/local/bin/s3fs $bucket /mnt/$bucket
  fuse: device not found, try 'modprobe fuse' first
modprobe fuse
  FATAL: Module fuse not found.
  FATAL: Error running install command for fuse

Has anyone else encountered this?  If so, do we need to recompile the
kernel???  Hopefully not, as I don't even know where to start.

My Ubuntu kernel version is 2.6.16-xenU

If this means I need to rebuild my kernel, can someone tell me know to do that?  I'm new to that process.  

0
kenjaW
Asked:
kenjaW
  • 6
  • 4
1 Solution
 
fosiul01Commented:
have a look this one

http://www.experts-exchange.com/OS/Linux/Q_24069940.html

do locate

locate fuse.ko

run depmod -a, then try to modprobe fuse
0
 
kenjaWAuthor Commented:
It looks like fuse.ko is not on my system.  Next step was to download fuse and make it.  

It fails on ./configure saying it needs the location of the kernel source via the --with-kernel directive.  

Where do I get a copy of the 2.6.16-xenU kernel source???  
0
 
kenjaWAuthor Commented:
Managed to find the kernel source.  I downloaded fuse 2.7.4 and compiled it referencing the kernel source.  

./configure
make
make install

Everything seems to have executed without errors, but there still is not a fuse.ko file and none of the other errors have gone away.  Am I doing something wrong?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
fosiul01Commented:
execute

updatedb

then locate fuse.ko

0
 
kenjaWAuthor Commented:
root@ec2-:~/fuse-2.7.4# updatedb
root@ec2-:~/fuse-2.7.4# locate fuse.ko
root@ec2-:~/fuse-2.7.4#


Nada.
0
 
fosiul01Commented:
from where did you install fuse ??

can you try bellow

can you not insall fuse by  apt-get install fuse-utils

or from tar ball
http://www.computing.net/answers/linux/fatal-module-fuse-not-found/30113.html

or

http://fuse.sourceforge.net/ 

some how you need to install fuse.ko in your system
0
 
fosiul01Commented:
is 12.30 am , so i will be off now

bottom line is try to install fuse.ko somehow in your sytem
then you need to execute lsmod command as i sent my first link to add fuse.ko with the module

if there is any problem, i will see it tomorrow again

sorry for this
0
 
kenjaWAuthor Commented:
I grabbed it from fuse.sourceforge.net initially and then built it.  

I just did a apt-get install fuse-utils.  I'm getting a message about "Unable to load fuse module, but continuing anyway; please reboot to enable fuse"

Not sure why that is, but rebooting does not seem to help.


root@ec2-:~# apt-get install fuse-utils
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following extra packages will be installed:
  libfuse2
The following NEW packages will be installed:
  fuse-utils libfuse2
0 upgraded, 2 newly installed, 0 to remove and 95 not upgraded.
Need to get 144kB of archives.
After this operation, 430kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://archive.ubuntu.com hardy/main libfuse2 2.7.2-1ubuntu2 [125kB]
Get:2 http://archive.ubuntu.com hardy/main fuse-utils 2.7.2-1ubuntu2 [19.7kB]
Fetched 144kB in 0s (153kB/s)    
Selecting previously deselected package libfuse2.
(Reading database ... 23039 files and directories currently installed.)
Unpacking libfuse2 (from .../libfuse2_2.7.2-1ubuntu2_i386.deb) ...
Selecting previously deselected package fuse-utils.
Unpacking fuse-utils (from .../fuse-utils_2.7.2-1ubuntu2_i386.deb) ...
Setting up libfuse2 (2.7.2-1ubuntu2) ...

Setting up fuse-utils (2.7.2-1ubuntu2) ...
creating fuse group...
Adding group `fuse' (GID 113) ...
Done.
No override present.
Unable to load fuse module, but continuing anyway; please reboot to enable fuse
update-initramfs: deferring update (trigger activated)

Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Processing triggers for initramfs-tools ...



After Reboot:

root@ec2-:~# depmod -a
root@ec2-:~# modprobe fuse
FATAL: Module fuse not found.
FATAL: Error running install command for fuse

0
 
kenjaWAuthor Commented:
It looks like the Amazon EC2 image I was using didn't have that file.  

I finally solved it using:

mkdir -p /lib/modules/2.6.16-xenU/kernel/fs/fuse
cd /lib/modules/2.6.16-xenU/kernel/fs/fuse
rm -f fuse.ko
curl -O http://www.persistentfs.com/extras/ec2-linux-2.6.16-xenU/fuse.ko
/sbin/depmod
reboot

Followed by installing S3FS:

svn checkout http://s3fs.googlecode.com/svn/trunk/s3fs s3fs
make -C s3fs
cp s3fs/s3fs /usr/local/bin
export AWS_ACCESS_KEY_ID=<insert_access_key>
export AWS_SECRET_ACCESS_KEY=<insert_secret_access_key>
echo "$AWS_ACCESS_KEY_ID:$AWS_SECRET_ACCESS_KEY" > /etc/passwd-s3fs
chmod 600 /etc/passwd-s3fs
bucket=<s3_bucket_name>
mkdir -p /mnt/$bucket
/usr/local/bin/s3fs $bucket /mnt/$bucket

Thanks for your help!

0
 
kenjaWAuthor Commented:
Thanks for your help.  It got me on the right track where I ultimately found the solution.  
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 6
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now