We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

vista iis, created new virtual directory, getting error

Medium Priority
357 Views
Last Modified: 2012-06-21
I published from visual studio to a directory on my desktop.  When I try to load the page, I get this error:

The requested page cannot be accessed because the related configuration data for the page is invalid.


Config Error Cannot read configuration file due to insufficient permissions  

Is there some security settings I have to worry about?

I am very new to iis7
Comment
Watch Question

If you created a new virtual directory, you will need to give IIS permission to read from the folder that you pointed it to.

You can do this either through IIS, or you can simply right click on the folder that contains your virtual directory, and make sure that IUSR, IIS_IUSRS and Network Service have read access to the folder.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
grant the read permission to IIS_IUSRS to the folder where your web app is located.

Also it might be a better idea to convert your application to a web application via II7. To do this, simply right click in the folder within IIS7 and chose convert to Application option.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.