[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 471
  • Last Modified:

How to improve network throughput for Exchange 2007 SP1 CCR

Hello,
    I have an Exchange 2007 SP1 setup with CCR.  This is running on Windows 2008 servers.  I have to reseed all the storage groups on the passive node.  I ran one successfully using the wizard from the Exchange Management Console last night.  That was a 4 GB storage group and it took 7 hours to complete.  That seems to be an excessive amount of time, and with my largest storage group at 80 GB, that rate is very bad.  

   The hardware is Dell poweredge 2950s with dual quad core processers and 4 GB of RAM.  Network is Fast Ethernet.  The servers are located on the same subnet and not across a WAN link.  The servers are running Windows Server 2008 64 bit.

   Is there something I am missing to increase the rate that these databases can reseed?  Having a week long process to do this seems to defeat the purpose of a high availablity solution.  

   Thanks in advance.
0
lbicher56
Asked:
lbicher56
1 Solution
 
megs28Commented:
That is quite slow.  Keep in mind that it might not necessarily be the network causing the bottleneck.  Run some performance testing to ensure that it's not the disks attributing to a bottleneck, and you can also check out perf stats for your NICs.  Check that your AV software is configured properly.  Disable mapi/vapi scanning to see if performance improves.

As far as network bottlenecks go, you should be using 10/100/1000 not 10/100.  Ensure you don't have a duplex mismatch anywhere down the line either (switch to switch, client to switch, etc.).  Make sure your network cables are good.  Update the drivers on your NICs, etc.  Check here for more things to tweak relating to a CCR cluster:  http://technet.microsoft.com/en-us/library/bb123996.aspx
0
 
lbicher56Author Commented:
Thanks.  After one of my databases completed a reseed after 24 hours, I did some testing copying a 3GB file between the two boxes.  Copying over what I have designated as my public interface only took 4 minutes.  However, copying over my private interface calculated to be 4 hours.  And my throughput on the private interface matched what I saw during the reseed.  So that is the answer to my question.

Until I fix that, since I'm running update-storagegroupcopy via the Management console, if I run the command can I specify the public interface for now?  I know that may interfere with client access but I may need to take that risk.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now