• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4861
  • Last Modified:

Sql Server 2005 Setup Failed

During setup, when everything is done there is a screen that shows what all was installed and it has a "status" column. The item that is called "SQL Server Database Services" says "Setup Failed. Refer to the setup log for details."

In the setup log is has this...
=== Verbose logging started: 2/14/2009  12:56:02  Build type: SHIP UNICODE 3.01.4000.4042  Calling process: C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\setup.exe ===
MSI (c) (64:54) [12:56:02:015]: Resetting cached policy values
MSI (c) (64:54) [12:56:02:015]: Machine policy value 'Debug' is 0
MSI (c) (64:54) [12:56:02:015]: ******* RunEngine:
           ******* Product: E:\Servers\Setup\SqlRun_SQL.msi
           ******* Action: 
           ******* CommandLine: **********
MSI (c) (64:54) [12:56:02:015]: Client-side and UI is none or basic: Running entire install on the server.
MSI (c) (64:54) [12:56:02:015]: Grabbed execution mutex.
MSI (c) (64:54) [12:56:02:015]: Cloaking enabled.
MSI (c) (64:54) [12:56:02:015]: Attempting to enable all disabled priveleges before calling Install on Server
MSI (c) (64:54) [12:56:02:015]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (F8:C4) [12:56:02:030]: Grabbed execution mutex.
MSI (s) (F8:BC) [12:56:02:030]: Resetting cached policy values
MSI (s) (F8:BC) [12:56:02:030]: Machine policy value 'Debug' is 0
MSI (s) (F8:BC) [12:56:02:030]: ******* RunEngine:
           ******* Product: E:\Servers\Setup\SqlRun_SQL.msi
           ******* Action: 
           ******* CommandLine: **********
MSI (s) (F8:BC) [12:56:02:030]: Note: 1: 2203 2: E:\Servers\Setup\SqlRun_SQL.msi 3: -2147287010 
MSI (s) (F8:BC) [12:56:02:030]: MainEngineThread is returning 1620
MSI (c) (64:54) [12:56:02:030]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (c) (64:54) [12:56:02:030]: MainEngineThread is returning 1620
=== Verbose logging stopped: 2/14/2009  12:56:02 ===

Open in new window

0
bloomk
Asked:
bloomk
1 Solution
 
Raja Jegan RSQL Server DBA & ArchitectCommented:
Do you have the necessary Pre-requisites installed in your machine.
0
 
Vitor MontalvãoMSSQL Senior EngineerCommented:
What's your server box?
OS + SP?
And wich edition of SQL Server are you trying to install?
0
 
bloomkAuthor Commented:
The Problem was caused by a file in the setup being corrupt. I had uploaded the contents of the disk to my server for install and some files had gotten corrupt. So i uploaded a zip of the disk instead. Problem solved.
0
 
netdbaCommented:
Here is a link i used it resolved my installation issue

http://support.microsoft.com/kb/968749
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now