Windows Server 2003 won't boot past logo screen

Posted on 2009-02-14
Last Modified: 2012-06-27
I am installing Windows Server 2003 standard edition onto a Dell Power Edge 6650.  It has a hardware raid controller that supports 5 drives running raid 5.

The system completed the installation but when it tried to log into Windows, it never got past the logo screen.  When I booted in safe mode, the last line that displayed was a line loading the file drvmain.stb.

There is a bios switch that reads "OS Install Mode" and when I set it to "Yes", it limits the amount of RAM to 256MB.  When I turn this switch on, Windows will boot up and everything works fine (slow but fine).

I have ran memory tests over and over.  I have tried 2GB configuration and 4GB configuration.  I do not see any memory issues.  Hardware reports show that everything is fine.

Has anyone seen this in the past and have a possible fix suggestion?

Thanks in advance.
Question by:bigdogkbl
    LVL 76

    Expert Comment

    LVL 6

    Assisted Solution

    Having myself installed 2003 onto about 1300 dell servers the best way to do it is this:

    1. Download open manage for that server
    2. Use the dell oem cd (There ARE drivers! slipstreamed into the image on the CD)
    3. Let the open manage cd build the raid array (which means all data will be deleted and
    the partition will be recreated, i suggest using the full size of the disk)
    4. Then complete the install (insert the cdkey into the screen)

    If that fails....

    Verify that your perc is working (you definitely have a perc card unless it was removed, or not provided)
    Verify that you have the latest firmware and bios for you server

    LVL 12

    Expert Comment


    Turn off OS-Install-Mode.
    Reinstall OS. (format OS drive to fat32)

    Great is our GOD.

    Author Comment

    Sorry that I did not include the following information in my original post.

    I did use the latest version (I thought) of the latest version of the Open Manage Server software from Dell that works with the poweredge 6650 machine.  I let it configure the raid controller using my preferred raid 5 setting.  I then let it prompt me for the operating system disk and then let it complete the windows installation.  I will double check the version that I used and compare it to the link included by arnold.

    I had it format the drive using NTFS.  I let it use the full size of the drive although it automatically reserved a certain amount for the utility partition.  I saw no way of avoiding that (not that I would have avoided it anyway).

    I do have a PERC card.  I am not sure if there is anything else I can do to test that it is working other than what I have done:
    - Ran hardware test and the controller card reported no errors.
    - Verified that the number of drives and the amount of disk space that it detected was correct during the configuration.

    One of the replies to my original post suggested using fat32 when formatting the drives.  Is it really not suggested to use NTFS?

    Thanks for the continued support.
    LVL 76

    Assisted Solution

    Which version of Win2k3 Standard are you using, R2, SP1, SP2?
    I think the issue you have is because you use the full drive.
    Since currently you have no data, Rebuild the OS with 30GB for the OS and the rest for application/data.
    And see whether you get better results this way.
    Also check whether you are setting the Caching on the Perc for direct I/O, Cached I/O, write through, or write Back.  You can make these adjustments through the Perc Bios without corrupting the data.

    I would have recommended to have a RAID 1 for the OS and the remaining three drives in a RAID 5. Perc and raid 5, check firmware version and make sure they are up-to-date.  I think there was a firmware version that had issues with RAID 5 under certain circumstances.

    Accepted Solution

    As it turned out, there was a hardware memory issue.  The memory diagnostics from the Dell Utility partition reported no errors with memory.  I downloaded a third party memory diagnostic utility and it found 340 errors in the memory above 500mb which would explain why the OS switch to restrict memory to 256 allowed me to boot normally.

    Thanks to all for the help with this.  My apologies that the issue turned out to be this simple.  I wish the dell utilities would have found this in the first place.

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    Join & Write a Comment

    My purpose is to describe the basic concepts of virtual memory as implemented in a modern Windows-based operating system. I will also describe the problems inherent in older systems and how virtual memory solves them. The dark ages - before virtu…
    Log files are useful in diagnosing and repairing problems.  This is a list of common log files and their standard locations that I've compiled.   While this is not exhaustive, it is a pretty good list that I've found to be useful.  I may update it f…
    This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
    With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    20 Experts available now in Live!

    Get 1:1 Help Now