[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 454
  • Last Modified:

Error 85010014

I know this has been discussed a lot before, but I haven't yet been able to find a solution.  For a few wondrous, beautiful days I had my smart (?) phone connected to my exchange server, and it was working like a champ.  Then suddenly it stopped working (after some MS update, but I don't know if that had anything to do with it.)  Now it won't work at all.  I have gone over every Technet and Expert-Sexchange article I can find, and nothing is working.  I've created the new virtual directory, and that hasn't worked either.  I reinstalled the Small Business Server and recreated the domain, all for naught.  I'm still getting the error in the title.

I've even turned off the required SSL, and it's not working.  Is this just some update that has trashed the ability to connect to my exchange server over my smart phone (Windows Mobile 6.*)?  I'd pay actual money at this point to get it working (not really, but still...)
0
TheRealPCRob
Asked:
TheRealPCRob
  • 6
  • 4
  • 3
  • +1
2 Solutions
 
RaghuvCommented:
Ok, since you already tried lot of stuff, I would suggest we start from the basic....I am assuming we have Exchange 2003 here.....

1) Disable FBA for Outlook Web Access and ensure the Exchange Virtual Directory has Windows Integrated + Basic Authentication selected.

2) Ensure you do not have Exchange-OMA virtual directory under IIS, which is created by default in SBS (We can create this later on, but for now, delete it).

3) Delete the registry key called "ExchangeVDir" located at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters

4) Ensure Microsoft-Server-ActiveSync does not have the option "Require SSL" enabled.

5) Also check and remove any IP address restriction from all the virtual directories (Default Website, Microsoft-Server-ActiveSync, Exchange etc) [Right click on the required Virtual directory & choose properties -> Choose Directory Security tab -> Click on the 2nd Edit button -> Remove any IP addresses listed]

Try the above steps and then create a new fresh ActiveSync profile on your Mobile device and ensure to uncheck the option for SSL.


0
 
RaghuvCommented:
And if you are comfortable performing the above steps then check out the link -> http://www.pocketpcfaq.com/faqs/activesync/exchange_errors.php
0
 
unnivishwanathanCommented:
-After you verify the steps suggested by Raghu also please check the following :-

1) Update your Massync.dll : http://support.microsoft.com/kb/957191

2) Disable the FAMv4 service

a). Open REGEDIT.exe
b). Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
c). Look for FAMv4 under the Services Key.
d). Set the "Startup" value to 4 so that it disables the FAMv4 service.
e). Open a Cmd prompt.
f). Type NET STOP FAMV4. This stops the FAMv4 service.

3) Perform an IISreset and then try activesync
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
TheRealPCRobAuthor Commented:
Raqhuv: Thanks for the response.  Yes, I have SBS 2003, which means it's Exchange 2003, and Exchange also has SP2.

I followed your instructions, and though you didn't say it I went ahead and reset the IIS service.  I setup the new ActiveSync connection to the server, unchecking the SSL required, and let it do it's thing.  It ran through the sync process (all the local syncing works fine, by the way) 3 or 4 times and finally gave the same error 85010014.

Just for thoroughness, I also disconnected the phone and tried a send/receive to see if it would work, but of course it did not.  I got an "error syncing" message.

unnivish: There is no FAMv4 service on my server.
0
 
RaghuvCommented:
Hi, not sure what you meant by "I also disconnected the phone and tried a send/receive", I hope you are not using Desktop Sync :), anyways just for confirmation, can you try accessing OWA on your Mobile device....

Also I hope you have followed KB article http://support.microsoft.com/kb/957191 & updated your Massync.dll as mentioned by Unni.....

The steps I gave you earlier is the basic setup for ActiveSync to work.....since it's still not working, I would suggest you to install a Windows Mobile Emulator on a Computer which is on the same network as your Exchange and then try configuring it with local IP address of the Exchange server.

For installing and configuring Mobile Emulator, check this out -> http://msexchangeteam.com/archive/2007/09/17/447033.aspx
0
 
MesthaCommented:
Another option would be to use a test account on the MS test site:
https://www.testexchangeconnectivity.com

Is this SBS 2003 R2 or the original SBS 2003?
SBS 2003 R2 does the changes that are outlined in 817379 automatically. The RTM version does not and that can cause problems.

The error code is an authentication issue, which SBS RTM with service packs is actually prone to.

-M
0
 
TheRealPCRobAuthor Commented:
Raqhuv: as a matter of fact, I am using desktop sync.  At the moment, it's the only sync I have.  It's also not working if I try to set it up directly through the phone.  By the way, why wouldn't I set it up through the desktop sync, since it has a facility for adding the server, choosing the sync options, and I can use a real keyboard to enter the password?  

Mestha: thanks for the link; that could help.  One problem I'm running into currently is that if I use mail.domainname.com for the active sync test, it connects and everything but fails because the certificate is for www.domainname.com.  If I use www.domainname.com it fails immediately and says there's no exchange server there.

Should my certificate be for mail.domainname.com?  Everything I read when setting it up said to use the actual common name of the domain, but I'm not going to run SSL on my actual website, so maybe it should be the mail.domainname.com.  Hmm, I'll try that while waiting for any additional response.
0
 
TheRealPCRobAuthor Commented:
Update:  somewhere in all of the steps from above, OMA no longer works.  When I try to go there I get a message saying OMA only works on exchange 2003, and my mailbox is stored on an older version of exchange.  I've re-ran the Configure E-Mail and Internet Connection Wizard and followed the steps in article 81737, but neither works.

Is there any reliable way to get this part, at least, running again without reinstalling SBS (and therefore the whole dang domain) again?
0
 
MesthaCommented:
The certificate needs to match the name that you are using to access Exchange. If your exchange server is not on the www address then you need to change it. Certificate mismatch is a hard failure for this configuration.

It is key whether this is SBS RTM or SBS R2. They have different behaviours.
817379 is done by R2 automatically, not by RTM.
If you have RTM then undo what you did for 817379, including the registry change and the additional virtual directory. Then run the Configure Email and Internet wizard again.
That should get things back to the default state.
Then follow the instructions on my web site here:
http://www.amset.info/exchange/mobile-85010014.asp

-M
0
 
TheRealPCRobAuthor Commented:
I apologize, Mestha, I thought I'd already specified that I do have SBS 2003 R2.  I have undone 817379 and ran the wizard again, but to no avail.  I then re-applied 817379 and still no luck.  You said to do that if I have RTM, but did you mean if I have R2?

Well, either way it's not working.  As I said above, even OMA isn't working now.  Fortunately I'm the only one currently who would have used it in my organization.

Both the www and mail go to the same server, so perhaps that doesn't matter.  Either way, now I'm just getting the message that the certificate is invalid because it's self-signed.  Considering this is just for our use, I'm not willing to pay a yearly ransom to convince my own phone that my own mail server is valid.
0
 
MesthaCommented:
Self signed certificates are notorious for causing problems with this feature. One of the primary recommendations is to switch to a commercial certificate. It protects all web services on the server, so that would include RWW, Exchange, Outlook over the Internet, Exchange ActiveSync and OMA. With no certificate prompts.

SBS R2 should be making the changes that 817379 does for you.
Try running the wizard again, choose to turn off all of the remote settings and allow the wizard to complete.
Then run the wizard again to reset things.

Failing that, you could reset the virtual directories: http://support.microsoft.com/default.aspx?kbid=883380
After doing that you will need to run the wizard again.

-M
0
 
TheRealPCRobAuthor Commented:
Mestha: Thanks again for your quick response.  Well, I tried the first step, running the wizard to turn it all of, then running it again to turn on the exchange and oma over the web.  The exchange works, but oma still doesn't.

I'll try one of the two suggestions in the linked article later this morning and let you know.
0
 
TheRealPCRobAuthor Commented:
Mestha: I was able to get all the virtual directories reset following the instructions in that article, and thanks for that.  I've also got the phone syncing with the exchange server, though I don't feel real good about it.  I basically had to remove SSL from everything, including the exchange, active sync, and OMA virtual directories, and turn off FBA (basically what Raqhuv was trying to get me to above.)  I just don't like having to turn off all security in order to get this to work.

On the other hand, my partner's iPhone can now connect to the Exchange server, so he's happy.  I'm tempted to keep screwing around with it to see if I can make it work with SSL, but I don't know if it's worth it.

Anyway, I'm going to see if I can figure out how to award these points.  Mestha, your information was the most helpful, so you'll get more points.  Raqhuv, your information was also helpful, and did solve my original problem, but it wouldn't have worked at all without Mestha's information, so you'll get fewer points.

Thanks to both of you, though.
0
 
MesthaCommented:
Don't confuse the require SSL option with the ability to use SSL. They are not the same. You can block port 80 and use exclusively port 443 if you wish, and you will be using SSL. It is the require SSL setting that causes problems.

-M
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 6
  • 4
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now