?
Solved

Not enough server storage is available to process the command

Posted on 2009-02-14
8
Medium Priority
?
4,151 Views
Last Modified: 2013-11-30
2 workstations. Both XP Pro. Desktop and Laptop. Cannot map the drive. I've been trying to sort this out for my client remotely but have tried everything I can think of. Both workstations are in my workshop connected to my network with the same workgroup. It doesn't seem to be the laptop at fault because I tried mapping the same drive from my main XP PRO workstation at my shop but still the same error so the problem is with the PC itself. I have changed the IRPStackSize as suggested below
RESOLUTION
Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this issue, increase the value of the IRPStackSize registry entry. To do this, follow these steps:1. Click Start, click Run, type regedit, and then click OK.  
2. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
If the IRPStackSize entry is not present in this subkey, follow these steps:a.  Click Edit, point to New, and then click DWORD Value.
b.  Type IRPStackSize, and then press ENTER.

Note Type IRPStackSize exactly as it appears. The value name is case sensitive.
 
3. Click IRPStackSize, click Edit, and then click Modify.
4. In the Data Value box, type a larger value, and then click OK.

Note Values may range from 0x1 to 0xC. These values are equivalent to 1 to 12 in decimal notation.
If the problem persists after you complete the previous procedure, increase the value of IRPStackSize more.

Still Same problem. I have uninstalled Service Pack 3. S
Still Same problem. I have also uninstalled all network properties eg. File and Print Sharing for Microsoft Networks, Microsoft TCP/IP 6 Internet Protocol TCP/IP, Client for Microsoft Networks. NWLink IPX/SPX Netbios Compaitible Transport Protocol.

Restarted and have reinstalled each one.

I also have increased virtual memory as also suggested in another post.

I'm running out of options and do not wish to backup and reinstall everything.

Please HELP!!!
0
Comment
Question by:KCComputers
8 Comments
 
LVL 5

Expert Comment

by:BarsMonster
ID: 23644100
Could you try IRPStackSize like 100?
You do this on server, right?
Could you verify that after reboot value in registry is the same?

Also, make sure you are modifying in "/CurrentControlSet/"
0
 

Author Comment

by:KCComputers
ID: 23644535
I have changed the IRPStackSize to 100 and rebooted. It is in /CurrentControlSet and the registry change was saved to 100. I have also uninstalled service pack 3 back to 2 as well. What next? Any ideas?
0
 
LVL 23

Accepted Solution

by:
Mysidia earned 2000 total points
ID: 23645197
The highest you should ever try to set IRPStackSize to is  32 in hexadecimal, or 50 in decimal.

Which machine(s) have you applied the change to?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:KCComputers
ID: 23646012
Ok, Have changed IRPStackSize back to 32 in hexadcimal and rebooted. Still same problem. What next?
0
 

Author Comment

by:KCComputers
ID: 23646058
I just rebooted both Server and Workstation and it finally works. Will install service pack 3 again and make sure that the settings stay the same.
0
 
LVL 23

Expert Comment

by:Mysidia
ID: 23646111
Did you apply this configuration to the Workstations, the server, or both?

What version of Windows is the file server running?
0
 

Expert Comment

by:anglittle
ID: 25993555
I had the same issue and set the IRPStackSize to decimal 12 and it did not work.  However changing the value to decimal 50 did work.
0
 
LVL 1

Expert Comment

by:GaryScott
ID: 32655340
do you use Acronis True Image ? that mihgt be a culprit.
0

Featured Post

Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is a collection of issues that people face from time to time and possible solutions to those issues. I hope you enjoy reading it.
Make the most of your online learning experience.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…

580 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question