We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now


Not enough server storage is available to process the command

Medium Priority
Last Modified: 2013-11-30
2 workstations. Both XP Pro. Desktop and Laptop. Cannot map the drive. I've been trying to sort this out for my client remotely but have tried everything I can think of. Both workstations are in my workshop connected to my network with the same workgroup. It doesn't seem to be the laptop at fault because I tried mapping the same drive from my main XP PRO workstation at my shop but still the same error so the problem is with the PC itself. I have changed the IRPStackSize as suggested below
Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this issue, increase the value of the IRPStackSize registry entry. To do this, follow these steps:1. Click Start, click Run, type regedit, and then click OK.  
2. Locate and then click the following registry subkey:
If the IRPStackSize entry is not present in this subkey, follow these steps:a.  Click Edit, point to New, and then click DWORD Value.
b.  Type IRPStackSize, and then press ENTER.

Note Type IRPStackSize exactly as it appears. The value name is case sensitive.
3. Click IRPStackSize, click Edit, and then click Modify.
4. In the Data Value box, type a larger value, and then click OK.

Note Values may range from 0x1 to 0xC. These values are equivalent to 1 to 12 in decimal notation.
If the problem persists after you complete the previous procedure, increase the value of IRPStackSize more.

Still Same problem. I have uninstalled Service Pack 3. S
Still Same problem. I have also uninstalled all network properties eg. File and Print Sharing for Microsoft Networks, Microsoft TCP/IP 6 Internet Protocol TCP/IP, Client for Microsoft Networks. NWLink IPX/SPX Netbios Compaitible Transport Protocol.

Restarted and have reinstalled each one.

I also have increased virtual memory as also suggested in another post.

I'm running out of options and do not wish to backup and reinstall everything.

Please HELP!!!
Watch Question

Could you try IRPStackSize like 100?
You do this on server, right?
Could you verify that after reboot value in registry is the same?

Also, make sure you are modifying in "/CurrentControlSet/"


I have changed the IRPStackSize to 100 and rebooted. It is in /CurrentControlSet and the registry change was saved to 100. I have also uninstalled service pack 3 back to 2 as well. What next? Any ideas?
The highest you should ever try to set IRPStackSize to is  32 in hexadecimal, or 50 in decimal.

Which machine(s) have you applied the change to?

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts


Ok, Have changed IRPStackSize back to 32 in hexadcimal and rebooted. Still same problem. What next?


I just rebooted both Server and Workstation and it finally works. Will install service pack 3 again and make sure that the settings stay the same.

Did you apply this configuration to the Workstations, the server, or both?

What version of Windows is the file server running?
I had the same issue and set the IRPStackSize to decimal 12 and it did not work.  However changing the value to decimal 50 did work.
do you use Acronis True Image ? that mihgt be a culprit.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.


Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.