Proliant ML350 tries to boot from ext USB drive before HDD

Posted on 2009-02-15
Last Modified: 2012-05-06
We have a number of ML350s and do our backups to disk. We have never had a problem until we upgraded the 500 GB Iomega external USB drives to 1 TB ones. At every server reboot (after updates for example) the server tries to boot from the external USB drive.
We have tried everything I can see in the BIOS. The boot order is for the RAID controller first, and boot drive order is C: then DROM then NIC then USB.  The USB drive is recognized in the BIOS as C:, and I think this may we were the problem arises, but I see no way of changing this in the BIOS level the Iomega is listed as H: once the OS starts up.
The odd thing is that its not consistent, we have 12 identical servers with the same BIOS setups and Iomega drives, some will start up others not (or maybe on the third or fourth reboot).  If I set the boot order to be CDROM then C:, then its guaranteed they will attempt to boot only from the Iomega.
We have the latest version of the BIOS on all computers. Any suggestions welcome!
Question by:crolfe
    LVL 13

    Expert Comment

    have you tried updating the ROM on the SMARt Array controller on the affected machines as well as the main internal ROM

    The fact that it's not consistent would seem to indicate there is a difference and a difference in SA ROM could be it

    Not a definite solution but maybe a first step


    Author Comment

    Thanks, 2610 SA controllers all have the same BIOS that is the lastest version. I found the source of the 'inconsistency': cold boots are OK, warm boots not.

    Cold reboot (power off totally) : the Proliant splash screen is displayed first (before the memory test). After the lengthy boot process, the F9 setup/F10/F12 menu is displayed on the screen (briefly). Then it says attempting to boot from C: and goes into windows as it should.

    Warm reboot (restart from OS) : no Proliant splash screen
    No  F9 setup/F10/F12 menu
    blinking cursor at the point where F9/F10/F12 should be coming up.

    This is repeatable on all servers. The problem of course is that updates initiate a warm reboot.
    LVL 26

    Expert Comment

    Try to get in your BIOS --> Advance options --> Option ROM loading sequence --> Load Embeded Device First

    Reboot and let us know the result.


    Author Comment

    Sounded good, but i don't have that option anywhere in the BIOS, under advanced I have:
    MPS table
    ROM selection (current or backup)
    NVRASM erase
    nmi debug
    drive write cache
    expansion card caching optimization
    processor options legacy serrr

    Boot controller order is:
    1. PCI slot 3 RAID
    2. HP integrated PCI IDE
    3. Intel SATA

    Boot order: IPL
    1. HDD C:
    2. CD ROM
    3. Floppy
    4. USB Drivekey (C:)
    5. NIC

    I am puzzled why is works OK from a cold boot, but not a warm boot

    Thanks for the suggestions

    LVL 26

    Expert Comment

    Here is what you may try to do on Windows registry to disable USB boot

    1. Click Start, and then click Run.
    2. In the Open box, type regedit, and then click OK.
    3. Locate, and then click the following registry key:


    4. In the right pane, double-click Start.
    5. In the Value data box, type 4, click Hexadecimal (if it is not already
    selected), and then click OK.
    6. Reboot your server.


    Author Comment

    Unfortunately this did not work either. The problem is that all this is happening before windows starts. After a warm boot, at the point when it should say F9 setup etc the cursor just sits there blinking. \

    A cold boot works OK: sequence is as follows:
    F9 setup F10etc  
    -- attempting to boot from drive C: -
     starting windows
    LVL 26

    Accepted Solution

    I guess so. The only place that you may have to reconfigure is your Bios. Try to get around the Bios options and reconfigure any USB options. Write down what you did and if it does not work, come back and put it back then change another one. I don't have a ML350 to test for you. All of our HP are either DL380, DL580, or ML570.... they may have different bios option..., but theorically, they should function the same.


    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Join & Write a Comment

    Suggested Solutions

    Title # Comments Views Activity
    Bitcoin  mining server setup 5 43
    VM host RAID 8 56
    Server memory config 4 16
    Local storage vs SAN for VM's 10 41
    Usually shares are where we want them for our users and we tend to take them for granted. There are times, however, when those shares may disappear causing difficulty for your users. One of the first things to try is searching for files that shou…
    Learn about cloud computing and its benefits for small business owners.
    It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
    This video is in connection to the article "The case of a missing mobile phone (". It will help one to understand clearly the steps to track a lost android phone.

    755 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    21 Experts available now in Live!

    Get 1:1 Help Now