[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1101
  • Last Modified:

How to open ports for eMule Cisco ASA 5505

I can't open tcp 4662 port in my new firewall Cisco ASA 5505. I wish to permit the traffic from the outside to one pc on my lan. The pc Ip on the lan is 10.0.0.9 and I wish to open port 4662 TCP.
I have use these:

access-list outside_access_in extended permit tcp host 10.0.0.9 interface outside eq 4662
static (inside,outside) tcp interface 4662 10.0.0.9 4662 netmask 255.255.255.255
but the mule dosen't work.

this is now my running-config on cisco

Firewall# sh running-config
: Saved
:
ASA Version 8.0(4)3
!
hostname Firewall
domain-name driussi.it
enable password Nhcxxt5YNCRoLPm9 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.0.0.254 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 192.168.1.253 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name driussi.it
access-list acl_icmp extended permit icmp any any
access-list outside_access_in extended permit tcp host 10.0.0.9 interface outsid
e eq 4662
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-615.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 4662 10.0.0.9 4662 netmask 255.255.255.255

access-group acl_icmp in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.1.254 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.0.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
management-access inside
dhcpd address 10.0.0.20-10.0.0.33 inside
dhcpd dns 192.168.1.254 interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:bb98c1c4d6e8c7953197b10d8751ea2b
: end



0
Dampyr
Asked:
Dampyr
  • 3
  • 2
1 Solution
 
lrmooreCommented:
>access-list acl_icmp extended permit icmp any any
>access-list outside_access_in extended permit tcp host 10.0.0.9 interface outside eq 4662
>access-group acl_icmp in interface outside

Modify these as follows:

access-list outside_access_in permit tcp any interface outside eq 4662
access-list outside_access_in permit icmp any any echo-reply
access-list outside_access_in permit icmp any any unreachable
access-group outside_access_in in interface outside
0
 
Pete LongConsultantCommented:
curious
wold it not be better to
policy-map global_policy
 class inspection_default
  inspect icmp
and not bother with
access-list outside_access_in permit icmp any any echo-reply
access-list outside_access_in permit icmp any any unreachable
 
pl
0
 
lrmooreCommented:
Supposedly same result, but I've seen different results in different versions of PIX/ASA code. "old school" always works.  Keeping me on my toes, mate!
<8-}

0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
DampyrAuthor Commented:
No, whith this configuration emule doesn't work. I have always  ID down
i don't know what i must do......
0
 
lrmooreCommented:
Maybe you want to open UDP 4672 also?
http://portforward.com/cportsnotes/emule/eMule.htm

static (inside,outside) udp interface 4672 10.0.0.9 4672 netmask 255.255.255.255
access-list outside_access_in permit udp any interface outside eq 4672
0
 
Pete LongConsultantCommented:
>>Keeping me on my toes, mate
 
LOL, no - just wanted to know what you thought :)
0

Featured Post

Choose an Exciting Career in Cybersecurity

Help prevent cyber-threats and provide solutions to safeguard our global digital economy. Earn your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now