• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 751
  • Last Modified:

My favicon wont show up for some viewers and it won't show in IE?

I have just added the favicon.ico to my website.
I can see it ok with Mozilla, but I cannot see it IE.

Other viewers cannot see it in any browser

What have I done wrong?

I simply added this into the head of my index page:
<link rel="icon" href="www.avitalsheffer.com/favicon.ico" type="image/x-icon" />
<link rel="shortcut icon" href="www.avitalsheffer.com/favicon.ico" type="image/x-icon" />

Can someone help please?
0
Amanda Watson
Asked:
Amanda Watson
  • 11
  • 10
2 Solutions
 
Amanda WatsonAuthor Commented:
0
 
David S.Commented:
Try converting it from JPEG format to GIF format.
0
 
Amanda WatsonAuthor Commented:
Ok
I tried that.
I am not seeing it in IE or noone else is seeing it in Mozilla.

I can see it in Mozilla still...

What is wrong>
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
Amanda WatsonAuthor Commented:
I just tested on another computer and I cant see it anywhere

Can anyone else see it?

0
 
knonieCommented:
Try it without using: type="image/x-icon"

Sometimes, favicon doesn't show up instantly on the site we are developing, perhaps because of cache.
So, it's always good to Refresh your browser using Ctrl and F5 together.
If it doesn't work, check it on other PC.

If you still can't see in on any other PC, check your "ico" files if they are created corrected.
Or use this site to create one from image:
http://www.html-kit.com/favicon/

:-)



<link rel="shortcut icon" href="favicon.ico">

Open in new window

0
 
knonieCommented:
And yes, the MOST IMPORTANT,
which I guess is the real problem:

Put "http://" in ico source field.
Starting a URL with www is not a standard way.

:-)





<link rel="shortcut icon" href="http://www.avitalsheffer.com/favicon.ico">

Open in new window

0
 
Amanda WatsonAuthor Commented:
Great that has solved the problem on Mozilla but I still can't see it on IE?
0
 
knonieCommented:
Check your ico file...
Perhaps something wrong with that.

If I view ico file's URL, i.e. http://www.avitalsheffer.com/favicon.ico
It displays that image unavailable icon.

You may try a new favicon using the site I mentioned earlier.

:-)
0
 
Amanda WatsonAuthor Commented:
Perfect answer
0
 
Amanda WatsonAuthor Commented:
sorry, knonie, its still not showing in IE?
0
 
knonieCommented:
The icon should by 16 x 16 px, while yours one is 32 x 32.
I guess perhaps that's the problem why IE is not supporting it.

Have you tried creating a new icon and testing it?

Just create a test icon in a standard way, and see.

Also, I suggest you to remove the double reference to favicon file in
Because it's not needed.

:-)

<!-- Remove the line below -->
<link rel="icon" href="http://www.avitalsheffer.com/favicon.ico" type="image/x-icon" /> 
 
<!-- Keep this line only -->
<link rel="shortcut icon" href="http://www.avitalsheffer.com/favicon.ico"> 

Open in new window

0
 
Amanda WatsonAuthor Commented:
Ok, I deleted that line and I used the link you provided to create the favicon so I don't know why it would be the wrong size and format etc.

wouldn't it be ok?

Can you see it in IE?
0
 
knonieCommented:
Everything seems correct, but still not working.

Now, another option that you can try is placing your favicon in the same directory as your HTML files,

And use this HTML code:
<link rel="shortcut icon" href="favicon.ico" type="image/x-icon" /> 

Open in new window

0
 
Amanda WatsonAuthor Commented:
Well it is already in the root as my html files?  That is, its in the same folder as my index.html page?

but still can't see it in IE.

??

How does everyone else do it?
0
 
knonieCommented:
Your site's HTML pages are currently placed inside a folder named "newsite"
While your favicon is placed on root.

Just place your favicon inside the folder "newsite",
and then, give the relative path to favicon in html code, as advised in my last post.

:-)
0
 
Amanda WatsonAuthor Commented:
ive just posted it live to test, and still not there
0
 
knonieCommented:
Do you have some other domain/hosting where we can upload and test this site,
Because I have applied favicons for twenties of sites this way, and never got any issue.

Code syntax is correct,
ico file is correct,
File path is correct,

Then what else is preventing it... It's quite confusing...

:-)
0
 
Amanda WatsonAuthor Commented:
Could it be a setting on my IE broswer?
0
 
knonieCommented:
I've never heard of any settings in browser that prevents only favicon loading.

If it's with browser, you shouldn't be seeing Experts-Exchange's icon, as well as Yahoo! and MSN,
but I guess you can see all of them except your site.

The thing is that it's also not showing at my end as well.

Check this URL in your IE:
http://avitalsheffer.com/newsite/favicon.ico

Do you see any image on the page, top-left corner?
I can't see it. [But an image-unavailable icon is there]

Now check this one in IE:
http://www.experts-exchange.com/favicon.ico
Can you see an image on the page?

I suspect something might be on your hosting server that's preventing it...
But can't say...

:-)


0
 
knonieCommented:
I guess there's something wrong again with your Favicon file.

As I remember, it was visible yesterday inside the IE page if viewed via this:
http://avitalsheffer.com/newsite/favicon.ico

I'm testing it on my test server, to see if it's something wrong with your ico, or server settings.

:-)
0
 
knonieCommented:
Eureka!!!
Working now...

Seems like something wrong with the icon file, although that site I mentioned above never created this issue earlier.

Visit this demo link:

http://tinyurl.com/ae4cbp
See, it's working.

Visit this link:
http://tinyurl.com/cl5a6m

It will display the icon. Right click and "save image as..."
Name it favicon, and replace your existing one.

It will work!

:-)

Note: Use this site to make favicons:
http://www.degraeve.com/favicon/

:-)
0
 
Amanda WatsonAuthor Commented:
You are so good!

Thanks for your help Knonie!

I hope to be getting your expertise again someday ;-)
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 11
  • 10
Tackle projects and never again get stuck behind a technical roadblock.
Join Now