• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1230
  • Last Modified:

Windows XP - attempt to access shared drives over LAN - username/password not accepted

Dear Experts,

I am attempting to connect to shared drives on my main desktop over my LAN from my laptop. Same problem when using another desktop.

When I enter my desktop username (has admin rights) and password it just reprompts me repeatedly.

My main desktop is running XP Pro SP3, the other PCs are running XP Pro SP2.

I have no problem accessing the Internet (via the LAN) from the laptop.

I do have a firewall (Online Armor v.3) installed and I am using windows firewall.
I have tried switching off Online Armor v.3, but it makes no difference.

I have enabled file sharing in folder options, also Everyone has Full Permissions.

I've checked both computer for some sort of security error to see if the problem is authentication related but there appears to be no logs on either computer.

I have looked at the Windows Firewall log (C:\WINDOWS\pfirewall.log) on the primary desktop (IP=192.168.1.99). The only entries relating to the laptop (IP=192.168.1.254) are of the form:

2009-02-16 17:00:11 OPEN-INBOUND TCP 192.168.1.254 192.168.1.99 1378 80 - - - - - - - - -
2009-02-16 17:00:11 CLOSE TCP 192.168.1.99 192.168.1.254 80 1378 - - - - - - - - -


Regards,
Leigh

0
LeighWardle
Asked:
LeighWardle
  • 17
  • 11
  • 4
  • +2
1 Solution
 
simsjrgCommented:
Are you using REMOTEPCNAME\USERNAME or LOCALHOST\USERNAME when trying to access it or are you just entering a username and password? In a home network or workgroup the easiest way around this is to create the same username and password on both machines. This will not require you to authenticate.
0
 
IIRRCommented:
Press start Button > Click Run Tab

net use z: \\remote_machine_ip_address\share_folder
0
 
LeighWardleAuthor Commented:
simsjrg:

REMOTEPCNAME is potoroo.
USERNAME is potoroo.

I am entering potoroo\potoroo as the username.

>> In a home network or workgroup the easiest way around this is to create the
>> same username and password on both machines. This will not require you to
>> authenticate

username=potoroo is an account on both PCs (using same password).
So why I am being asked to authenticate?

Regards,
Leigh
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
IIRRCommented:
If computer workgroups are diffrent ( example : remote=workgroup, local = homegroup ) you cant login remote computer !

You must use direct ip connection

Step By Step
1. Learn Remote Computer Ip Address. ( example : 192.168.2.3)
2. Learn Remote Computer share ( example c$ )

3. Press Start Button On your LocalMachine
4. Click Run Button
5. type "cmd" and press enter
6. when command promp is open type
"net use  z:\\192.168.2.3\c$"
press enter when

and wait

put your username and password if  asked

You Must see  "The command completed successfully"

then Press My Computer >  Local Disk ( z: )
0
 
MariusSunchaserCommented:
Both PCs are in the same Workgroup?
0
 
LeighWardleAuthor Commented:
Yes, both PCs are in the same Workgroup.
0
 
MariusSunchaserCommented:
Do you have Simple File Shring on or off on those computers?
0
 
LeighWardleAuthor Commented:
Marius,

Simple File Sharing was off on all computers.

I tried switching Simple File Sharing on for all computers.

Now attempting to connect to the shared folders gives a login prompt with the username set to Potoroo\Guest.  The username is grayed out and cannot be changed.

I have tried changing the password for Guest - but there is no option that lets me do this.

Regards,
Leigh
0
 
MariusSunchaserCommented:
No, turn simple file sharing off on both computers.
Make same accounts on each computer (same name same password). Give everyone full rights in the sharing tab, and give necessary permissions to users in the Security tab.
That should solve your problem.
Also, to improve security set a password for the default admin account (don't leave a blank password, set one) and disable guest account on each computer.
0
 
LeighWardleAuthor Commented:
Marius,

Following your suggestions, I:

* turned simple file sharing off on both computers.
* made same accounts on each computer (same name same password).
* gave everyone full rights in the sharing tab
* gave full permissions to Users (Potoroo\Users) in the Security tab.

But I still can't access the shared folder.

My default admin account already has a password.
I disabled the guest account on each computer.

Regards,
Leigh
0
 
LedigimateCommented:
The network user accounts don't need to be part of the Users group.

You may want to try the following:

* On the desktop computer, press Start > Run
* type
compmgmt.msc <enter>
* In the left pane, Double-click "System Tools", double-click "Local Users and Groups", and then click "Groups"
* Click the Action menu, and select "New Group..."
* Name the group "LANUsers"
* click the "Add" button to add the users to the members list
* click "Add" again and then click "Advanced"
* click "Find Now" and select "Authenticated Users" and add it to the list of members
* in the left pane, select "Users"
* in the right pane, double-click the user name(s) and select the "Members Of" tab
* Remove "Users" from the list.
* Close Computer Management
* Modify the shares' permissions to include the "LANUsers" group and give them full rights.
0
 
LedigimateCommented:
And you would then not have to enter the desktop computer's user name and password to access the share.  It should not prompt you for a user name or password if the user name and password used to log on to your laptop is the same as that created on the desktop computer.
0
 
LedigimateCommented:
in my suggestions above, I've assumed that the user names on the computers that require access to the share, are different from the desktop computer's local user account name.  Do not remove the "Users" group from the "Members Of" list for the desktop computer's local user account(s).
0
 
MariusSunchaserCommented:
In the security tab, in my setup, add "Authenticated Users". Try now.
0
 
LeighWardleAuthor Commented:
Hi Ledigimate,

I followed your suggestions.

Just made one change to this section:

>> * in the right pane, double-click the user name(s) and select the "Members Of" tab
>> * Remove "Users" from the list.

Here I added "LANUsers" to the "Members Of" list.

Still doesn't work.

Regards,
Leigh
0
 
LeighWardleAuthor Commented:
Marius,

>> In the security tab, in my setup, add "Authenticated Users". Try now.

That didn't work.

Regards,
Leigh
0
 
LedigimateCommented:
Just to eliminate possible causes, see if you can access the share with a different user name.
* Create a new password protected user account on your laptop and log on as that user.
* on the main desktop computer, using Computer Management: Create the same new user with same password and add that user to the "LANUsers" group, but REMOVE that user from "Users" group.  
* make sure "Authenticated Users" is a member of "LANUsers"
* in the shared folder's sharing tab, click Permissions, add "LANUsers" and give it full rights
* in the shared folder's security tab, give the necessary rights to "LANUsers"
After this if you can access the shared folder from the new user account on your laptop, then i suppose the issue is with the a user having the same name as the desktop computer's computer name.
0
 
LedigimateCommented:
see the following KB article:

http://support.microsoft.com/kb/310845/en-us
0
 
LeighWardleAuthor Commented:
Hi everyone,

I will be travelling for the next 3 days, will respond when I get back.

Regards,
Leigh
0
 
LeighWardleAuthor Commented:
Hi everyone,

Sorry it's been weeks since I have been able to find time to work on this issue.

Regards,
Leigh
0
 
LeighWardleAuthor Commented:
Hi Ledigimate,

>>Just to eliminate possible causes, see if you can access the share with a different >>user name.
>>* Create a new password protected user account on your laptop and log on as >>that user.
>>* on the main desktop computer, using Computer Management: Create the same >>new user with same password and add that user to the "LANUsers" group, but >>REMOVE that user from "Users" group.  
>>* make sure "Authenticated Users" is a member of "LANUsers"
>>* in the shared folder's sharing tab, click Permissions, add "LANUsers" and give it full rights

When I clicked the Permissions button I got this message:
"This has been shared for administrative purposes. The permissions cannot be set."

Regards,
Leigh
0
 
LeighWardleAuthor Commented:
Hi Ledigimate,

I have changed the User Names that were the same as one of my computer names.

I got a bit further:

>>Just to eliminate possible causes, see if you can access the share with a different >>user name.
>>* Create a new password protected user account on your laptop and log on as >>that user.
>>* on the main desktop computer, using Computer Management: Create the same >>new user with same password and add that user to the "LANUsers" group, but >>REMOVE that user from "Users" group.  
>>* make sure "Authenticated Users" is a member of "LANUsers"
>>* in the shared folder's sharing tab, click Permissions, add "LANUsers" and give it full rights
>>* in the shared folder's security tab, give the necessary rights to "LANUsers"

When I go to the the shared folder's security tab, I give the necessary rights to "LANUsers" - but after I click OK - I get an egg-timer that lasts for many minutes.
After I terminate that task the shared folder's security tab shows no mention of "LANUsers".

So I am still stuck.

Regards,
Leigh
0
 
LeighWardleAuthor Commented:
Hi Ledigimate,

I have changed the User Names that were the same as one of my computer names.

>>Just to eliminate possible causes, see if you can access the share with a different >>user name.
>>* Create a new password protected user account on your laptop and log on as >>that user.
>>* on the main desktop computer, using Computer Management: Create the same >>new user with same password and add that user to the "LANUsers" group, but >>REMOVE that user from "Users" group.  
>>* make sure "Authenticated Users" is a member of "LANUsers"
>>* in the shared folder's sharing tab, click Permissions, add "LANUsers" and give it full rights
>>* in the shared folder's security tab, give the necessary rights to "LANUsers"

Another step forward!
In the shared folder's security tab - "LANUsers" has the necessary rights.

But I still cannot connect to the shared drive from the laptop.

Regards,
Leigh
0
 
LeighWardleAuthor Commented:
Hi Ledigimate,

Are you still interested in resolving this issue?

Regards,
Leigh
0
 
LedigimateCommented:
Yes.  I'm sorry I didn't attend to this issue for quite some time.
To help me help you, I hope you won't mind doing the following for me:
Please run the attached batch script on each computer.  When running the batch script, a text file [computername].NETINFO.TXT will be created on the computer in the folder that contains the batch script.  For each computer, please copy the text file that was created by the batch script to the computer you are at now and then attach them to your next comment.  I would like to see if there's something obvious we've overlooked before it gets too complicated.

The attached batch script has been renamed with a .txt extension added to the file name.  When downloading it, please change the file extension from
.bat.txt
to
.bat
netinf.bat.txt
0
 
LeighWardleAuthor Commented:
Hi Ledigimate,

Sorry for the delay in getting back to you.

The outputs from the netinf.bat are attached.
(Potoroo is the desktop, Wind is the laptop).

Good luck,

Regards,
Leigh
netinfo.zip
0
 
LedigimateCommented:
Okay. I don't see anything wrong in the output you've posted. So now here's a few things I want you to look at and give me some feedback:

1. On the computer named POTOROO, right-click on the folder you've shared, and click "Sharing and Security..."

In the Sharing Tab, does the share name end with a $ sign?  If so, then it is probably an administrative share.  My guess is you've shared the root directory of your drive with simple file sharing turned off.  When sharing the root directory of your hard drive, Windows automatically treats it as an administrative share, setting the share name so you cannot type in your own, and permissions are set so that it cannot be changed and only users with administrative privilages can access that share.  Then, when attempting to access the share from the laptop, if prompted for a username and password, then enter the username of an administrator as follows:
POTOROO\username
and enter the password for that administrator.  You cannot use POTOROO\potoroo, as noted previously.
That only applies to administrative shares.  Administrative shares can only be accessed by users in the Administrators user group, and are not listed when you browse through the shares of a computer or when you use the net view command, but they are accessible by typing \\POTOROO\sharename$ in the run box or net use \\POTOROO\sharename$ at the command prompt.
If the share is not an administrative share, then you won't need to enter an administrator username and password to access the share.
All this wouldn't help much if at this point you're not even prompted for a username or password but instead get the "network path was not found" error.  In that case, chances are that youre not typing the correct share name, or your Windows firewall is not configured for File and printer sharing.  Make sure the following network ports are unblocked for the subnet:
TCP 139
TCP 445
UDP 137
UDP 138
If this helped, then great.  Otherwise, post back and we'll try something else.
0
 
LedigimateCommented:
Correction:  Administrave shares are created for local hard drives by default.  You may have to click "New share" to create a new share without a $ sign appended to the share name.
0
 
LeighWardleAuthor Commented:
Hi Ledigimate,

Still no joy!

I am doing my testing on Potoroo's D: drive.

The default share, D$, exists.
I can get a login prompt from the laptop by typing \\potoroo\d$ into the address field of File Explorer.
But when I enter the username of an administrator as follows:

POTOROO\Leigh

and enter the password for that administrator I just keep getting the prompt.

I already have a share called "D_Drive" and I get the same behaviour.

Regards,
Leigh
0
 
LeighWardleAuthor Commented:
Just another comment:

I have another PC called Bilby that has identical hardware to Potoroo.
It's C: drive was cloned from Potoroo on 31 January.
All of Bilby's file shares work.

So something has changed on Potoroo since 31 January that has broken it's file sharing?
0
 
LedigimateCommented:
The attached two batch scripts will try to do the following:

onpotoroo.bat will:
- remove the LANUsers group if it exists (since it didn't help),
- create a new password protected account named "TestUser" with "testpassword" as its password,
- remove "TestUser" from the "Users" group
- add "TestUser" to the "Administrators" group

onwind.bat will:
- do the same as onpotoroo.bat, and also
- attempt to map a network drive to "\\POTOROO\Drive_D (D)" with the username "POTOROO\TestUser" and the password "testpassword"

If you run onpotoroo.bat on POTOROO and then run onwind.bat on WIND, and it still reprompts repeatedly, even for "POTOROO\TestUser", then you might try installing SP3 on all the other computers too.  If then still no joy, then...er...uhm...well....uh..... then I think you could try requesting the help of some more experts.  Or I could ask you to post screen shots of all the settings you've made in your effort to make the shares accessible to see if I could spot something wrong.
onpotoroo.bat.txt
onwind.bat.txt
0
 
LedigimateCommented:
I meant,  "\\POTOROO\D_Drive (D)", not "\\POTOROO\Drive_D (D)".  The batch script has it typed correctly, though.
0
 
LeighWardleAuthor Commented:
Hi Ledigimate,

onpotoroo.bat worked OK.

But onwind.bat gave this output:


C:\>NET LOCALGROUP LANUsers /DELETE
System error 1376 has occurred.

The specified local group does not exist.


C:\>NET USER TestUser testpassword /ADD
The command completed successfully.


C:\>NET LOCALGROUP Users TestUser /DELETE
The command completed successfully.


C:\>NET LOCALGROUP Administrators TestUser /ADD
The command completed successfully.


C:\>NET USE * "\\POTOROO\D_Drive (D)" testpassword /USER:POTOROO\TestUser
System error 1130 has occurred.

Not enough server storage is available to process this command.

Regards,
Leigh
0
 
LedigimateCommented:
FINALLY!

To finally fix this problem you are required to change a registry setting on POTOROO.
It is best practice to always make a backup copy of the registry before editing the registry.

Follow these steps after creating a registry backup:

1. Open the Registry Editor (regedit.exe)
2. Find and click on the key
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
3. In the right pane, look for the IRPStackSize REG_DWORD value.  If you found it, proceed from step 6, otherwise:
4. Click the Edit menu > New > DWORD value
5. Rename the new value as
IRPStackSize
6. Double-click on IRPStackSize
7. In the "Edit DWORD value" dialog, select the "Decimal" option under "Base"
8. In the "Value data" box, type the value 21 and click OK.
9. Close Registry editor and restart the computer.

If after reboot it still doesn't work, then edit the IRPStackSize value again, add 3 to it and restart again.  If that didn't work then keep adding 3 until it works.  The maximum value for IRPStackSize is 50.  If you've added 3 and restarted without success until you've reached IRPStackSize 50, then change IRPStackSize back to 21 and post back for another possible solution.
0
 
LeighWardleAuthor Commented:
Hi Ledigimate,

You are a legend!!!
IRPStackSize = 21 fixed the problem.

Many, many thanks for your persistence in helping me fix the problem.

Regards,
Leigh
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 17
  • 11
  • 4
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now