[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 491
  • Last Modified:

Block internet access to specific computers

I have a cisco Pix setup and operational with VPN connectivity.  The problem is there are some users that will not quit going out to the internet.  I need to block them from getting to the internet.  I need VPN access to remote to all but do not want them getting out.  The computers that need to get out are 10.0.1.5, and 10.0.1.107  the others need stopped.
Result of firewall command: "show config"
 
: Saved
: Written by tthayer at 19:45:54.840 EST Thu Dec 31 1992
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxxxxxxxx encrypted
passwd xxxxxxxxxxxxxxxx encrypted
hostname MIMPIX
domain-name MIM
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list inside_outbound_nat0_acl permit ip any 172.16.1.0 255.255.255.224 
access-list split_tunnel_acl permit ip 10.0.1.0 255.255.255.0 any 
pager lines 24
icmp permit any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside pppoe
ip address inside 10.0.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool External_VPN_Pool 172.16.1.1-172.16.1.25 mask 255.255.255.0
pdm location 10.0.1.0 255.255.255.0 inside
pdm location 172.16.1.0 255.255.255.0 outside
pdm location 10.0.0.0 255.0.0.0 inside
pdm location 172.16.1.0 255.255.255.0 inside
pdm location 10.0.1.101 255.255.255.255 inside
pdm location 0.0.0.0 255.255.255.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 XX.XXX.XX.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+ 
aaa-server TACACS+ max-failed-attempts 3 
aaa-server TACACS+ deadtime 10 
aaa-server RADIUS protocol radius 
aaa-server RADIUS max-failed-attempts 3 
aaa-server RADIUS deadtime 10 
aaa-server LOCAL protocol local 
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication serial console LOCAL
aaa authentication ssh console LOCAL
aaa authentication telnet console LOCAL
aaa authorization command LOCAL 
http server enable
http 10.0.1.0 255.255.255.0 inside
http 172.16.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
sysopt connection permit-l2tp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client configuration address initiate
crypto map outside_map client authentication LOCAL 
crypto map outside_map interface outside
isakmp enable outside
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup MIMVPN_User address-pool External_VPN_Pool
vpngroup MIMVPN_User dns-server xxx.xxx.xxx.xx xxx.xxx.xxx.xx
vpngroup MIMVPN_User default-domain MIM
vpngroup MIMVPN_User split-tunnel split_tunnel_acl
vpngroup MIMVPN_User split-dns MIM.local
vpngroup MIMVPN_User idle-time 1800
vpngroup MIMVPN_User password XXXXXXXX
telnet 10.0.1.0 255.255.255.0 inside
telnet 172.16.1.0 255.255.255.0 inside
telnet timeout 5
ssh 10.0.1.0 255.255.255.0 inside
ssh 172.16.1.0 255.255.255.0 inside
ssh timeout 5
management-access inside
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname xxxxxxx@xxxxxx.net
vpdn group pppoe_group ppp authentication mschap
vpdn username xxxxxxxxx@xxxxxx.net password xxxxxxxx
dhcpd dns xxx.xxx.xxx.xx xxx.xxx.xxx.xx
dhcpd domain MIM
username tthayer password xxxxxxxxxxxxxxxx encrypted privilege 15
username admin password xxxxxxxxxxxxxxxx encrypted privilege 15
username Administrator password xxxxxxxxxxxxxxxx encrypted privilege 15
username chiggins password xxxxxxxxxxxxxxxx encrypted privilege 15
privilege show level 0 command version
privilege show level 0 command curpriv
privilege show level 3 command pdm
privilege show level 3 command blocks
privilege show level 3 command ssh
privilege configure level 3 command who
privilege show level 3 command isakmp
privilege show level 3 command ipsec
privilege show level 3 command vpdn
privilege show level 3 command local-host
privilege show level 3 command interface
privilege show level 3 command ip
privilege configure level 3 command ping
privilege show level 3 command uauth
privilege configure level 5 mode enable command configure
privilege show level 5 command running-config
privilege show level 5 command privilege
privilege show level 5 command clock
privilege show level 5 command ntp
privilege show level 5 mode configure command logging
privilege show level 5 command fragment
terminal width 80
Cryptochecksum:xxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Open in new window

0
Trygve Thayer
Asked:
Trygve Thayer
  • 3
  • 3
1 Solution
 
dsexton18Commented:
If you have a domain coltroler you could send IE to a loop back interface IE set up a proxy server and have it point to the local host 172.0.0.1..then they will go no where when they open up IE

http://forums.techarena.in/active-directory/1103911.htm

http://www.experts-exchange.com/OS/Miscellaneous/Q_21248374.html
0
 
Trygve ThayerAuthor Commented:
No domain controller involved.  I really need to do this on the pix.
0
Become a Leader in Data Analytics

Gain the power to turn raw data into better business decisions and outcomes in your industry. Transform your career future by earning your MS in Data Analytics. WGU’s MSDA program curriculum features IT certifications from Oracle and SAS.  

 
dsexton18Commented:
If you have access to the DHCP server you could give those clients you don't want to have internet access a bogus DNS server.  with out dns they can't go any where.  
0
 
Trygve ThayerAuthor Commented:
Here is what I have attempted but it does not work.  Please help as we have night shift looking at porn and we need to keep them from getting to the internet.

Result of firewall command: "show config"
 
: Saved
: Written by tthayer at 09:47:13.471 EST Mon Feb 16 2009
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password *************** encrypted
passwd **************** encrypted
hostname MIMPIX
domain-name MIM
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
object-group network block-outbound
  network-object 10.0.1.100 255.255.255.255
  network-object 10.0.1.101 255.255.255.255
  network-object 10.0.1.102 255.255.255.255
  network-object 10.0.1.103 255.255.255.255
  network-object 10.0.1.104 255.255.255.255
  network-object 10.0.1.105 255.255.255.255
  network-object 10.0.1.106 255.255.255.255
access-list inside_outbound_nat0_acl permit ip any 172.16.1.0 255.255.255.224
access-list split_tunnel_acl permit ip 10.0.1.0 255.255.255.0 any
access-list inside_access_in permit ip object-group block-outbound 172.16.1.0 255.255.255.0
access-list inside_access_in deny ip object-group block-outbound any
access-list inside_access_in permit ip any any
pager lines 24
icmp permit any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside pppoe
ip address inside 10.0.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool External_VPN_Pool 172.16.1.1-172.16.1.25 mask 255.255.255.0
pdm location 10.0.1.0 255.255.255.0 inside
pdm location 172.16.1.0 255.255.255.0 outside
pdm location 10.0.0.0 255.0.0.0 inside
pdm location 172.16.1.0 255.255.255.0 inside
pdm location 10.0.1.101 255.255.255.255 inside
pdm location 0.0.0.0 255.255.255.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 72.157.10.7 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication serial console LOCAL
aaa authentication ssh console LOCAL
aaa authentication telnet console LOCAL
aaa authorization command LOCAL
http server enable
http 10.0.1.0 255.255.255.0 inside
http 172.16.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
sysopt connection permit-l2tp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client configuration address initiate
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup MIMVPN_User address-pool External_VPN_Pool
vpngroup MIMVPN_User dns-server ***.***.***.*** ***.***.***.***
vpngroup MIMVPN_User default-domain MIM
vpngroup MIMVPN_User split-tunnel split_tunnel_acl
vpngroup MIMVPN_User split-dns MIM.local
vpngroup MIMVPN_User idle-time 1800
vpngroup MIMVPN_User password ********
telnet 10.0.1.0 255.255.255.0 inside
telnet 172.16.1.0 255.255.255.0 inside
telnet timeout 5
ssh 10.0.1.0 255.255.255.0 inside
ssh 172.16.1.0 255.255.255.0 inside
ssh timeout 5
management-access inside
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname *********@bellsouth.net
vpdn group pppoe_group ppp authentication mschap
vpdn username mimworks@bellsouth.net password ********
dhcpd dns ***.***.***.*** ***.***.***.***
dhcpd domain MIM
username tthayer password **************** encrypted privilege 15
username admin password **************** encrypted privilege 15
username Administrator password **************** encrypted privilege 15
username chiggins password **************** encrypted privilege 15
privilege show level 0 command version
privilege show level 0 command curpriv
privilege show level 3 command pdm
privilege show level 3 command blocks
privilege show level 3 command ssh
privilege configure level 3 command who
privilege show level 3 command isakmp
privilege show level 3 command ipsec
privilege show level 3 command vpdn
privilege show level 3 command local-host
privilege show level 3 command interface
privilege show level 3 command ip
privilege configure level 3 command ping
privilege show level 3 command uauth
privilege configure level 5 mode enable command configure
privilege show level 5 command running-config
privilege show level 5 command privilege
privilege show level 5 command clock
privilege show level 5 command ntp
privilege show level 5 mode configure command logging
privilege show level 5 command fragment
terminal width 80
Cryptochecksum:****************************
0
 
JFrederick29Commented:
Access-list isn't applied.

conf t
access-group inside_access_in in interface inside
0
 
Trygve ThayerAuthor Commented:
Thanks it worked
0

Featured Post

Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now