We help IT Professionals succeed at work.

point to point T1 setup

Medium Priority
261 Views
Last Modified: 2012-05-06
I have a point-to-point T1 set up between two buildings. I have a netvanta 3205 and a netvanta 1224R at each end. I want to route one main default subnet across the T1 between our shop and our warehouse.

1. I am looking for either a step-by-step, or tutorial/ recipe to guide me through the setup.
2. I set them both up for bridging as per the below but
  a. how I can I tell they are bridging other than green WAN lights
  b. will bridging transparently pass packets
3. is there something I must do on our default in-house firewall/router to interact with the the T1 or the netvanta that is on the side of the point-to-point adjacent to the firewall/router?

So far, I have http'd and consoled in to each netvanta. I also confg'd terminal as per below: Embarq says they are running B8ZS coding and ESF framing on the T1. The T1 is intended for data only.

Here's what I have done:

http://www.interlinkweb.com/blog/post.aspx?id=301

I have an attachment; I can xonsole into either machine and have them side by side at the moment. Thanks for any thorough step-by-step document and any list of tests to verify it works;).
NetVanta-Series-T1-FT1-DSX-1-NIM.pdf
Comment
Watch Question

Commented:
I am at a loss as to why you are configuring a point-to-point between to sites using bridging.  A better way, and one that will help with troubleshooting in the future is to use PPP on the WAN.  A config is attached that will do all of the magic.  You will just have to adjust the LAN addresses in the template.
ROUTER 1 (HOST)
 
 
Router>config t
Router#
!
interface t1 1/1
  tdm-group 1 timeslots 1-24 speed 64
  clock source internal
  no shutdown
!
!
interface eth 0/1
  ip address  192.168.1.1  255.255.255.0 
  no shutdown
!
!
interface ppp 1
  description Host Site
  ip address  10.10.20.1  255.255.255.252 
  no shutdown
  cross-connect 1 t1 1/1 1 ppp 1
!
!
router bgp 65000
 no auto-summary
 no synchronization
 bgp router-id 10.10.20.1
 bgp log-neighbor-changes
 network 0.0.0.0 mask 0.0.0.0
 redistribute static
 redistribute connected 
  neighbor 10.10.20.2
   no default-originate
   soft-reconfiguration inbound
   update-source ppp 1
   remote-as 65000
!
!
ip route 0.0.0.0 0.0.0.0 192.168.1.254
!
======================================
!
ROUTER 2 (REMOTE)
 
Router>config t
Router#
!
interface t1 1/1
  tdm-group 1 timeslots 1-24 speed 64
  clock source line
  no shutdown
!
!
interface eth 0/1
  ip address  192.168.20.1  255.255.255.0 
  no shutdown
!
!
interface ppp 1
  description Remote Site
  ip address  10.10.20.2  255.255.255.252 
  no shutdown
  cross-connect 1 t1 1/1 1 ppp 1
!
!
router bgp 65000
 no auto-summary
 no synchronization
 bgp router-id 10.10.20.2
 bgp log-neighbor-changes
 redistribute connected 
  neighbor 10.10.20.1
   no default-originate
   soft-reconfiguration inbound
   update-source ppp 1
   remote-as 65000
!
! 
 
 
=======================================
 
Firewall
 
Add a route for the remote site in the firewall that would resemble something like:
 
ip route 192.168.20.0 255.255.255.0 192.168.1.1

Open in new window

Commented:
In the above example 192.168.1.254 represents the ip address of your firewall.  You will have to change that as well to whatever it really is.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
I still need to pass local lan packets over the point to point. is there something I need to do on the local lan firewall/router to allow 192.168.1.x packets to pass over the ppp1 (10.10.20.x)? Specifically I'd like to get to the web interface at the remote end (the 3205 netvanta) thannks again!

Commented:
The configuration above already took care of that.  In the bgp section we are redistributing connected routes over the point-to-point in both sides of the link.  In the router, you can do a "show ip route" and you will see all of the networks.  In your firewall, you will need to pass the remote routes to the 192.168.1.1.  Look at the above template again and scroll all the way to the bottom.  
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.