We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

Can't install SP3 on xp due to permission error?

a1techs
a1techs asked
on
Medium Priority
780 Views
Last Modified: 2012-05-06
When I try to install Service pack 3 on my xp machine i get a system error popup displaying "you dont have permission to update windows xp please contact your system admin" Ive already tried running subinacle to fix any registry issues, and tryin different user accounts. Any suggestions would be much appreciated.
screenshot.jpg
Comment
Watch Question

Try to right click it.  Click run as.  And type in the admin and admin password of your machine.  That should do the trick.

Author

Commented:
that was one of the first things i tried and still no luck.......
Sounds like your registry permissions are incorrect.  Have you tried to actually create a new admin account?
Commented:
this microsoft kb has the info that should help
http://support.microsoft.com/kb/888791

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Thanks Orion88 that link led me to the correct answer. I had to change the policy settings to allow the update.exe to change files. THANKS
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.