We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

w2k3 SMTP email problem: 550 Access denied - Invalid HELO name

dbrennecke
dbrennecke asked
on
Medium Priority
5,426 Views
Last Modified: 2013-11-30
Can someone please walk me through this configuration problem? We have a w2k3 server in a data center that is sending out automated emails (from the same @ourdomain.com address as our corporate Exchange 2003 Server). For the most part, we aren't having any issues except for some recipients are bouncing the emails back with a "550 Access denied - Invalid HELO name" error.

I just don't know the proper configuration settings on the virtual SMTP to prevent this from happening. I assume this is what prevents email spoofing, so there is likely something I need to set (and perhaps grant permission on from our Exchange Server?)

Help.. I am lost.




Comment
Watch Question

Expert of the Quarter 2009
Expert of the Year 2009

Commented:
In SMTP Config in IIS manager, right click on the Default SMTP VS and choose Properties. Click on the tab Delivery, then Advanced. In the FQDN change the name to match your reverse DNS and IP address entry. That should not be the same as your Exchange server, it should have its own DNS information.

-M

Author

Commented:
I get the jist of what needs to be done.. but for clarifty...

Exchange IP: 1.2.3.4 which resoves to
"mail.mycompany.com"  with a
Top-level Domain of "mycompany.com"

Data Center IP: 5.6.7.8 which resolves to
"5.6.7.8.static.reverse.ltdomains.com" with a
Top Level Domain of "ltdomains.com"

The Advnaced Delivery setting is:
FQDN: MyMachineName

So I need a bit more help getting this right (sorry to be such a newbie)!

Expert of the Quarter 2009
Expert of the Year 2009
Commented:
Forget about what your Exchange server has, that is irrelevant.

The server in the data centre needs a valid host name pointing to it.

So that could be host.example.net.
Then you need to set in the reverse DNS records (aka PTR records) host.example.net on that server external IP address. You may have a control panel to do that, the company that is providing the connectivity in the data centre may have to do it for you.

Then you set the FQDN to host.example.net - changing it from servername. It is the servername that is causing the initial error, and lack of DNS and reverse DNS will also be causing you email delivery issues. So I am actually covering more than you need.

-M

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Makes sense... I will get with the data center and see what they can assist with. Thanks for the thorough response.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.