We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

Portcls.sys keeps blowing up on a Thinkpad R61

lowplainsdrifter
on
Medium Priority
750 Views
Last Modified: 2013-11-17
Clean install of Windows... ran all of the updates.
Sound in Dev Mgr still not working, so I grabbed the Realtek AC97 drivers from a bunch of different sites.
Every time it tries to install it, portcls.sys blue screens!
Laptop worked fine before - prev hard drive's integrity was in doubt, machine was also infected badly with viruses.
I've gone to Realtek's and Lenovo's site for different drivers - no luck.
Also used Driver Detective - no luck with that, either.
Comment
Watch Question

Can you give me the STOP code and the Paramaters? it should read something like this:
STOP 0x???????? (0x????????, 0x????????, 0x????????, 0x????????) where the Question marks are values.

Author

Commented:
 Sure...

  0X0000007E, 0XC0000005, 0XEDB6A46D, 0XF7B6AA74, 0XF7BCA770

  Also note that I put SP3 on this sytem before attempting the audio driver installation.
 
 I'm pretty sure this is not a "high definition" driver issue...

Author

Commented:
Ooops... my bad..I actually have SP2 on there at the moment.  The other Lenovo I'm working on has SP3.
Microsoft has a solution here: http://support.microsoft.com/kb/330182
Try everything in the article, and let me know if it helps.
Sorry this came in three parts, i wasnt sure how many answers i could get. The laptop is a Levono Thinkpad R61? not an R61e or R61i? Also what is the type and model of the laptop? It is running WIN XP correct?

Author

Commented:
Thanks for your reply postings so far... actually this is an R51 - the stenciling is rubbed away a bit.  Now it is XP Pro Sp3 - I installed SP3 in case there was something in there that could be helpful.
Is it possible for you to tell me if it is just an R51 and not an R51e or i? It would help to know what the type and model is as well. Thanks.

Author

Commented:
Sorry - Just an R51... Type is 2883, 2VU
Try this one first, as it seems to be your best possibility.
I think I found your answer here: http://support.microsoft.com/kb/950616
 Sorry to say this... I ended up just doing another clean install.  What I did, was that immediately after reinstalling, I installed the sound driver - it worked fine, then I did the rest - other drivers, windows updates, etc.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.