[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Can't RDP to Server 2003 Standard

Posted on 2009-02-16
9
Medium Priority
?
905 Views
Last Modified: 2013-11-21
I have a network that runs 2 servers.  Both are Server 2003 Standard.  One is a DC.  The other is a Terminal server running Citrix.  On the Terminal Server, Citrix works, but I cannot RDP to the TS.  I have opened a command line and Telneted localhost 3389, but could not connect.  The only ports I have successfully been able to telnet to are 21 and 80.  I have no firewall service running.  I uninstalled the only known antivirus to eliminate that as a cause.  I cannot see if there is any other installed program that may be blocking virtually all ports.
0
Comment
Question by:zotfarms
9 Comments
 

Author Comment

by:zotfarms
ID: 23655653
Just in the last few minutes, now Citrix does not work either.  I looked at the terminal services manager, and it says that the server is listening for both RDP and Citrix, but neither work.
0
 
LVL 6

Expert Comment

by:meugen
ID: 23656958
have you tried to connect to the server using Program Neighbourhood through TCP 1494 Port?
Do you have any errors in EventViewer? Can u reboot the box and then try to see if you have any errors in EventLog, do you have a Licensing Server in your network?
0
 
LVL 4

Expert Comment

by:sprengy
ID: 23657156
Did it worked before? Did you tried to reboot the server (common issue within W2K3)?
Did you check whether remote administration is still enabled?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:zotfarms
ID: 23661302
I did try to connect with net neighborhood with session reliability turned off, so it should have been going through port 1494.  I tried Winsockfix this morning.  The applet said that there were registry entries that it could not find, but after the reboot it seems to have come up.  It behaved as though there was a firewall blocking all ports last night.  I could telnet to ports 21 and 80 only.  Every other port seemed blocked.  After running Winsockfix, the ports seemed to be open, but I am not convinced that this is what fixed it.  I am concerned that the problem will come back.
0
 
LVL 31

Expert Comment

by:Henrik Johansson
ID: 23664187
Do you get any error when trying to connect?
0
 

Accepted Solution

by:
zotfarms earned 0 total points
ID: 24472824
I am not sure why it stopped working, but it started working on its own and everything has been fine since.
0
 
LVL 31

Expert Comment

by:Henrik Johansson
ID: 24472899
A possibly solution is that the server service has got some extra system resources to play with.

If server service lack on available system resources, it will drop RDP connection without explanation. We have this symptom on some of the file servers and the only solution we've found is to restart the server service (LanManServer) locally on the server.
0
 

Expert Comment

by:Mayhew
ID: 25037791
I had a similar issue with a Windows 2003 server and it turned out to be the video card drivers.  Did you update the video card drivers recently?  If not, try to see if there is a new video card driver update.
0
 

Expert Comment

by:tech-services
ID: 34310790
I would recommend this Microsoft Article.
http://support.microsoft.com/kb/555382

Article ID: 555382 - Last Review: July 31, 2005 - Revision: 1.0
You can not establish a Remote Desktop session to a computer running one of the affected products.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This is my 3rd article on SCCM in recent weeks, the 1st (http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2008/A_4466-A-beginners-guide-to-installing-SCCM2007-on-Windows-2008-R2-Server.html) dealing with installat…
On a regular basis I get questions about slow RDP performance, RDP connection problems, strange errors and even BSOD, remote computers freezing or restarting after initiation of a remote session. In a lot of this cases the quick solutions made b…
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
Whether it be Exchange Server Crash Issues, Dirty Shutdown Errors or Failed to mount error, Stellar Phoenix Mailbox Exchange Recovery has always got your back. With the help of its easy to understand user interface and 3 simple steps recovery proced…

872 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question