We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

ESXi Virtual Guest Machines not able to access the internet or ping gateway

Medium Priority
3,678 Views
Last Modified: 2012-06-27
Just installed ESXi on a HP Proliant server and installed 4 VM guests. I was able to get everything ok and even was able to hook up an iSCSI server with open filer. Everything is working fine except that none of my VM guests can go outside the VMnetwork. they can ping eachother and can ping the host ESXi but cannot ping the gateway.

Here is what I have


1 ESXi on HP Proliant with 2 Nics


1nic VM Network / Management 172.17.6.X/24
2nd iSCSI 172.17.60.0/24 Connects to iSCSI server (OpenFiler)


 have my management laptop on the 172.17.6.X network and I can access the internet just fine. My ESX server can ping outside addresses.
My iSCSI network is connected to a different Vlan on my physical switch wich only those 2 ports can see eachother.


I also have used my external DNS settings inside the VMs and still cannot access the internet.


Any help is greatly appreciated.
Comment
Watch Question

Commented:
Hi

On the vSwitch that has your VM's on it did you create a Virtual machine Port group or did you pick up the VMKernal Port group?

Does that make sense?

Regards
Krystian

Author

Commented:
If you mean when i created the switch i choose a virtual machine port group
Top Expert 2008
Commented:
Check if port security is enabled on the physical switch ports where your vSwitch is connected. Port security is enabled by default on many cisco switches and will prevent VMs from accessing the network.

Lars

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
OK Guys we finally figured it out.

This is what we did to solve the problem.


Since I was already tired of editing the network settings on the host server, I decided to re-install ESXi to make sure that all the changes I had made did not make any conflicts.I moved my existing VMs into my iSCSI datastore.


I reinstalled ESXi on my host computer, and recreated my VMs. I then turned on my Vms and again they were not able to access the gateway therefore no internet.


We then knew that the problem was on our cisco switch and checked the logs on our Cisco Catalyst 500 and it reported that the port where we had our ESXi server plugged in had some problems and it denied access. It appears that the port only allows 1 IP address and that was why my internal Vms were being rejected from obtaining a DHCP request. We had configured the port to be a server port but for some reason the switch was denying requests from my vms and was blocking the access to the gateway. We reconfigured the port to be a router port and that allowed my Vms to obtain a DHCP address fom my dhcp router. Now i am able to go out to the internet on all Vms.


Well I just want to thank everybody that posted. It is great to have so many smart people in this forums that now makes me more confident on implementing a VMWare infrastucture in my workplace.
Thank you so much for your help and I will keep you posted on my deployment of VMware in my production enviroment.


I had the exact same problem for months. I never thought it would be related to a port role. =/
That fixed my problem.

Thanks a lot Experts.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.