• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 8238
  • Last Modified:

Web Service, Unable to Connect to Remote Server

Hi,

I would really appreciate it if someone can assist me with this problem:

I have a Integration Services Project in business Intelligence Studio that uses a Web Service Task to connect to a web service on a different machine. Running the package throws the error

"Microsoft.SqlServer.Dts.Tasks.WebServiceTask.WebserviceTaskException: The Web Service threw an error during method execution. The error is: Unable to connect to the remote server."

- I can browse the web service (.asmx) using Internet Explorer
- In setting up the HTTP connection manager in BI studio I CAN click on the "Test connection" tab successfully.
-I am not using "localhost" as a reference but DNSname/Machine name

Any help would be great thanks.
0
experts555555
Asked:
experts555555
  • 2
  • 2
1 Solution
 
experts555555Author Commented:
Hi,

Thanks, I'd like  to add that after re-creating the SSIS package I get the following error:

SSIS package "AutoUpdatePackage.dtsx" starting.
Error: 0xC002F304 at Call Update Web Service, Web Service Task: An error occurred with the following error message: "Microsoft.SqlServer.Dts.Tasks.WebServiceTask.WebserviceTaskException: The Web Service threw an error during method execution. The error is: The request failed with HTTP status 502: Proxy Error ( The ISA Server denied the specified Uniform Resource Locator (URL).  )..
   at ...

something tells me the server the Web Service is located on is blocking something, but why then can I browse the web service via Internet Explorer?
0
 
experts555555Author Commented:
Hi all,

I found the solution!!!

The Call to the web service / SSIS package is dependent on the browser settings of the machine/server the package is running on.

This is the first time I come across this, it makes sense if you think about it. Before adding proxy settings into Internet explorer i tried adding these  settinginto the HTTP Connection manager, but it didn't work. The only other difference then was the settings of IE which was setup on my local machine, but not on the server I am implementing on.

Hope this makes sense. Hope someone else can benefit from this.
0
 
zrodCommented:
waw
0
 
zrodCommented:
unable to connect to remote server when dragging and dropping a user control in a windows form?
any idea  hw to solve this isuue?
0
 
PedroCGDCommented:
For those interested in the subject, take a look at:
http://pedrocgd.blogspot.com/2009/11/bi-stepbystep-ssis-calling-webservice.html
Regards,
Pedro
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now