We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

Browsing the other PC's returns error in Explorer : Cannot open the Server service

Medium Priority
616 Views
Last Modified: 2013-11-25
Hi,

The setup is,

XP PC connected to Wind 98 and XP machines in workgroup.
All the PC's can browse each other and can also browse the files on the problem XP machine.
The problem XP machine cannot browse any PC's.
Microsoft SP3 loaded.
The Server service and Browser Services are running.
Tried many reboots - to no avail.
PC has fixed ip address.

The Application log has this error.

Event Type: Error
Event Source: PerfNet
Event Category: None
Event ID: 2004
Date:  2009/02/17
Time:  10:32:15 AM
User:  N/A
Computer: LAPTOP1
Description:
Unable to open the Server service. Server performance data will not be returned. Error code returned is in data DWORD 0.
 
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 34 00 00 c0               4..À    


Please help....
Comment
Watch Question

Author

Commented:
Tx, but I already googled this. As mentioned the service  SERVER is running.....

Author

Commented:
Yes I googled that too...

Commented:
Are you using IPversion 6 on this machine? If so, netbios will not be compatible.

Also check these points of interest:

~~Is Netbios over TCP/IP enabled (under TCP/IP properties>>WINS tab.)

~~Is File and printer sharing enabled?
boot the XP machine in safe mode with networking... then try accessing the other machines

Author

Commented:
In safe mode with networking have the same issue. I've also tried going to an earlier restore point - but it reboots and sais that couldn't restore to earlier point - try another. I've tried numerouse ones with the same issue. I've loaded XP SP 3. I've now tried uninstalling all Microsoft updates sicne the exploring issue began about 2 weeks ago but to no avail.

Btw sometimes when trying to explore a particular PC on the network it returns in Explorer "Invalid Function"

Any ideas to solve this mystery...?

Commented:
I think it might be a good idea to run SFC /scannow at the command prompt.

This checks the versions of critical OS files to make sure they are the right versions to work with each other. When running this command, it will ask for your install disk. It takes about 10 minutes.

Author

Commented:
Will run tommorow and let you know....

Author

Commented:
It ran through - didn't ask for CD's - installs copied on HD. Didn't give any errors or even any report at the end. Problem persists.... PLEASEHELP
Yeah, I don't know what else to try. Also, maybe change your title to "Browsing the other PC's returns error in Explorer : Cannot open the Server service" since it's a little misleading when you said that the server service was started.

Author

Commented:
Tx will do...

Commented:
Are either of these machines multihomed, meaning two or more IPs for the machine. If so, your netbios bind may be binding to the wrong network adapter and therefore you may not be able to communicate with the server service, even though it is started.

Author

Commented:
I'm afraid not - only one ip. The machines on the network can browse and copy files to the XP machine, but the XP machine cannot browse the other PC's. I suspect some sort of an update on the machine took place because the machine could previously browse the other machines.
turn off the windows firewall (not disable the service) and try to browse
also did you try fliping the options for netbios (default, netbios over tcpip etc)
do you have the support tools for windows installed on this machine? if yes what does the command "browstat status" show?
if you go to the computer management > show hidden devices > under non-plug and play drivers do you see anything listed with an exclamation?

Author

Commented:
"also did you try fliping the options for netbios (default, netbios over tcpip etc)" Tried this - no luck.
"do you have the support tools for windows installed on this machine? if yes what does the command "browstat status" show?" If not - how can I get them?

Tx

Author

Commented:
"turn off the windows firewall (not disable the service) and try to browse" NO CHANGE
"also did you try fliping the options for netbios (default, netbios over tcpip etc)
do you have the support tools for windows installed on this machine? if yes what does the command "browstat status "show?" DOESN'T RECOGNISE THE COMMAND "browstat status" I installed: support.microsoft.com/kb/838079

"if you go to the computer management > show hidden devices > under non-plug and play drivers do you see anything listed with an exclamation?" SERIAL has an exclamation Mark.

Btw, when restarting the SERVER service get error: Could not stop the server service on Local computer.ERROR 1811:The server is in use and cannot be unloaded. This is the command in the Server service startup:C:\WINDOWS\system32\svchost.exe -k netsvcs
It shows that its stopped even with above error. And restarts fine.

Also: When clicking explore on some PC's returns error in Explorer:"Incorrect Function"

Commented:
Sorry:

Lost track of this post.

1) Check for mallware using your antispyware package:

>>Or you can<<

You can download malwarebytes and check for mallware that may be stopping your server service and hosing up explorer.
http://www.malwarebytes.org/mbam.php

>>Or you can<<

Download Hijackthis:

Then run the program:

Copy and paste the results on this site for analisys.
http://www.hijackthis.de/index.php?langselect=english#anl

+++++++
2) Make sure you are on the latest service pack.

BEWARE:
SP service pack 3 has a problem with many AV products. SP3 has a file in it called fixccs.exe that makes mass edits to the registry. Since these edits are made to the registry some AV products prevent this from happening. FixCCS.exe stands for fix current control set. These are your communications and logon protocols. So, what I have done in the past is disabled my AV products then installed it while it was disabled. If you already have SP3 on this machine, you may be looking at the issues of your AV products denying a full download of SP3. This partial download usually prevents you from having any communications, including getting to the internet even though you can ping a site.

Author

Commented:
tx will try

Author

Commented:
Howeer - how can this be the issue if I've tried already as follows:"In safe mode with networking have the same issue" ?

Please advise....

Commented:
a partical install of service pack 3 could cause a corrupt current control set. within SP3, there is a file that edits your registry with aobut 8800 registry edits, called FixCCS.exe. You might wish to read up on it. Due to editing the registry, many AV products block it. Because the Current control set defines many binding functions, like how netbios binds to a certain NIC, It could cause issues with communications on your client machine. There are many registry edits that are needed to communicate, even if you use safe mode. Safe mode with network support only starts a generic microsoft device driver for the NIC you are using. Same with the monitor driver. Safe mode still relies upon some of those registry settings within the current control set to communicate with.

However, It is my first guess you have some sort of MALLWARE on this machine. To be more specific, it sounds like the conflicker virus.But, it is best to check this computer with an up-to-date Antispyware package. Malwarebyets not only detects and destroys the conflicker virus, it also picks up a whole lot more. This is why I recommended it in leiu of an other AntiSpyware package.

Author

Commented:
tx will run it.

Author

Commented:
Ran Malwarebytes and removed a few issues - Unistalled AVG anti virus and then found that installed xp service pack 3 automatically. But still no solution! Please help.

Commented:
Let's check the services needed for Browsing:

Those would be:

Server Service
Workstation Service
Browser service

All should be started and set to automatic.

Commented:
Tonight, I will go through and see what we have covered and see if I can come up with a solid conclusion for this issue>

Author

Commented:
tx
Commented:
Let's check a couple things:

1) Go to the command prompt and type IPconfig /all:

Let me know what the NODE TYPE is for this computer.

2) Make sure file and print sharing is enabled. Also, on the nic configuration>>>TCP/IP properties>>WINS tab, enable Netbios over TCP/IP.

3) Let see what we have for logon of the following services:

Go to start>>run and type "services.msc"
right click these two services and tell me what they logon as:
server service
performance logs and alerts  (should be local system)

I am not setting at a windows machine right now, so I hope those are right.

4) Now, let's check com plus.

Go to start>>settings>>control pannel>>administrative tools>> component services: and let's see what we have for permissions on the server service.

Expand component services>>computers>>my computer>>system applications>> roles>>server application>>users..... and tell me what users are allowed.




The error you are seeing tells me that performance monitor is having a problem with accessing the server service.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Tx will check but can only do so some time next week

Author

Commented:
C:\Program Files\Support Tools>IPconfig /all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : Laptop
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Mixed
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Wireless Network Connection:

        Media State . . . . . . . . . . . : Media disconnected
        Description . . . . . . . . . . . : Intel(R) PRO/Wireless 3945ABG Networ
k Connection
        Physical Address. . . . . . . . . : 00-19-D2-28-81-67

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Realtek RTL8168/8111 PCI-E Gigabit E
thernet NIC
        Physical Address. . . . . . . . . : 00-16-D3-58-4B-57
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 192.168.0.195
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.0.245
        DNS Servers . . . . . . . . . . . : 192.168.0.245
                                            196.25.1.1

C:\Program Files\Support Tools>

Author

Commented:
1. See Node above: is set to mixed
2. Box as specified
3. server service : logged on as local
performance logs and alerts : was logged on as ntauthority but was stopped . when start it sais it started and stopped as no work to do. Set it now to local but give same message.

Author

Commented:
Server Service
Workstation Service
Browser service

All started as local user

Author

Commented:
Expand component services>>computers>>my computer>>system applications>> roles>>server application>>users..... and tell me what users are allowed.

is set to everyone

Author

Commented:
Please help!
Commented:
OK, lots of little bugs.

1) Is this in a domain? If so, your preferred DNS servers should be your DNS servers.

2) The node type is mixed is defined best here.
http://www.tech-faq.com/netbios-node-type.shtml

3) You have DHCP disabled, This means we are looking at a fixed IP. However, the latest way to contact SMB shares is Netbios over DHCP. (THIS ONLY WORKS IF THE DHCP SERVER IS ALSO A BROWSER). Go into your NIC configuration>>TCP/IP properties>>advanced button>>WINS tab and change all nics to netbios over TCP/IP, and disable LMhost lookup.

4) LMHOST record is a record that holds a manually configured copy of hosts for a LAN in the event you don't have a WINS server. It is not needed if you use netbios broadcasts to populate the browselist. LMHOST records is to WINS as the HOST record is to DNS.

5) the services are running and file/print sharing is enabled. (SO all is well there)

6) If this is NOT a domain level, then we may need to designate a master browser for this network. Otherwise they may compete for the role of master browser.

Author

Commented:
Tx. Its in a workgroup. There are two XP machines and 2 Win98 machines. All has been working fine untill this... Onlythis XP machine cannot explore the others  -the others can explore this PC and the others.

Author

Commented:
How do we setup a Master Browser?

Commented:
First off, let's make sure you are on Netbios over TCP/IP. Netbios over DHCP is the default for an XP workstation. The problem with that is, if your DHCP server, (which you don't have, unless your router is supplying DHCP),  does not hold the browselist.

Go to the NIC configuration>>TCP/IP properties>>Advanced button>>WINS tab

and enable """"NETBIOS OVER TCP/IP""

+++++++++++++++++++++++++++++++++++++++

You actually have TWO issues brewing. The browser service populates a list of computers in my network places, as well as the files and folders. DNS is sometimes used as the path to these files and folders. Here is the problem. You are not able to browse, this is a Netbios problem. Then, you may not have access, this is a DNS issue.

You DO NOT have a DNS server on your LAN, Unless your router is acting as a DNS and DHCP server.

So, this is where it gets tricky. If you ever go to a domain level, your going to want to disable what we are about to enable, right now.
_______________________________________________________
Open up internet explorer and type  your gateway IP address on there. Then, log onto your router with the admin username and password. Most DSL routers have an admin username and password of either.

admin/admin
or
admin/ (blank)

Then, you want to enable DHCP so your router supplies DHCP for your clients within your LAN. So, this means you will be getting a DHCP address from the WAN side and you will dishing out DHCP with the router on your LAN side.
________________________________________________________


Once done changing all of your NICs to enable netbios over TCP/IP and also allowing your router to provide DHCP, then lets see how things interact. If you still have issues, go to the command prompt of the problem child machine and type: NBTSTAT -RR

If that still doesn't work, I can provide the fixes.

Author

Commented:
Tx, but if the router provides DHCP - does that mean I must remove the fixed ip address from each of the machines?
I do believe the router is providing DHCP but not on the range of any of the fixed ip addresses.
What else can we do to fix please?

Commented:
That's the problem with having Netbios over DHCP. When that is elected, it goes out to find a DHCP server. The first one it sees will be the router. So, the client asks for the browselist and the router says, "NO CAN DO", I don't have the browselist.

Author

Commented:
Will make changes...

Author

Commented:
It still doesn't solve the problem!

Commented:
I appologize, I lost track of this:

In a workgroup environment, you will have to designate a Master browser.

If they are not on the same subnet, you will have to create a LMHOST file for each machine, or designate/create a WINS server.
______________________________________________________________________________
I have an article I would like to share with you that explains the domain master browser service. In a workgroup environment, you will have to make registry edits to designate who is the domain master browser. This will prevent them from electing themselves as domain master browser.

This article also explains how the election process works. So, pay close attention to that.

Finally, it also tells you how to route netbios broadcasts. If you are on a different subnet or trying to communicate over a VPN connection or a VLAN, you will need that information as well. I call it the WINS/WAN configuration of the master browser service.

Note: This article was designed for an NT4 server environment. Howerver, the Master browser service is the exact same from the NT4 era to the 2008 server era. The only difference will be one of the registry edits you are going to make:In a 2003 server world, the registry key for the domain master browser is: "Isdomainmaster" This would include XP In the NT4 world, the registry key for the domain master is: "Isdomainmasterbrowser".

http://www.microsoft.com/resources/documentation/windowsnt/4/server/reskit/en-us/net/chptr3.mspx?mfr=true

Author

Commented:
Tx
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.