• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2196
  • Last Modified:

Plug and play seems to be deactivated?

I´m having big trouble with two IBM Thinkpad Laptops. It started out as a blue screen turning upp giving the error message IRQL not_less_or_equal - and then it forces a reboot. Well, since then I´ve restored the computers to factory settings many many times, since it seems to be lika a lottery if the restoration works out or not.

I finally got them up and running, but the problem now is that they are not able to detect plug and play devices. For example when I plug in different kind of USB-devices they do turn up in device manager as a blue warning icon or a question mark - but the system doesnt install it automatically or notify the user about it. How ever I am able to install the devices manually from the device manager.

In the event logs there is an entry where it says: "Plug and Play user interface dialogs have been suppressed in factory mode." with the event ID: 270

I didnt find much useful information on microsofts webpage, but I did find an forum post about a similar problem.

http://www.pcreview.co.uk/forums/thread-100090.php

In that case, the problem was solved by using a microsoft utility: "sysprep.exe" to activate the plug and play function. But when I tried that, the computers stopped working. And suddenly I couldnt boot up the OS at all. But I reckon that this problem has something to do with this error message in the event loggs.

I have also checked that the Plug and Play service is started and running. I also did a "sfc /scannow" without any difference.

Also tried restoring the BIOS to the default settings - and updating to SP3.

Any ideas?
0
andre_st
Asked:
andre_st
  • 2
1 Solution
 
andre_stAuthor Commented:
Perhaps it is usefull for others in a similar situation...but I also tried the following suggestion from a Microsoft MVP (without any difference in my case):

Create a file with NOTEPAD containing the following lines and save it as FIX.REG
-------------------------- cut after this line --------------------------------
REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment]

"DEVMGR_SHOW_NONPRESENT_DEVICES"="1"
-------------------------- cut before this line --------------------------------

Double click on FIX.REG and say yes to the Merge Into Registry question.

Unplug ALL USB devices.
Open Device Manager.
View, Show Hidden Devices.
Uninstall all devices under USB Controllers.
Uninstall all devices under Disk Drives that you know are not present.
Uninstall all devices under Storage Volumes. Say no to any reboot prompts until you are finished. Also, if a Storage Volume doesn't uninstall, ignore it and move to the next one.
If you have a yellow ? with unknown devices, uninstall all of the entries there as well.

When this is done, reboot TWICE.

Reconnect the USB devices and see if they're recognized properly.
0
 
orangutangCommented:
0
 
andre_stAuthor Commented:
Hello "Orangutang"!

And thank you for your reply. The solution provided on the linked page worked perfectly for me!!!

In my case the registry entry was located in a different location:

HKLM\SYSTEM\SETUP\FactoryPreInstallInProgress"=dword:00000001

What I did was that I simply changed the "value" of the entry to "0", instead of "1". Rebooted, and suddenly plug and play works as it is supposed to.

Thanks again!
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now