SBS 2008 WSUS Sync Fails

Posted on 2009-02-17
Last Modified: 2012-05-06
I am doing a new install of SBS 2008 Standard on a newl server. After the install, the SBS Console shows everything as good excepts the Updates. When I launcg the WSUS server and force a manual syncronization, it chugs for a while at 0% and then fails. The error says...
IOEXCEPTION: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.
The SBS 2008 server is connected to a Cisco RV042 firewall. Everything else is working, including RWW, OWA and all outbound HTTP/HTTPS
I found one hits on a Google search that referrred to Stateful Packet Inspection and MTU. I turned SPI and set switched the MTU from Auto to 1500, but it did not make any difference.
Does anyone have any ideas?
Thanks in advance,
Question by:dcadler
    LVL 38

    Accepted Solution

    Your Cisco is probably blocking the attempts to connect to the MSU site. Verify that the rules are set up properly.

    If it has monitoring capabilities, then monitor the connection states while attempting to synchronize WSUS.


    Author Comment


    As a test, I temporarily disabled the firewall on the Cisco RV042 and the WSUS started syncing so I know it has to be a firewall issue. The firewall has a default rule that allows and request from any IP on the LAN side to go to any destination so I have to assume it is not ab outbound issue. I added two access rules for incoming requests on port 80 and 443 coming into the WAN1 port from any IP and going to the SBS server IP on the LAN.

    I tested this and after about 15 mins it is stil sitting on 0% sync.

    Any ideas?


    LVL 38

    Expert Comment

    by:Philip Elder
    I am not familiar with Cisco. You will need to talk to your Cisco contact to get the information on what is happening and how the Cisco is blocking the communication.

    Otherwise, perhaps an E-E Cisco expert may have the answer.


    Author Closing Comment

    You pointed to the firewall which led me to do further testing. I ended up updating the RV042 firmware to the latest release,, and everything started working.

    Thanks for your help

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Join & Write a Comment

    If you are a user of the discontinued Microsoft Office Accounting 2008 (MSOA) and have to move to a new computer running Windows 8, you will be unhappy to discover that it won't install.  In particular, Microsoft SQL Server 2005 Express Edition (SSE…
    A quick step-by-step overview of installing and configuring Carbonite Server Backup.
    This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
    This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

    746 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    16 Experts available now in Live!

    Get 1:1 Help Now